Wilkommen

Password Safe

Über wie viele Passwörter und Benutzernamen müssen Sie die Übersicht behalten? Entweder ist die Antwort eins oder hunderte. Password Safe erlaubt Ihnen eine verschlüsselte Liste Ihrer Passwörter sicher und einfach zu realisieren. Ein einziges Master-Passwort entsichert sie alle für Ihre Verwendung.

Sicherheit fängt beim Benutzer an. Das Aufbewahren von Passwortlisten, die entweder auf Papier geschrieben oder in einem Textdokument auf der Benutzeroberfläche (Bildschirm) zu sehen sind, ist unsicher. Es kann einfach von neugierigen Blicken (sowohl Cyberbasiert als auch menschlich) eingesehen werden. Das ständige Verwenden desselben Passwortes in einem großen Bereich von Systemen und Internetseiten führt zu einem Alptraum, wenn jemand das Passwort herausgefunden hat. 'Die' haben dann alle Ihre Passwörter und haben damit Zugriff auf sämtliche Teile Ihres Lebens (System, Email, Verkauf, Finanzen, Arbeit, ...).

Password Safe gestattet Ihnen die Verwaltung der alten Passwörter und bietet ebenso eine schnelle wie einfache Methode neue zu erstellen, abzuspeichern, zu organisieren und abzufragen. Sie können komplizierte neue Passwörter verwenden, die Sie mit den selbstbestimmten Passwortrichtlinien erzeugen. Einmal abgespeichert, sind Benutzername und Passwort mit ein paar Klicks da.

Mit Password Safe können Sie Ihre Passwörter mit eigenen Verweisen selber anpassen — zum Beispiel, nach Benutzer ID, Kategorie, Internetseite oder Standort. Sie können wählen, ob Sie alle Ihre Passwörter in einer einzigen Datenbank ablegen, oder ob Sie für unterschiedliche Zwecke verschiedene Datenbanken verwenden (zum Beispiel eine für Arbeit und eine für Zuhause). Und mit der intuitiven Schnittstelle sind Sie innerhalb von ein paar Minuten voll dabei.


Über Password Safe

Password Safe und der verwendete Twofish Verschlüsselungsalgorithmus wurden ursprünglich von Bruce Schneier und Counterpane Labs entwickelt und für die Allgemeinheit freigegeben.

Password Safe ist jetzt ein "Open Source" Projekt beheimatet auf sourceforge.net. Die neuesten Programmupdates, Dokumentation und Neuigkeiten finden sich auf http://pwsafe.org.

Password Safe ist frei verfügbar und kann, mit den im Standard Open Source Initiative (OSI) "Artistic License 2.0." beschriebenen Einschränkungen, verteilt werden. Eine Kopie dieser Lizenz befindet sich im Installationspaket Password Safe mit dem Namen LICENSE.

Twofish ist eine schnelle aber freie Alternative zu den AES, DES und IDEA Verschlüsselungsalgorithmen. Details zum Twofish Algorithmus, dazugehörige Geschwindigkeitsvergleiche sowie eine ausführliche Liste von Produkte sind verfügbar unter http://www.schneier.com/twofish.html.

Für Informationen über die letzten Änderungen, Verbesserungen und Ergänzungen in der Dokumentation lesen Sie bitte die Dateien readme.txt, changelog.txt und releasenotes.txt im Installationspaket.

Alle andere Markenbezeichnungen oder Produktnamen sind Markenzeichen von den jeweiligen Unternehmen. Es besteht keine Unterstützung oder weitere Bereitstellung seitens dieser Unternehmen, und ist auch nicht vorgesehen.


Password Safe und YubiKey

YubiKey ist ein innovatives Authentifizierungsgerät in Hardware eingebettet, entwickelt und vertrieben von Yubico. Für den Anwender, sieht es aus wie ein kleine, dünne USB-Adapter mit einer Taste. In Password Safe funktioniert es wie ein Authentifizierungs Token, der eine große hardwaremäßige Sicherheit dartsellt für die Datenbank. YubiKey

YubiKey beschaffen

Zum Anfangen braucht man zuerst mal ein YubiKey Gerät. Diese können online hier beschafft werden. Achten sie darauf dass Password Safe im YubiKey eine Firmwareversion von mindestens 2.2 voraussetzt.

Konfiguration des YubiKey

Der YubiKey muss richtig konfiguriert werden, um den Betrieb mit Password Safe zu gewährleisten. Dies kann gemacht werden im Verwalten->Yubikey... Dialogfenster, wie beschrieben im Menu Verwalten.
Wenn Sie schon ein YubiKey haben, achten Sie darauf dass Password Safe Slot 2 für die Authentifizierung verwendet, und dabei Slot 1 für andere Anwendungen frei lässt.

Verwendung von YubiKey

Einaml konfiguriert, können Sie es einsetzen um zusammen mit dem Master-Passwort die Password Safe Datenbank zu schützen, wie beschrieben in Neue Datenbank erstellen.


Neue Datenbank erstellen und öffnen

Password Safe ermöglicht dem Benutzer alle Passwörter in einem einzigen "Safe" (Passwortdatenbank) abzuspeichern, oder mehrere Datenbanken für unterschiedliche Zwecke anzulegen (z.B. eine für die Arbeit, eine für den persönlichen Gebrauch). Jede Datenbank ist unabhängig, kann verschoben werden und läuft auf den verschiedensten Systemen, solange dieselbe Version von Password Safe verwendet wird. Die Datenbanken sind verschlüsselt mit einem Schlüssel, der vom Master-Passwort abgeleitet ist (das Master-Passwort selber hingegen ist nicht in der Datenbank enthalten, in welche Form auch immer).

Wenn Sie Password Safe zum ersten Mal einsetzen, drücken Sie das Symbol "Neue Datenbank erstellen". Sie werden aufgefordert, Name und Speicherort der Datenbank festzulegen (standardmäßig wird "pwsafe.psafe3" vorgeschlagen). Dann müssen Sie noch das Master-Passwort angeben, womit der Inhalt der Datenbank verschlüsselt und "abgesperrt" wird.

Bevor Sie beginnen

Password Safe arbeitet hart daran um sicherzustellen dass die Passwortinformationen sachgemäß abgespeichert werden. Trotzdem kann Password Safe nichts gegen physikalische Schaden oder Verlust der Festplatte tun, sowohl im PC als auch im Laptop. Darum enpfehlen regelmäßig Kopien anzufertigen von der Passwortdatenbank 'off-line', d.h auf einem anderen PC oder Festplatte. Dies können Sie entweder händisch machen, oder mit einem Cloud Speicherdienst wie DropBox, SugarSync oder JungleDisk, um nur ein paar zu nennen.

Ebenfalls ein Überlegung wert wäre es Maßnahmen zu treffen für den Zugriff auf Ihre Datenbanken, sei es für Verwandte oder Mitarbeiter, im Falle Sie nicht mehr weitermachen können. Vom Konzept her hat Password Safe von Haus aus kein 'Hintertürchen' oder 'Passwortwiederherstellung'. Das bedeutet dass Sie selbst dafür verantwortlich sind anderen Zugang zu Ihrem Master-Passwort zu geben und zu gewährleisten. Dies kann einfach in einem geschlossenen Umschlag geschehen, vielleicht sogar im Tresor. Es wäre auch möglich einzelne Teile des Master-Passwortes aufzuteilen auf mehrere Personen.

Neue Datenbank erstellen

Es gibt zwei Möglichkeiten eine neue Datenbank zu erstellen. Durch Klicken auf Neue Datenbank im Eingabe des Master-Passwortes Dialog beim Start der Anwendung, oder mit Menü Datei->Neu, wenn Password Safe geöffnet ist. Beide Methoden rufen dann den Dialog Einstellung Master-Passwort auf.

Hinweis: Standardmäßig wird Password Safe die zuletzt benutzte Datenbank vorschlagen und zur Eingabe des Master-Passwortes auffordern. Wenn Sie mehrere Datenbanken verwenden, können Sie eine Auswahl aus der Liste treffen. Sie können auch den Pfad der Datenbank händisch eingeben, oder sogar eine Datei auswählen im Dialog "Datei" indem Sie die Taste ("...") drücken. Wenn bereits eine Datenbank geöffnet ist, können Sie mit Datei->Öffnen oder mit dem Symbol Andere Datenbank öffnen auf eine andere Datenbank umschalten.

Fenster beim Start

Abfrage des Passwortes einer neuen Datenbank

Virtuelle Tastatur

Um ein Master-Passwort sicher zu gestalten, können auch Zeichen (z.B. von einer Deutschen Tastatur) wie ä, ö oder ähnliche verwendet werden. Zur Eingabe der Zeichen dieses Master-Passwortes an einer fremden Tastatur, kann eine virtuelle Tastatur benutzt werden. Diese Tastatur bildet die fremden Tastatur nach, mit allen da vorhandenen Zeichen. Die virtuelle Tastatur kann durch Drücken des Symboles Symbol virtuelle Tastatur aufgerufen werden. Fremdwörtliche Zeichen, die an der eigenen physischen Tastatur nicht eingegeben werden könnten, können somit eingegeben werden, um so das gewünschte "richtige" Master-Passwort zu bilden. Auch Teile eines Master-Passwortes können mit der virtuellen Tastatur gestaltet werden.

Eingabe des Master-Passwortes mit einer virtuellen tastatur


Arbeiten mit gespeicherte Passwörter

Password Safe stellt etliche Mechanismen zur Verfügung, um mit Namen und Passwörtern umzugehen. Meistens soll der Benutzername oder das Passwort in die Zwischenablage kopiert werden, um dann diese Information in das verlangte Eingabefeld einzufügen. Password Safe besitzt die Funktion -Autom. Eingabe-, um die Eingabe von Benutzername und Passwort in einem WEB-Formular zu automatisieren.

  1. Password Safe öffnen
  2. Wählen Sie Benutzername und Passwort, die Sie benutzen wollen aus
    Benutzername:
  • Wählen Sie das Symbol für Benutzername in der Toolleiste aus
    oder
  • Rechter Mausklick und wählen Sie Benutzername in die Zwischenablage kopieren aus
    oder
  • Geben Sie Strg + U ein
    um dann mit Einfügen (paste) den Benutzernamen in das gewünschte Feld abzulegen.
    Passwort:
  • Wählen Sie das Symbol für Passwort in der Toolleiste aus
    oder
  • Rechter Mausklick und wählen Sie Passwort in die Zwischenablage kopieren aus
    oder
  • Doppel-Klicken Sie auf das ausgewählte Feld
    oder
  • Gib Strg + C ein
    um dann mit Einfügen (paste) das Passwort in das gewünschte Feld abzulegen.
Bemerkung: Benutzername und Passwort können auch kopiert werden mit den Mitteln die im Menü Bearbeiten zur Verfügung stehen, aber um ehrlich zu sein, wären das dann zu viele Klicks.


Suchen

Einen bestimmten Text suchen

Password Safe erlaubt es nach Einträgen zu suchen, die einen vorgegebenen Text enthalten. Dies ist dann nützlich, wenn Sie sich am Namen des Eintrages nicht mehr genau erinnern, aber noch gut wissen, was "drin" steht, z.B. der Eintrag mit Maria in den Notizen.

Um eine geöffnete Datenbank zu durchsuchen, drücken Sie Strg-F (oder Bearbeiten->Eintrag Suchen). Es erscheint eine Suchleiste über die Statusleiste am unteren Ende der Anwendung so ähnlich wie folgt:

Die einfachste Methode ist es, einfach der Text wonach Sie suchen einzugeben und die Enter-Taste zu drücken, oder auf das Symbol des Vergrößerungsglases auf der rechten Seite des Textfeldes zu klicken. Die Anzahl der Treffer (wenn überhaupt) wird am rechten Ende der Suchleiste angegeben. Der erste Text, der übereinstimmt, wird ausgewählt und hervorgehoben. Das mehrmalige Drücken der Enter-Taste (oder Klicken des Vergrößerungsglases) führt zum nächsten übereinstimmenden Text. Wenn alle Einträge ausgewählt wurden, fängt das Spiel von vorne wieder an.

Die Taste F3 wiederholt das Suchen. Durch wiederholtes Drücken von F3 kann der Eintrag mit dem gewünschten Kriterien leicht erreicht werden. Durch Drücken der Umschalt-Taste kann rückwärts gesucht werden. Wenn sie mit dem Vergrößerungsglas arbeiten, wird die Umschalt-Taste ebenfalls die Suchrichtung umdrehen.

  • Um die Suchleiste zu schließen, klicken Sie auf das 'x' an der linken Seite des Textes, oder drücken Sie noch mal Strg-F.
  • Standardmäßig läuft die Suche ohne Groß/Kleinschreibung. Um mit Groß/Kleinschreibung zu suchen, drücken Sie das "AA"-Symbol. Dieses Symbol ändert sich dann in "Aa".
  • Um eine erweiterte Suche zu machen, wie z.B. das Einschränken auf bestimmte Felder oder Einträge usw., drücken Sie das Symbol "...".
  • Um ein Report der letzten Suche zu erstellen, drücken sie create search report .
  • Um den Suchtext zu löschen, klicken Sie auf das "Löschen"-Symbol.


Upgraden einer älteren Version von Password Safe

Um neue Merkmale zu unterstützen und die Sicherheit zu erhöhen, wurde die Datenbank für die gespeicherten Informationen und Einstellungen zwischen zwei Versionen geändert. Es wurde aber größte Sorgfalt aufgebracht, um ein automatisches und transparentes Upgraden zu ermöglichen:
  • Version 1.x von Password Safe kann nur Datenbanken lesen die von Version 1.x generiert wurden.
  • Version 2.x von Password Safe kann Datenbanken lesen die aus den Versionen 1.x und 2.x stammen.
  • Version 3.x von Password Safe kann Datenbanken lesen die aus allen vorherigen Versionen stammen.
Um die Datenbank einer früheren Version von Password Safe zu öffnen, sollten Sie sie auf jeden Fall so öffnen wie jede andere Datenbank auch. Die Einträge werden angezeigt wie immer, mit möglicherweise "unbekannten" Werten in Feldern, die in den früheren Versionen nicht unterstützt wurden (z.B. das Erstellungsdatum eines Eintrages).
Wenn Sie eine Datenbank aus einer früheren Version abspeichern, werden Sie gewarnt über die Tatsache dass die neue (abgespeicherte) Datenbank von früheren Versionen von Password Safe nicht mehr geöffnet werden kann.

Frühere Versionen der Datenbank generieren

Durch gezieltes Exportieren im gewünschten Format können Sie Versionen der Datenbanken erstellen die von älteren Password Safe Versionen gelesen werden können (Datei->Exportiere zu und wählen Sie V1.x Format... oder V2 Format... aus). Beachten Sie dass in der exportierten Datenbank keine Informationen enthalten sind die in neueren Versionen hinzugekommen sind. Zum Beispiel, eine Version 2 der Datenbank wird keine Informationen über Änderungszeitpunkte der Einträge enthalten.


Ein Wort über Master-Passwörter

Eine der wichtigsten Schlüssel für Ihre Sicherheit ist die Wahl eines starken Master-Passwortes für Ihre Password Safe Datenbank. Die Datenbank ("Safe") enthält alle Ihre Benutzernamen, Passwörter und sämtliche zusätzliche Informationen die Sie eingefügt haben. Den Namen der Geliebten, ein Geburtstag oder irgendeine andere Kombination die einfach zu erraten ist, hinterlässt Daten, die leicht zu knacken sind. Es ist wichtig ein Master-Passwort zu wählen, das schwer zu erraten ist, aber genauso wichtig ist es, eins zu wählen, woran sie sich leicht erinnern können.

Password Safe hat eine eingebaute Prüfung auf vermeintlich schwache Passwörter. Im Allgemeinen sollte ein Master-Passwort (wie jedes andere Passwort auch) aus einem Mix aus Buchstaben und mindestens einer Ziffer oder Speziellen Zeichen (wie diese über die Ziffern an der Tastatur). Wenn das Programm ein eingegebenes Master-Passwort als schwach einstuft, wird eine Bestätigung angefordert. Sie haben dann die Wahl das original eingegebene (schwache) Master-Passwort anzunehmen, oder ein Neues einzugeben.

Um das Master-Passwort zu ändern, siehe Ändern des Master-Passwortes.

Bemerkung: Es besteht keine Möglichkeit in Password Safe verlorene oder vergessene Passwörter wieder aufzufinden.
Dies wurde im Konzept bewusst so entschieden, weil jede Art der Passwortwiederherzustellung auch eine Sicherheitslücke darstellt.


Benutzernamen, Passwörter und Gruppen: Basis

Die Verwaltung von Benutzernamen, Passwörter und Gruppen, zusammen mit den dazugehörigen Parametern, erfolgt über mehrere Reiter:

  • Basis: alle notwendigen Angaben für die Passwordverwaltung
  • Zusätzlich: weitere Angaben, inklusive Historie
  • Datum und Uhrzeit: Ablaufzeiten und Statistiken
  • Passwortrichtlinie: Abweichungen vom Standard

Die meisten Eingabefelder im Basis- und den zusätzlichen Reiter, sind soganannte Smarte Felder. Dies bedeutet dass, wenn man sie anklickt, der aktuelle Inhalt dieses Feldes in die Zwischenablage kopiert wird. Der Hintergrund des Feldes leuchtet grün auf, um anzudeuten dass es kopiert wurde. Zur Zeit werden folgende Felder unterstützt:

  • Basis
    • Gruppe
    • Titel
    • Anwendername
    • Passwort
    • Notizen
    • URL
    • E-Mail
  • Zusätzlich
    • Autom. Eingabe
    • Ausführen

      • Hinweis: Wenn Sie die Strg-Taste gedrückt halten, während sie die Tasten Autom. Eingabe oder Ausführen anklicken, werden keine Variablen umgesetzt bevor sie in die Zwischenablage kopiert werden.

Reiter Basis

Die wichtigsten Elemente sind in diesem Reiter zusammengefasst.

Eintrag bearbeiten: Basis

Folgende Informationselemente gehören zu jedem Passworteintrag:

  • Gruppe: ein Name zum Zusammenfassen aller artverwandten Einträge
  • Titel: ein 'freundlicher' Name für den Passworteintrag
  • Benutzername: der eigentliche Benutzername
  • Passwort: das dazugehörige Passwort
  • Notizen: allgemeine Notizen zu diesem Eintrag
Nur das Titel- und das Passwortfeld sind Pflichtfelder. Alle anderen sind optional.

In diesem Reiter kann auch die URL eingestellt werden:

  • URL: Die URL die sich auf diesen Eintrag bezieht. Wenn dieses Feld nicht leer ist, dann ist die "Los" Taste aktiviert. Wenn kein Protokoll angegeben ist, wird "http://" angenommen (z.B. "www.foo.net" ist gleich mit "http://www.foo.net").Vorausgesetzt das Feld URL ist nicht leer, bewirkt ein Drücken der Taste Los dass der Browser zu der eingegebenen Adresse geht. Wenn Sie die Taste Los zusammen mit der Strg Taste drücken, wird nach dem Öffnen des Browsers auch die Autom.Eingabe ausgeführt. Der nachstehende Hinweis beschreibt die Funktionsweise in allen Einzelheiten.
  • Email: Die Email-Adresse die sich auf diesen Eintrag bezieht. Wenn dieses Feld nicht leer ist, dann ist die "Senden" Taste aktiviert. Wenn sie diese Taste drücken, wird die standardmäßige Email-Anwendung geöffnet; im "An:"-Feld wird die Email-Adresse dieses Eintrages vorbelegt. Der nachstehende Hinweis beschreibt die Funktionsweise in allen Einzelheiten.
    Die nachfolgenden Hinweise beschreiben das Verhalten der URL-Eingabe genauer:
  • Standardmäßig wird Password Safe den Browser verwenden, welchen Ihr PC in der Regel zum öffnen von Internetseiten hernimmt. Wenn erwünscht, können Sie einen alternativen Browser angeben durch Angabe von '[alt]' in eckigen Klammern vor der URL, z.B. "[alt]http://www.foo.net". Dies ist nützlich, wenn der Standardbrowser Firefox ist, und Sie wünschen aber auf eine Seite zuzugreifen, die am besten mit dem Internet Explorer funktioniert. Den alternativen Browser können Sie konfigurieren im Dialogfenster Verwalten->Optionen->Verschiedenes.
  • Wenn '{alt}' in geschweiften Klammern vor der URL gesetzt wird, dann wird es 'wie-es-ist' dem alternativen Browser übergeben, ohne dass 'http://' hinzugefügt wird, wenn kein Protokoll definiert ist. Die ist dann sinnvoll, wenn der alternative Browser eine Anwendung mit Fernzugriff ist, z.B. ein SSH Client. [ssh] würde denselben Effekt haben.
  • Wenn '[autotype]' vor der URL steht, wird Password Safe nach der Anzeige und Aktivierung des Browsers die Funktion Autom.Eingabe ausführen. Wenn im Feld Autom.Eingabe nichts eingegeben ist, wird der standardmäßige Wert eingesetzt.
    Die Email-Adresse entspricht den Standardregeln nach RFC 2368:
  • Sie können im Feld Email eine oder mehrere Email-Adressen hinterlegen, mit ';' getrennt. Sie sollten Internet-sichere Zeichen verwenden. Für das Leer-Zeichen sollte ein %20 verwendet werden.
  • Der Email-Adresse können einige Name-Wert Pärchen angehängt werden. Dem ersten Paar soll das Zeichen '?' vorgesetzt werden, bei allen anderen muss ein '&' vorgesetzt werden.
    • subject - gefolgt von Text der im "Betreff" stehen soll.
    • body - gefolgt von Text der in der Email selber stehen soll.
    • CC - gefolgt von Adresse(n) die im "CC" (Carbon Copy) stehen sollen.
    • BCC - gefolgt von Adresse(n) die im "BCC" (Blind Carbon Copy) stehen sollen.
    Beispiel: benutzer@beispiel.com?subject=Hinweis Titel&body=Inhalt&CC=empfaenger@ziel.de

Erstellen eines neuen Eintrag mit Benutzername und Passwort

  1. Die Datenbank öffnen wo der neue Eintrag eingefügt werden soll
  2. Wählen Sie im Menü Bearbeiten > Eintrag einfügen aus
  3. Geben Sie die notwendige Information im Dialogfenster Eintrag Einfügen ein
Hinweis: Wenn ein Gruppenname ausgewählt ist, und dann eine neuer Eintrag eingefügt wird, wird für diesen Eintrag der Gruppenname im Dialogfenster Füge Eintrag ein vorbelegt. Wenn ein neuer Name im Gruppenfeld eingegeben wird, wird diese Gruppe neu erstellt.

Passwörter generieren und bearbeiten

Wenn gewünscht, können ein eigenes Passwort händisch im Passwortfeld eingegeben werden, oder Password Safe generiert eine neues Passwort auf Basis der derzeitig gültige Passwortrichtlinien.

  1. Im Dialogfenster Eintrag Einfügen die Taste Generierung klicken
  2. Wenn Sie nicht zufrieden sind mit dem Ergebnis, klicken Sie erneut Generierung, oder geben Sie das Passwort händisch ein.
Hinweis: Wenn Sie ein "single sign-on" System einsetzen das erlaubt dasselbe Passwort für verschiedene Maschinen/Server/Anwendungen usw. gleichzeitig einzusetzen, kann mit Password Safe so ein Eintrag entsprechend verwaltet werden. Wenn Sie ein Passwort ändern, werden alle anderen gleichverwandte Passwörter mit geändert. Diese werden "Alias" Einträge genannt, und wird im Detail hier beschrieben.

Bestehende Einträge bearbeiten

  1. Wählen Sie den Passworteintrag zum Bearbeiten in der Liste aus
  2. Wählen Sie Eintrag bearbeiten im Bearbeiten Menü aus
Hinweis: Standardmäßig werden Passwörter ausgeblendet. Um das Passwort zum Eintrag zu sehen, drücken Sie Anzeigen.

Neue Gruppe einfügen

  1. Wählen Sie Gruppe einfügen im Menü Bearbeiten aus
  2. Geben Sie den Gruppenname ein

Gruppenname bearbeiten

  • Rechtsklick auf die Gruppe und wählen Sie Gruppe umbenennen aus der Liste aus
Hinweis:
  1. Gruppennamen können verschachtelt werden, durch Setzen eines Gruppennamens in einer anderen Gruppe.
  2. Gruppen bestehen nicht fü sich selbst. Sie bestehen nur als Wirt eines Eintrages oder einer anderen Gruppe. Darum wird eine leere (d.h. ohne Eintrag und ohne Untergruppe) Gruppe verschwinden wenn sie gesichert wird in die Datenbank. Die einfachste Möglichkeit um sicherzustellen dass eine neue Gruppe bestehen bleibt, ist ein neuer Eintrag zu machen und die neue Gruppe im Gruppenfeld einzugeben (Gruppen werden dabei mit einem '.' getrennt).

Geschützte Einträge

Wenn ein Eintrag geschützt ist, sind Sie nicht in der Lage irgendein Feld zu verändern. Erst nachdem der Schutz weggenommen ist, sind wieder Änderungen möglich. Geschützte Einträge sind Rot gekennzeichnet (unten links).

Edit/View Entry


Benutzernamen, Passwörter und Gruppen: Zusätzlich

Die Verwaltung von Benutzernamen, Passwörter und Gruppen, zusammen mit den dazugehörigen Parametern, erfolgt über mehrere Reiter:

  • Basis: alle notwendigen Angaben für die Passwordverwaltung
  • Zusätzlich: weitere Angaben, inklusive Historie
  • Datum und Uhrzeit: Ablaufzeiten und Statistiken
  • Passwortrichtlinie: Abweichungen vom Standard

Reiter Zusätzlich

Eintrag bearbeiten: Zusätzlich
  • Autom. Eingabe: Wenn dieses Feld nicht leer ist, wird dessen Inhalt den standardmäßigen Inhalt für das 'automatische Eingeben' ersetzen (dies wird oben angezeigt, und stammt entweder vom Password Safe Standard oder vom Wert in der Datenbank der mit "Verwaltung → Optionen → Verschiedenes" angegeben wurde). Für mehr Information, siehe Hilfe zu "Autom. Eingabe".

  • Ausführen: Wenn dieses Feld nicht leer ist, wird dessen Inhalt bei der Aktion 'Ausführen' als Kommando dem Betriebssystem übergeben. Es können Variablen wie Anwendername, Passwort, usw. mit übergeben werden. Für mehr Information, siehe Hilfe zu "Ausführen".

  • Doppelklick-Aktion und Shift Doppelklick-Aktion :
    • Dies erlaubt es festzulegen welche Aktion Password Safe ausführt, wenn Sie ein Doppelklick bzw. Shift-Doppelklick auf diesem Eintrag ausführen. Standardmäßig wird Kopiere Passwort für Doppelklick , und Kopiere Benutzername für Shift-Doppelklick vorbelegt. Die standardmäßigen Aktionen werden im Dialog Verwalten → Optionen → Verschiedenes festgelegt.

  • Passworthistorie: Es ist möglich Password Safe so zu konfigurieren, dass es sich die letzten paar Passwörter eines Eintrages merkt. Dies kann eingestellt werden beim Erstellen des Eintrages, oder später wenn Sie diesen Eintrag bearbeiten. Die jüngsten Passwörter eines Eintrages werden angezeigt. Die Anzahl der Passwörter die sich Password Safe merkt, kann eingestellt werden. Eine genauere Erklärung zur Passworthistorie finden Sie hier.

  • Tastaturkürzel: Tastaturkürzel können einen Eintrag zugeordnet werden, und erlauben so die direkte Auswahl eines Eintrages, unabhängig von der momentanen Anzeige im Fenster, nur mit den entsprechen Tastaturkürzel.

    Zusätzliche Hinweise zu Tastaturkürzel für Einträge:
    • Tastaturkürzel für Einträge werden aggespeichert als Teil des Datenbanksatzes zum Eintrag. Allerdings sind in Password Safe auch schon Schnelltasten für verschiedene Menüpunkte hinterlegt. Der Gültigkeitsbereich dieser Menü-Schnelltasten erstreckt sich über alle Datenbanken die ein Anwender auf einem PC geöffnet hat. Diese Menü-Schnelltasten können vom Anwender angepasst werden (Verwalten → Optionen, Schnelltasten). Sie können sich auch unterscheiden, abhängig von der ausgewählten Anwendungssprache z.B. Englisch, Deutsch, usw.
    • Darum tritt, obwohl eine Warnung ausgegeben wird wenn ein Tastaturkürzel ausgewählt wird das schon einem Menüpunkt zugeordnet wurde, kein Konflikt auf wenn Sie später die Menü-Schnelltaste anpassen, oder die Anwendungssprache wechseln. Gleichermaßen könnte ein Tastaturkürzel (noch) unbelegt sein, wenn es einem Eintrag zugewiesen wird, und später zu einem Konflikt führen wenn eine Menü-Schnelltaste definiert wird, oder die Anwendungssprache geändert wird.
    • Weil Tastaturkürzel zu einem Eintrag keine Änderungen in die Datenbank vornehmen können -anders als ein Menüpunkt-Schnelltaste, z.B. zum Löschen eines Eintrages- haben diese als Sicherheitsmaßnahme Vorrang vor Menüpunkt-Schnelltasten.
    • Tastaturkürzel zu einem Eintrag müssen entweder die Alt- oder Strg-Taste (mit oder ohne Shift-Taste) enthalten. Wenn eine der beiden bei der Eingabe nicht dabei ist, werden alle Kombinationen von Alt, Strg und Shift in dieser Reihenfolge (Alt; Alt+Shift; Strg; Strg+Shift, Alt+Strg; Alt+Strg+Shift) ausprobiert, bis eine einzigartige Kombination gefunden wurde. Zum Beispiel, wenn der Anwender "Shift + 6" auswählt, könnte das Tastaturkürzel zu "Alt + Shift + 6" abgeändert werden. Wenn hingegen aber "Strg + 6" ausgewählt würde, wird es nicht geändert.
    • Wenn ein Tastaturkürzel schon zu einem Eintrag zugeordnet ist, wird es unter folgenden Umständen von einem Eintrag entfernt:
      • Wenn ein Eintrag importiert wird (via XML oder Text). Hinweis: Dies wird auch im Importbericht vermerkt.
      • Wenn ein Eintrag hinzugefügt wird während des Zusammenfügens von Datenbanken. Hinweis: Dies wird auch im Bericht vermerkt.
      • Wenn ein Eintrag eingetragen wird per "Drag & Drop" aus einer anderen Datenbank. Innerhalb der selben Datenbank ist dies nicht der Fall.
      • Wenn Einträge kopiert werden zur Datenbank als Ergebnis eines Vergleich-Dialoges.
      • Jeder Eintrag der mit Duplizier-Aktionen entstanden ist.

    Eine Liste der aktuell verwendeten Tastaturkürzel wird unter der Liste der Menu-Schnelltasten via "Verwalten → Optionen → Schnelltasten" angezeigt. Mit einem Doppelklick auf dem Tastaturkürzel kommt man zum Dialog Anzeigen/Bearbeiten des jeweiligen Eintrages. Ebenfalls kann man Tastaturkürzel als Merkmal in 'Filter Neu/bearbeiten' setzen um alle Einträge mit oder ohne Tastaturkürzel zu sehen.


Benutzernamen, Passwörter und Gruppen: Datum und Uhrzeit

Die Verwaltung von Benutzernamen, Passwörter und Gruppen, zusammen mit den dazugehörigen Parametern, erfolgt über mehrere Reiter:

  • Basis: alle notwendigen Angaben für die Passwordverwaltung
  • Zusätzlich: weitere Angaben, inklusive Historie
  • Datum und Uhrzeit: Ablaufzeiten und Statistiken
  • Passwortrichtlinie: Abweichungen vom Standard

Reiter Datum und Uhrzeit

Eintrag bearbeiten: Datum und Uhrzeit
  • Passwortablaufdatum: Um das Ablaufdatum eines Passworteintrages zu setzen, geben Sie das gewünschte Ablaufdatum an, entweder als absoluter Tag (z.B. "25.01.2009") oder als relativer Tag zu Heute (z.B. "30 Tage") und klicken Sie auf An bzw. In. Wenn das Ablaufdatum sich nähert, wird Password Safe sowohl beim Start melden, dass das Passwort geändert werden soll, als auch den Eintrag mit einer anderen Farbe hinterlegen.
    Wenn "In N Tage" gewählt wurde, können Sie einen "periodischer" Ablauf bestimmen. Dies bewirkt, dass ein neues Ablaufdatum berechnet wird basierend auf der Anzahl festgelegten Tagen, wenn das Passwort abgeändert wird. Zum Beispiel: Sie erstellen einen Eintrag am 11ten Januar, und legen periodisch 5 Tage fest. Sie bekommen dann am 16ten Januar eine Ablaufmeldung. Wenn Sie das Passwort am 17ten Januar ändern, wird das neue Ablaufdatum am 22ten Januar sein (5 Tage nachdem das Passwort gesetzt wurde).
  • Um das Ablaufdatum abzustellen, klicken Sie auf Keine.
  • Statistiken: Dieses NUR-Lesen Feld hält die Information des gewählten Eintrages zum Erstellzeitpunkt, zuletzt zugegriffen, usw. auf dem Laufenden. Diese Information wird im Dialog Eintrag Einfügen nicht angezeigt.

Hinweis: Password Safe wird nur dann den Benutzer warnen, wenn eine der Passwörter abgelaufen ist. Es liegt in der Verantwortung des Benutzers das Passwort zu ändern. Es gibt jetzt eine Menüpunkt ("Ansicht → Zeige Einträge mit Ablaufdatum") um ein internes Filter einzuschalten, um alle Einträge mit Ablaufdatum anzuzeigen, unabhängig von dem ab das Ablaufdatum noch nicht, bald oder schon abgelaufen ist. Wenn man diesen Punkt wieder auswählt, wird das interne Filter wieder entfernt und die normale Anzeige ist wieder da.

Expired Password Filter


Benutzernamen, Passwörter und Gruppen: Passwortrichtlinie

Die Verwaltung von Benutzernamen, Passwörter und Gruppen, zusammen mit den dazugehörigen Parametern, erfolgt über mehrere Reiter:

  • Basis: alle notwendigen Angaben für die Passwordverwaltung
  • Zusätzlich: weitere Angaben, inklusive Historie
  • Datum und Uhrzeit: Ablaufzeiten und Statistiken
  • Passwortrichtlinie: Abweichungen vom Standard

Reiter Passwortrichtlinie

Eintrag bearbeiten: Passwortrichtlinie

Wenn Sie für einen Eintrag nicht die standardmäßig festgelegte Passwortrichtlinie (siehe hierzu Verwalten->Optionen->Passwortrichtlinie) benutzen wollen, können Sie nach Auswählen von "Verwende die Richtlinie unten:" eine eigens für diesen Eintrag festgelegte Passwortrichtlinie zusammenstellen. Sie können auch ein eigener Spezieller Satz einstellen, um diese bei der Generierung eines Passwortes zu verwenden. Sie können die Liste auch für die gesamte Datenbank mit "Verwalten → Optionen → Passwortrichtlinie" setzen, und an der gebrauchten Stelle überspielen mit den eigenen Angaben.
Hinweis: die interne "Easy-Vision" Zeichenliste wird immer für Easy-Vision und Aussprechbare Passwörter angewendet.


Passwortrichtlinie

Die Passwortrichtlinie beschreibt die Regeln, die verwendet werden, um ein Passwort zu bilden, d.h. die Schreibart, Länge und die dafür benötigten Buchstaben und Sonderzeichen. Einige Institute verlangen nur Kleinbuchstaben während andere nicht nur verlangen, dass Großbuchstaben, Zahlen und Sonderzeichen verwendet werden, sondern schreiben auch eine bestimmte minimale Länge vor. Im Allgemeinen ist es eine gute Idee die größtmögliche Länge und das breiteste Spektrum an verwendbaren Zeichen zu verwenden. Verifizieren Sie die genauen Vorschriften für die Passwörter mit den Dienstellen, welche diese verlangen.

Es besthet jetzt die Möglichkeit eine Standardliste auszuwählen die Anwendung findet in der gesamten Datenbank mit "Verwalten → Passwortrichtlinien...". Zusätzlich kann für jeden Eintrag eine eigene Zeichenliste festgelegt werden.
Hinweis: die Zeichenliste wird nicht verwendet für leicht zu lesende und aussprechbare Passwörter.

Der Dialog Passwortrichtlinie ermöglicht es sowohl eine generelle Richtlinie zur Bildung von Passwörtern, als auch benannte Richlinien festzulegen. Diese Richtlinien werden in der Datenbank gespeichert, und sind somit Datenbankspezifisch. Eine Richtlinie kann bei Bedarf überschrieben werden und Passwörter können auch händisch eingegeben werden im Dialog Eintrag bearbeiten/einfügen.

Passwortrichtlinien auswählen

Jedes "Element" (z.B. Benutze Kleinbuchstaben, Benutze Symbole, usw.), das im Dialog markiert ist, zwingt Password Safe dazu, die ausgewählten Zeichen bei der Bildung von Passwörtern zu verwenden. Jedes Passwort wird in der spezifizierten Länge gebildet, nicht länger und nicht kürzer. Die einzige Ausnahme hiervon ist die Verwendung von Benutze nur Hexadezimalzahlen. Wenn markiert, wird das Passwort nur aus Hexadezimalzahlen zusammengestellt. Wenn Sie diese Option auswählen, sind alle anderen Optionen abgeschaltet (=ausgegraut).

Die Auswahl von Generiere aussprechbare Passwörter veranlasst Password Safe ein "sinnloses" Wort zu bilden, das aussprechbar sein sollte, wie etwa "ingstria", "ringsony", usw. Die ist dann nützlich, wenn Sie ein Passwort brauchen, das sowohl sicher als auch leicht zu merken ist, auch ohne Password Safe. Wenn Sie diese Option mit Benutze Zahlen und/oder Benutze Symbole verwenden, werden einige Zeichen mit ihrem "leet" Äquivalent umgesetzt, z.B., "E" wird möglicherweise mit "3", "S" mit "5", usw. umgesetzt.

Die Zeichen die hinzugefügt werden, wenn Sie Benutze Symbole markieren, sind: + - = _ @ # $ % ^ & ; : , . < > / ~ \ [ ] ( ) { } ? ! und |. Wenn Sie Benutze leicht zu lesende Zeichen ausgewählt haben, werden aber nur + - = _ @ # $ % ^ & < > / ~ \ und ? verwendet.

Die verwendeten Buchstaben beim Markieren von Benutze leicht zu lesende Zeichen sind: a b c d e f g h i j k m n o p q r s t u v w x y z und A B C D E F G H J K L M N P Q R T U V W X Y und die Ziffern sind 3 4 6 7 8 9.


Passworthistorie

In Password Safe können Sie die letzten paar Passwörter eines Eintrages zusammen mit dem Datum festhalten, an welchem die Passwörter gesetzt wurden. Dies ist nützlich, um eine Übereinstimmung des Passwortes mit den an einigen Stellen eingesetzten Passwortrichtlinien nachzuweisen, oder um ein Passwort auf eine ältere Version zurückzuschalten, wenn das neue Passwort (warum auch immer) nicht funktioniert. Die Passworthistorie kann im Reiter "Zusätzlich" im Dialogfenster Eintrag bearbeiten erreicht werden.

Passworthistorie

Dieser Dialog stellt die letzten paar Passwörter für den jeweiligen Eintrag da. Um dies anzuzeigen drücken Sie auf die Taste "Passworthistorie" im Eintrag bearbeiten/Einfügen Dialog. Folgendes kann gemacht werden:

Die N letzten Passwörter behalten

Wenn markiert, werden zu diesem Eintrag die angegebene Anzahl an letzten Passwörtern abgespeichert. Die spezifische Anzahl für diesen einen Eintrag kann hiermit festgelegt werden.
Hinweis: Wenn Sie die Markierung aufheben, wird die Historie nicht gelöscht. Es wird lediglich die weitere Abspeicherung von Passwörtern in Password Safe für diesen Eintrag angehalten.

Passwort kopieren

Wenn Sie auf eine Zeile in der Liste der letzten Passwörter klicken, wird das Passwort aus dieser Zeile in die Zwischenablage kopiert.

Historie löschen

Wenn Sie auf diese Taste drücken, wird die gesamte Passworthistorie dieses Eintrages gelöscht. Wenn keine Historie vorhanden ist, ist die Taste deaktiviert (ausgegraut).
Hinweis: Der Eintrag wird erst zum Zeitpunkt, wann Sie 'OK' in "Eintrag bearbeiten/einfügen" Dialog drücken, geändert werden. Wenn Sie versehentlich auf "Historie löschen" gedrückt haben, drücken Sie nicht auf 'OK' sondern auf 'Abbrechen'.

Alles kopieren

Wenn Sie diese Taste drücken wird die gesamte Historie dieses Eintrages mit Datum und Passwort in die Zwischenablage kopiert.


Master-Passwörter ändern

Um ein Master-Passwort ("Safe Combination") zu ändern, muss zuerst die Datenbank, deren Passwort geändert werden soll, geöffnet werden. Einmal geöffnet, gehen Sie zum Menü Verwalten und wählen Sie Master-Passwort ändern aus. Folgender Dialog wird dann angezeigt:

Key Change dialog box

Hinweis: Wenn Sie kein YubiKey haben, werden die YubiKey Tasten nicht angezeigt, und Sie können die untenstehende Beschreibung überspringen.

Um ein Master-Passwort ("Safe Combination") zu ändern, muss zuerst die Datenbank, deren Passwort geändert werden soll, geöffnet werden. Einmal geöffnet, gehen Sie zum Menü Verwalten und wählen Sie Master-Passwort ändern aus. Sie sollten das derzeitige und dann zweimal das neue Master-Passwort zur Bestätigung eingeben. Zur Eingabe kann auch die virtuelle Tastatur verwendet werden.

Password Safe hat eine eingebaute Prüfung auf vermeintlich schwache Passwörter. Im Allgemeinen sollte ein Master-Passwort (wie jedes andere Passwort auch) aus einem Mix von Buchstaben und mindestens einer Ziffer oder einem Speziellen Zeichen (wie die Zeichen, die sich über Ziffern auf der Tastatur befinden) bestehen. Wenn das Programm ein eingegebenes Master-Passwort als schwach einstuft, wird eine Bestätigung angefordert. Sie haben dann die Wahl das original eingegebene (schwache) Master-Passwort anzunehmen, oder ein Neues einzugeben.

Für YubiKey Anwender:

Zusätzlich zum Ändern des Master-Passwortes wie oben beschrieben, können Sie in diesem Dialog die YubiKey Authentifizierung hinzufügen oder entfernen, eine zusätzliche Authentifizierung hinzufügen oder entfernen, als auch den YubiKey umschalten der für den Zugang zur Datenbank eingesetzt wird. Hiernach werden die einzelnen Aktionen detailliert beschrieben:

YubiKey Authentifizierung hinzufügen

Der Zugang zur PasswordSafe Datenbank ändern vom Einsatz eines Master-Passwortes zu YubiKey:
  1. Geben Sie das laufende Master-Passwort im Feld 'Altes Master-Passwort' ein.
  2. YubiKey einstecken.
  3. Wenn Sie wünschen, geben Sie ein Passwort im Feld 'Neues Master-Passwort' ein und bestätigen dies in Feld 'Bestätigung'.
  4. Drücken Sie die untere Yubikey Taste, und aktivieren Sie dann Ihr YubiKey.

YubiKey Authentifizierung entfernen

Der Zugang zur PasswordSafe Datenbank so ändern dass nur ein Master-Passwort benötigt wird:
  1. YubiKey einstecken.
  2. Wenn Sie momentan ein Master-Passwort im Einsatz haben, geben Sie es im Feld 'Altes Master-Passwort' ein.
  3. Drücken Sie die obere Yubikey Taste, und aktivieren Sie dann Ihr YubiKey.
  4. Geben Sie im Feld 'Neues Master-Passwort' das neue Master-Passwort ein und bestätigen dies in Feld 'Bestätigung'.
  5. Drücken Sie OK.

Passwort Authentifizierung hinzufügen / entfernen / bearbeiten

Password Safe kann YubiKey als einziger Zuganng benutzen, oder zusammen mit einem konventionellen Passwort. Zum Wechseln von einem zum anderen:
  1. YubiKey einstecken.
  2. Wenn Sie momentan ein Master-Passwort benutzen, geben Sie es im Feld 'Altes Master-Passwort' ein.
  3. Drücken Sie die obere Yubikey Taste, und aktivieren Sie dann Ihr YubiKey.
  4. Setzen Sie das 'Neue Master-Passwort' (und die Bestätigung) auf den gewünschten Wert: Leer um das Passwort zu entfernen, oder ein neues Master-Passwort zum hinzufügen oder ändern.
  5. Drücken Sie die untere Yubikey Taste, und aktivieren Sie dann Ihr YubiKey.

YubiKey Ändern

Um von einem YubiKey auf einem anderen zu wechseln:

  1. Den alten YubiKey einstecken.
  2. Wenn Sie auch ein Master-Passwort einsetzen, geben Sie es im Feld 'Altes Master-Passwort' ein.
  3. Drücken Sie die obere Yubikey Taste, und aktivieren Sie dann Ihr YubiKey.
  4. Entfernen Sie den alten YubiKey, und setzen den neuen ein.
  5. Wenn Sie es wollen, geben Sie im Feld 'Neues Master-Passwort' ein Master-Passwort ein und bestätigen dies in Feld 'Bestätigung'.
  6. Drücken Sie die untere Yubikey Taste, und aktivieren Sie dann Ihr YubiKey.

Hinweise:
  • Bemerkung: Es besteht keine Möglichkeit in Password Safe verlorene oder vergessene Passwörter wieder aufzufinden.
    Dies wurde im Konzept bewusst so entschieden, weil jede Art Passwortwiederherzustellung auch eine Sicherheitslücke darstellt.
  • Wählen Sie bitte ein schwer zu erratendes Passwort. Ein triviales Passwort wie "passwort" oder Ihr Name wäre einfach zu erraten und würde damit die Sicherheit, die Password Safe bietet, zuwiderlaufen.


Automatische Eingabe

Die Automatische Eingabe ist eine einfache und schnelle Methode, um Benutzernamen und Passwörter einzugeben. Mit einem einzigen Klick werden Benutzername und Passwort angegeben und die Daten werden zur Freigabe dem System übergeben. Standardmäßig ist die Formel für den automatisierten Tastenanschlag wie folgt: Benutzername, gefolgt vom TAB Zeichen, gefolgt vom Passwort, noch ein TAB Zeichen und dann die Eingabe-Taste (Benutzername TAB Passwort TAB ENTER). Dies funktioniert für die meisten WEB Seiten, die eine Authentifikation mit Benutzername/Passwort benötigen.

Für WEB Seiten oder Anwendungen die andere Daten erfordern, ist es möglich das Verhalten der 'Automatischen Eingabe', wie weiter unten im Absatz Automatische Eingabe anpassen beschrieben, anzupassen . Bemerkung: Man kann auch den Text für die standardmäßige Automatische Eingabe im Menü Verwalten->Optionen->Verschiedenes anpassen. Dies kann z.B. dann nützlich sein, wenn die Automatische Eingabe für Ihre Maschine zu schnell ist.

Automatische Eingabe anwenden

  1. Setzen Sie den Kursor im Feld Benutzername des Formblattes
  2. Maximieren Sie oder öffne Password Safe
  3. Wählen Sie den Passworteintrag aus
  4. Strg -T oder rechter Mausklick und wählen Sie Autom. Eingabe ausführen aus oder klicken Sie in der Toolleiste den entsprechenden Knopf zum Beginnen.

Automatische Eingabe anpassen

Für WEB Seiten oder Anwendungen, bei denen das Feld 'Benutzername' nicht vom Feld 'Passwort' und vom Feld 'Anmelden' gefolgt wird, können Sie das Verhalten abändern, indem Sie im Feld "Automatische Eingabe" den Text ausfüllen, der für das erhoffte Verhalten spezifiziert ist. Dies geht wie folgt:

  • \u wird ersetzt durch den Benutzernamen vom Eintrag.
  • \p wird ersetzt durch das Passwort vom Eintrag.
  • \g wird ersetzt durch die Gruppe, die mit dem Eintrag verknüpft ist.
  • \i wird ersetzt durch den Titel, die mit dem Eintrag verknüpft ist.
  • \o wird ersetzt durch den Inhalt des Feldes Notizen (möglicherweise mehrzeilig).
    • Alle Zeilenende Zeichen "\n", "\r" oder "\r\n" werden umgeformt zu "\r" (carriage return).
    • Es erfolgt keine Ersetzung für Escape Sequenzen im Feld Notizen (z.B. "\u", "\p" usw.) außer für die "\t" Sequenz, die ersetzt wird durch das TAB Zeichen.
  • \oNNN wird ersetzt durch den Inhalt von der nten Zeile im Feld Notizen.
    • NNN kann aus 1 bis 3 Ziffern bestehen (z.B., \o5 für die 5te Zeile, \o45 für die 45ste, usw.
    • Zeilenende Zeichen sind nicht eingeschlossen.
    • wenn NNN größer ist als die Anzahl Zeilen im Feld Notizen, dann hat dies keine Auswirkung.
    Hinweis: Für Anwendungen, die ein zweites Passwort verlangen oder einen beliebigen Text als Teil des Autorisierungsprozesses benötigen, ist dies eine bequeme Möglichkeit Autom. Eingabe zu unterstützen.
  • \b wird ersetzt durch die Backspace-Taste.
  • \t wird ersetzt durch die TAB Taste, um das Feld zu überspringen.
  • \n wird ersetzt durch die ENTER Taste, um die Taste zu 'Drücken'.
  • \\ wird ersetzt durch die Gegenschrägstrich (\) Taste.
  • \dNNN setzt die Verzögerung zwischen Zeichen auf NNN Millisekunden, anstelle von 10 (Standard).
    Dies ändert die Verzögerung des aktuellen und alle folgenden Zeichen . Z.B. "schnell\d500langsam" bewirkt dass 'schnell' im normalem Tempo ausgegeben wird, und die Zeichen 'l','a' bis 'm' ausgegeben werden mit jeweils einer halben Sekunde Verzögerung vor der Ausgabe. Wenn Sie eine Verzögerung nur 1x wollen, und keine Verzögerung der folgenden Zeichen, setzen Sie '\w' bzw. '\W' ein, wie weiter unten beschrieben.
  • \WNNN macht eine einmalige Verzögerung an der Stelle wo es erscheint. Die Verzögerung beträgt NNN Sekunden.
  • \wNNN macht eine einmalige Verzögerung an der Stelle wo es erscheint. Die Verzögerung beträgt NNN Millisekunden.
    Z.B. bei "wie\w500jetzt" wird zuerst 'wie' ausgeben (mit der Geschwindigkeit des zuletzt definierten '\d'), gefolgt von einer Verzögerung mit 0,5 Sekunden, und die Ausgabe von 'jetzt', in derselben Geschwindigkeit wie 'wie'. Gleichermaßen wird bei "das\W2Gleiche" eine Pause von 2 Sekunden zwischen den beiden Wörtern ausgegeben. Diese Vorgehensweise ist sinnvoll um die Ausgabe an einigen WEB-Seiten genau abzustimmen.
  • \z ruft den alten Mechanismus für Automatische Eingabe auf. Dieser Mechanismus behandelt nicht-Latein Buchstaben eventuell nicht ganz richtig, aber bringt Automatische Eingabe an problematische WEB-Seiten zum "Spielen". Wenn Sie feststellen das Automatische Eingabe auf bestimmte WEB-seiten nicht funktioniert, versuchen Sie es mit diesem Kode.
  • Sämtliche andere Text wird so wie er ist eingegeben.

Beispiel: Folgendes kann verwendet werden wo das Bankkonto (12345) vor dem Benutzernamen und das Passwort kommen muss:

12345\t\u\t\p\t\n

Anmerkung: Wenn Sie ein Problem mit der 'Automatischen Eingabe' haben, wäre es empfehlenswert Popup-Blocker von Dritthersteller abzuschalten. Einige Benutzer haben über Probleme berichtet wegen der gegenseitigen Beeinflussung von Popup-Blocker und der Funktion 'Automatischen Eingabe'.


Datenbanken sichern und wiederherstellen

Für gewöhnlich sind die Informationen, die in Passwortdatenbanken enthalten sind, sowohl sensibel als auch wichtig. Password Safe stellt einige Mechanismen zur Verfügung, um Passwörter zu sichern und wiederherzustellen. Diese Kapitel beschreibt Wege, um händisch Sicherungen ihrer Passwortdatenbanken zu machen. Password Safe kann auch so eingestellt werden dass automatisch Sicherungen gemacht werden, wenn die Datenbank gespeichert wird. Solche Sicherungskopien werden Zwischen-Sicherung genannt, und werden hier beschrieben.

Sicherung erstellen

Erstellen Sie eine Kopie der aktuellen Passwortdatenbank.

  1. Klicken Sie auf Sicherung erstellen
  2. Wählen Sie eine Speichestelle für die Sicherung
  3. Klicken Sie auf Speichern

Hinweis: Es wird dringend empfohlen regelmäßig Sicherungen der Passwortdatenbanken zu machen. Dies schützt Passwortlisten gegen Systemzusammenbrüche, Stromunterbrechungen und kaputte Dateien. Die Sicherung und die Datenbank sind mit demselben Master-Passwort verschlüsselt.

Wiederherstellen aus Sicherung

Die Wiederherstellung einer Passwortdatenbank aus einer Sicherung.

  1. Klicken Sie auf Wiederherstellung aus Sicherung
  2. Gehen Sie zum Verzeichnis wo die Sicherung sich befindet
  3. Wählen Sie die entsprechende Erweiterung (.bak/.ibak) aus
  4. Wählen Sie die gewünschte Datei aus
  5. Klicken Sie auf Öffnen
    Ein Aufforderung zur Eingabe des Passwortes wird angezeigt.
  6. Geben Sie das Passwort ein und klicken Sie auf OK
Hinweis:
  • Die wiederhergestellte Datenbank ist mit der Password Safe Standarderweiterung (.psafe3) erst dann gespeichert, wenn Sie den Befehl Speichern oder Speichern unter im Menü Datei ausgeführt haben. Wenn Sie die Anwendung verlassen wollen ohne die Datenbank abgespeichert zu haben, werden Sie sicherheitshalber aufgefordert Sie abzuspeichern.
  • Zusätzlich zu dem hier beschriebenen Erstellen und Wiederherstellen wie es hier beschrieben ist, wird Password Safe automatisch eine Kopie der Datenbank vorhalten, bevor Änderungen abgespeichert werden. Diese Kopie wird im selben Verzeichnis wie die aktuelle Datenbank abgelegt. Sie hat denselben Namen aber eine andere Erweiterung (".ibak" anstelle von ".psafe3"). Siehe hier für mehr Information über automatische Sicherungen.


Sicherungen

Reiter Sicherungen

Im Reiter Sicherungen können Sie die Vorgehensweise konfigurieren, wie automatische Sicherungen erstellt und verwaltet werden.

Datenbank sofort nach Bearbeiten oder Einfügen speichern

Wenn markiert, speichert Password Safe alle Änderungen in einem Passworteintrag sofort ab, ohne abzuwarten, ob der Benutzer Speichern oder Speichern unter betätigt. Wenn nicht markiert, werden die geänderten Sätze farblich markiert. Das überhaupt geänderte Einträge vorhanden sind, läßt sich auch am "*" in der Statuszeile abelesen.

Vor dem Speichern Zwischen-Sicherungen (.ibak) erstellen

Wenn markiert, wird Password Safe die Datenbank vor jeder Sicherung eine Zwischen-Sicherung anlegen. Name, Speicherort sowie die Anzahl der Zwischen-Sicherungen werden in folgenden Feldern definiert.

Name der Sicherungen

Der Name der Sicherungen besteht aus einer Basis (standardmäßig, der Name der Datenbank ohne Erweiterung .psafe3), und einer Erweiterung (keine, eine fortlaufende Nummer oder Datum und Uhrzeit der Sicherung). Hier können Sie auch konfigurieren wie der Name der Zwischen-Sicherung sein soll und wie viele Sicherungen abgespeichert werden sollen. Password Safe wird automatisch die Sicherungen löschen, die außerhalb der festgelegten Anzahl liegen. Bemerkung: Password Safe wird sie nur dann löschen, wenn die Erweiterung eine fortlaufend aufsteigende Nummer ist.

Verzeichnis der Sicherungen

Standardmäßig wird Password Safe die Sicherungen im selben Verzeichnis ablegen, in welchem sich die geöffnete Datenbank befindet. In diesem Feld können Sie einen alternativen Speicherort festlegen, z.B. ein spezielles Sicherungsverzeichnis, Netzlaufwerk, disk-on-key, usw. Sie sollten natürlich Schreibenden Zugriff auf dieses Laufwerk haben.

Klicken Sie hier für Details zu den unterschiedlichen Einstellungen.

Die Password Safe Voreinstellungen werden dargestellt.


Notsicherungen

Wenn PasswordSafe normal beendet wird, werden Sie gefragt falls noch ungesicherte Einträge in der Datenbank bestehen. Wenn Sie sich aber von Windows abmelden, oder wenn Sie den PC Runterfahren oder Neu Starten hat PasswordSafe eventuell nicht die Chance Sie zu fragen (das genaue Verhalten hängt von der Art des Runterfahrens und der Windowsversion ab).

In diesem Fall wird PasswordSafe versuchen ein "Notsicherungsdatei" zu machen (mit der Erweiterung 'fbak'). Diese Notsicherungsdatei wird im selben Verzeichnis abgelegt wo sich die aktuell geöffnete Datenbank befindet. Die aktuell geöffnete Datenbank und die "normalen" Sicherungen sind von dieser Aktion nicht betroffen.

Wenn die ursprüngliche Datenbank wieder geöffnet wird, prüft PasswordSafe ab, ob eine Notsicherungsdatei besteht, um gegebenenfalls einen Dialog wie folgt anzuzeigen.

Failsafe Backup Display during Open

In der ersten Zeile steht die ausgewählte Datenbank mit einigen Informationen (diese werden auch im Punkt Eigenschaften vom Menü Datei angezeigt). Danach folgen die Notsicherungsdateien. Wenn diese Notsicherungsdateien mit demselben Master-Passwort wie die geöffnete Datenbank geöffnet werden können, werden auch deren Eigenschaften angezeigt. Wenn das Master-Passwort unterschiedlich ist oder die Datenbank nicht gültig ist, erscheint ein 'Nein' in der Spalte Master-Passwort. Es erscheinen auch keine Eigenschaften.

Hier die Auswahl:

  • Weiter
    Wenn Sie diese Taste drücken, wird Passwordsafe alle Notsicherungsdateien überspringen und weiterarbeiten mit der ausgewählten Datenbank.

  • Auswahl
    Die ausgewählte Notsicherung wird anstelle der ausgewählten Datenbank geöffnet.

  • Löschen
    Hiermit löschen Sie die ausgewählte Notsicherungsdatei. Wenn Windows einen Papierkorb auf dem Laufwerk unterstützt (i.d.R. nur bei lokalen Festplatten), wird sie da drin abgelegt. Wenn nicht, wird die Notsicherungsdatei unwiederbringlich gelöscht.

  • Beenden
    Wenn es die erste Datenbank ist, die beim Start von PasswordSafe geöffnet wurde, wird PasswordSafe beendet. Wenn nicht, wird das Öffnen abgebrochen, und es wird mit der vorhandenen Datenbank -soweit vorhanden- weitergemacht.

  • Hilfe
    Zeigt diese Hilfe an.

Anregungen:

  • Wenn Sie nicht auswählen können, fahren Sie mit der aktuell geöffneten Datenbank weiter, und versuchen es mit dem Punkt Vergleichen... im Menü Datei. Hier können sie genau die Unterschiede zwischen der Datenbank und der Notsicherung sehen.
  • Wenn Sie die Notsicherungsdatei öffnen, und Sie sich entschieden haben diese Version zu behalten, sollten Sie diese wie eine normale Datenbank speichern. Wenn Sie dies tun, überlegen Sie sich die alte Datenbank umzubenennen oder die neue Datenbank unter einem anderen Namen zu speichern.
  • Wenn Sie damit zufrieden sind, die richtige Datenbank wiederhergestellt zu haben, sollten Sie alle alten Notsicherungsdateien löschen, um zu verhindern daß Sie später nochmals gefragt werden. Bemerkung: Wenn Sie diesen Dialog benutzen um Dateien zu löschen, werden diese im Papierkorb abgelegt, soweit es für die benutzten Speichermedien von der verwendeten Windowsversion unterstützt wird.

Anmerkung: Es gibt nichts was JEDWEDE Anwendung tun kann um Informationen abzuspeichern, wenn der PC einfach abgeschaltet wird, Strom verliert oder Prozessor, Festplatte oder irgendein Teil kaputt gehen. Sowie mit allen für Sie wichtigen Daten, sollten Sie regelmäßig Ihre Daten auf ein anderes Medium abspeichern. Dies könnte ein USB-Stick sein, externe Festplatten, Netzlaufwerke, CDs oder DVDs, usw. Diese Sicherungen sollten Sie an einem sicheren Platz aufheben.


Einträge importieren

Anmerkung: Teile in blau sind (noch) nicht aus dem Englischen übersetzt.

Password Safe bietet an, Passwortinformationen aus anderen Formaten zu importieren. Diese Formate/Dateien können mit Hilfe anderer Anwendungen entstanden sein z.B. exportiert aus einer Tabelle, oder sogar von Hand geschrieben mit Notepad oder ähnlichem Texteditor.

Die von Password Safe unterstützten Formate sind:

  • Text
  • XML
  • KeePass V1 TXT und CSV Dateien
  • KeePass V2 via KeePass V1 CSV Dateien
  • KeePass V1 und V2 XML Dateien

Password Safe generiert am Ende eines Importes einen Bericht mit einer Übersicht über die ausgeführten Operationen und dabei ev. aufgetretene Probleme. Dieser Bericht kann in die Zwischenablage kopiert werden, oder auf die Festplatte als Textdatei im selben Verzeichnis wie die Datenbank abgespeichert werden. Unter dem Menupunkt "Ansicht → Berichte" können die Berichte zu einem späteren Zeitpunkt angeschaut werden. Der Name des Berichtes ist festgelegt, und hängt ab von der Funktion mit der er erzeugt wurde. Wenn dieselbe Funktion ausgeführt, und der entsprechende Bericht auf die Festplatte abgespeichert wird, wird jegliche Bericht zu dieser Funktion überschrieben. Hinweis: Der Bericht kann sensible Daten enthalten, so Vorsicht ist geboten beim Abspeichern auf die Festplatte.

Hinweis: Sie können auch Untermengen aus einer anderen Password Safe Datenbank importieren. Sie öffnen eine andere Datenbank mit Password Safe (vorausgesetzt sie erlauben mehrere Instanzen in "Verwalten → Optionen → System"). Sie können per Drag und Drop Einträge oder Gruppen aus der 'import'-Datenbank in Ihre Datenbank ziehen.

Text Format

Textdateien, aus welchen die Passworteinträge importiert werden können bestehen aus einem oder mehreren Passworteinträgen. Jedes Feld innerhalb eines Eintrages ist mit einem Feldtrennzeichen getrennt und jeder Eintrag besteht aus einer oder mehreren Zeilen. Details zum erwarteten Format der zu importierende Textdatei finden Sie im "Text Export & Import Format" Kapitel.

Text-Einstellungen importieren

Das Trennzeichen in der zu importierende Textdatei und ein standardmäßiger Gruppenname für die neuen Einträge können eingestellt werden, bevor die Datei importiert wird.

Text Einstellungen importieren

  1. Datei->Importieren von
  2. Wählen Sie Nur Text...
  3. Stellen Sie die Einstellungen und Parameter für die zu importierende Textdatei ein
  4. Wenn in dem Notizenfeld ein Zeichen zur Erkennung von mehreren Zeilen benutzt wurde (entweder von einem früheren Export oder mit einem Texteditor) geben Sie es hier an, sodass während des Importierens des Notizenfeldes dieses in mehreren Zeilen zerlegt werden kann, durch Austauschen dieses Zeichens mit einem Wagenrücklauf-Zeichen.
  5. Klicken Sie auf OK
  6. Wählen Sie die Textdatei zum Importieren aus.
  7. Am Ende des Importierens öffnet sich ein kleines Fenster, in dem die Gesamtanzahl sowie die Anzahl der fehlerhaft verarbeiteten Einträge gemeldet werden.
WICHTIG: Wenn ein zu importierender Eintrag eine benannte Passwortrichtlinie, die noch nicht in der aktuel empfangenden Datenbank ist, benutzt, dann wird der Eintrag nach dem Import mit der standardmäßigen Passwortrichtlinie ausgestattet.
WICHTIG: Die erste Zeile der importierten Datei muss eine durch TAB getrennte Namensliste der Felder enthalten, die die Elemente im jeweiligen Eintrag beschreiben z.B. "Gruppe/Titel Benutzername Passwort URL", usw. Diese Zeile wird automatisch erzeugt beim Aufruf der Funktion "Export Text" erzeugt, muss aber in Dateien, die in anderen Anwendungen erstellt wurden, eventuell von Hand eingefügt werden.

XML

XML (eXtensible Markup Language) ist ein populäres Format, um Daten zwischen Anwendungen zu transportieren. Password Safe kann XML-Dateien importieren, die nach den in der Datei pwsafe.xsd festgelegten Vorgaben erstellt wurden. Diese Datei ist Bestandteil dieser Distribution.

When importing XML into an empty database, any database preferences in the beginning of the XML input file will be imported into the database. If the current receiving database already has entries, then these preferences will be ignored.

However, any "Password Policy Names" in the XML input file will be imported irrespective of whether there are entries already in the current receiving database. Note however, if a Password Policy with the same name already exists in the database, it will not be overwritten by the values in the XML input file.

If an entry that uses a Password Policy Name is imported and that name is neither in the current receiving database nor in XML input file, then the resulting entry in the database will revert to using the database's default Password Policy.

Change of the coding of XML Date/time values

Prior to PasswordSafe V3.26, date time fields were exported in our own format:

  <name>
    <date>yyyy-mm-dd</date>
    <time>hh:mm:ss</time>
  </name>

Where "name" was any of our record date/time fields e.g. 'ctime', 'atime', 'xtime', 'pmtime', 'rmtime' and the password history 'changed' date/time.

However, from V3.26 onwards, PasswordSafe will only export XML date/time fields using the International W3C Standard date/time format. V3.26 and V3.27 can input either format but for versions after 3.27, it will only accept the W3C standard.

The W3C standard for XML date/time fields is:

  <namex>yyyy-mm-ddThh:mm:ss</namex>

Where we have changed the "name" to distinguish the fields from the old format by appending an 'x' and so 'namex' is any of our new record date/time fields e.g. 'ctimex', 'atimex', 'xtimex', 'pmtimex', 'rmtimex' and the password history 'changedx' date/time.

To import an older format XML file with date/time fields, you must manually edit these fields to convert to the old PasswordSafe format to the W3C standard format.

KeePass V1 TXT und CSV Files

Der empfohlene Import von KeePass V1 Datenbankeinträge geht mit XML wie unten beschrieben.

TXT Datei

Sie können auch TXT-Dateien exportiert aus Keepass V1 importieren (getestet mir Dateien erzeugt in V1.19b).

Folgende Felder werden umgesetzt zu Password Safe Equivalente:

Jeder neuer Eintrag beginnt mit einer Zeile beginnend mit '[' und endend mit ']'. Der Text dazwischen wird als 'Titel' für diesen Eintrag verwendet.

Jeder Informationsteil steht in einer Zeile und folgende Tags stehen am Anfang jeder Zeile:

  • "Group: " wird zur Gruppe
  • "Group Tree: " wird zur Gruppenhierarchie zur Wurzel
  • "User Name: " wird zum Benutzernamen
  • "Password: " wird zum Passwort
  • "URL: " wird zur URL
  • "Notes: " wird zu den Notizen
  • "UUID: " wird zur internen "unique ID" vom Password Safe Eintrag
  • "Creation Time: " wird zum Erstellzeitpunkt
  • "Last Access: " wird zum letzten Zugriffszeitpunkt
  • "Last Modification: " wird zum Passwort und zum Zeitpunkt der letzten Änderung
  • "Expires: " wird zum Ablaufzeitpunkt

Folgende Felder werden zur Zeit nicht betrachtet:

  • "Icon"
  • "Attachment Description"
  • "Attachment" - Dieses Feld NICHT exportieren, weil es die Exportdatei riesig groß machen kann.

Beachten Sie dass Zeiten in Password Safe vor 19. Januar 2038 liegen müssen. Jeder Zeit danach wird als ungültig betrachtet, und das zugehörige Feld somit auch.

Bitte beachten Sie dass das Feld "Encode/replace newline characters by '\n'" angekreuzt werden MUSS während des Exportierens mit Keepass V1, wenn nicht kann der Import fehlschlagen oder zu unerwartete Fehler führen.

CSV Datei

Sie können auch eine CSV (Comma Separated Values) Datei importieren exportiert mit Keepass V1 (getestet mit Dateien der Version V1.19b).

Folgende Felder werden umgesetzt zu Password Safe Equivalente:

  • "Password Groups" wird zur Gruppe
  • "Group Tree" wird zur Gruppenhierarchie zur Wurzel
  • "Account" wird zum Titel
  • "Login Name" wird zum Benutzernamen
  • "Password" wird zum Passwort
  • "Web Site" wird zur URL
  • "Comments" wird zu den Notizen
  • "UUID" wird zur internen "unique ID" vom Password Safe Eintrag
  • "Creation Time" wird zum Erstellzeitpunkt
  • "Last Access" wird zum letzten Zugriffszeitpunkt
  • "Last Modification" wird zum Passwort und zum Zeitpunkt der letzten Änderung
  • "Expires" wird zum Ablaufzeitpunkt

Folgende Felder werden zur Zeit nicht betrachtet:

  • "Icon"
  • "Attachment Description"
  • "Attachment" - Dieses Feld NICHT exportieren, weil es die Exportdatei riesig groß machen kann.

Beachten Sie dass Zeiten in Password Safe vor 19. Januar 2038 liegen müssen. Jeder Zeit danach wird als ungültig betrachtet, und das zugehörige Feld somit auch.

Bitte beachten Sie dass das Feld "Encode/replace newline characters by '\n'" angekreuzt werden MUSS während des Exportierens mit Keepass V1, wenn nicht kann der Import fehlschlagen oder zu unerwartete Fehler führen.

KeePass V2 via KeePass V1 CSV Dateien

Der empfohlene Import von KeePass V2 Datenbanken via XML funtioniert wie unten beschrieben.

Password Safe kann keine Datei erzeugt mit KeePass V2 importieren - auch nicht das KeePass V1 CSV Format bei diesem Programm. Allerdings ist es möglich eine KeePass V2 Datenbank zu exportieren wie eine KeePass V1 Datenbank. Sie können diese dann zu einer TXT- oder CSV-Datei exportieren, und diese kann, wie oben beschrieben, importiert werden.

KeePass V1 und V2 XML Dateien

Password Safe kann XML Dateien exportiert mit KeePass V1 oder V2 nicht importieren weil die Felder zu unterschiedlich sind. Allerdings heben wir XSL Umsetz Dateien (KPV1_to_PWS.xslt and KPV2_to_PWS.xslt) mitgeliefert. Die unten aufgeführte Programme können verwendet werden um die ecportierte XML Dateien zu bearbeiten mit einer der XSLT Dateien um eine Password Safe-kompatible XML Datei zu erstellen, die wiederum in Password Safe V3.26 oder später importiert werden kann.

Die XSLT Dateien sind konform zu XSLT V1.0, beschrieben in http://www.w3.org/TR/xslt. Sie wurden getestet mit XML Dateien erzeugt mit KeePass V1.19b und KeePass V2.15.

Beachten Sie dass Zeiten in Password Safe vor 19. Januar 2038 liegen müssen. Jeder Zeit danach wird als ungültig betrachtet, und das zugehörige Feld somit auch.

Under Windows, the following XSLT processors support the supplied XSL Transform files. The example command line execution of these processors assume:

  • The style sheet to convert the KeePass XML file to a Password Safe XML file is: KPV1_to_PWS.xslt or KPV2_to_PWS.xslt.
  • The input KeePass V1 or V2 XML file is: KeePassV1.xml or KeePassV2.xml
  • The output Password Safe XML file will be: PWS.xml
  • All input and output files are in the same directory as the XSLT processor. If not, you will need to enter the full path of these files.
  1. The command line program from Microsoft (XSLT Processor Version 4.0). The properties of the file msxsl.exe state that it is V1.1.0.1 and dated 2001, although the web site states that it is V2.0 and dated 19 September 2004. It can currently be found at http://www.microsoft.com/downloads. It requires Microsoft Core XML Services (MSXML) V4.0 to be installed. Whilst the latest MSXML version is V6, V4 is normally installed on all versions of Windows supported by Password Safe.

    For KeePass V1 XML file use the command:

    msxsl KeePassV1.xml KPV1_to_PWS.xslt -o PWS.xml
    For KeePass V2 XML file use the command:
    msxsl KeePassV2.xml KPV2_to_PWS.xslt -o PWS.xml
  2. AltovaXML Community Edition (current version 2011r3). See http://www.altova.com/altovaxml.html.

    For KeePass V1 XML file use the command:

    AltovaXML -xslt1 KPV1_to_PWS.xslt -in KeePassV1.xml -out PWS.xml
    For KeePass V2 XML file use the command:
    AltovaXML -xslt1 KPV2_to_PWS.xslt -in KeePassV2.xml -out PWS.xml
  3. Saxon-HE (Home Edition) (current version 9.3.0.5). See http://saxon.sourceforge.net/. There is also a graphical front-end for Saxon called Kernow. See http://kernowforsaxon.sourceforge.net/. The format of the command depends on whether you use the Java or .Net version of Saxon-HE and/or Kernow. Please refer to the product's documentation for further information.

All these programs are free, although Kernow needs to be registered if used more than 100 times.

KeePass V1 XML Spezialverarbeitung

  • If a KeePass group contains a dot ('.'), it is converted to a forward slash ('/') when added to Password Safe, since dots are used as group delimiters by Password Safe.
  • All 'carriage return' characters are removed from the Notes field and all 'newline' characters are converted to the normal Password Safe delimiter '»' used to denote new lines within the Notes field.
  • The KeePass entry's UUID will be transferred to the Password Safe entry unless it is already used within that database (which is very unlikely), in which case a new value will be calculated during import.
KeePass V1 XML Elements | Password Safe XML Element Equivalent
<group> | <group>
<title> | <title>
<username> | <username>
<password> | <password>
<url> | <url>
<notes> | <notes>
<lastmodtime> | <pmtimex> and <rmtimex>
<creationtime> | <ctimex>
<lastaccesstime> | <atimex>
<expiretime> | <xtimex>, if the KeePass <expiretime> attribute "expires" is 'true'
<image> <attachdesc> <attachment> | These have no Password Safe equivalent and are ignored

KeePass V2 XML Spezialverarbeitung

  • The '<HistoryMaxItems>' field from the '<Meta>' section of the KeePass V2 XML file is used as the maximum number of passwords to be saved in an Password Safe's entry password history. All other fields in this section are ignored.
  • If a KeePass group contains a dot ('.'), it is converted to a forward slash ('/') when added to Password Safe, since dots are used as group delimiters by to Password Safe.
  • All 'carriage return' characters are removed from the Notes field and all 'newline' characters are converted to the normal Password Safe delimiter '»' used to denote new lines within the Notes field.
  • The KeePass entry's UUID will be transferred to the Password Safe entry unless it is already used within that database (which is very unlikely), in which case a new value will be calculated during import.
  • If the '<DefaultAutoTypeSequence>' field is present within a KeePass group is used as the default Password Safe Autotype field for entries within that group.
  • If an entry's '<AutoType>' field is set to 'True' and the '<DefaultSequence>' is not empty, then this is used as the Password Safe's entry's Autotype sequence. If it is 'True' but '<DefaultSequence>' is empty, then the '<DefaultAutoTypeSequence>' field from the parent group is used as the Password Safe's entry's Autotype sequence.
  • If the '<OverrideURL>' field is not empty, its value is inserted into the Notes field and prefixed by "OverrideURL:" and the URL field is prefixed by "[alt]".
  • If the URL string begins with "\\" or "cmd://" (case insensitve) the field is placed in the Password Safe's entry's Run Command field and Placeholder substitution is performed (see below). If neither of these prefixes appear in the URL string, it is placed in the Password Safe's entry's URL field with only {S:FieldName} substitution.
  • If the '<Tags>' field is not empty, its value is inserted into the Notes field and prefixed by "Tags:".

KeePass V2 exports all strings, e.g. Title, in a "String" section with "Key" and "Value" sub-elements. For example:

<String>
    <Key>Title</Key>
    <Value>Test title</Value>
</String>

The following table shows the conversion of these to the Password Save equivalent XML element.

KeePass V2 String Keys | Password Safe Entry XML Element Equivalent
Title | <title>
Username | <username>
Password | <password>
URL | <url> or <runcommand> depending on the prefix (see notes above)
Notes | <notes>
All others | Inserted into the Password Safe Notes field in the form: "Key: Value"

KeePass V2 exports all date/time fields, e.g. creation time, in a "Times" section. For example:

<Times>
  <LastModificationTime>2011-05-30T14:20:57Z</LastModificationTime>
  <CreationTime>2011-05-27T18:09:29Z</CreationTime>
  <LastAccessTime>2011-05-30T14:20:57Z</LastAccessTime>
  <ExpiryTime>2999-12-28T23:59:59Z</ExpiryTime>
  <Expires>False</Expires>
</Times>

The following table shows the conversion of these to the Password Save equivalent XML element.

KeePass V2 Time Values | Password Safe Entry XML Element Equivalent
<Times>/<LastModificationTime> | <pmtimex> and <rmtimex>
<Times>/<CreationTime> | <ctimex>
<Times>/<LastAccessTime> | <atimex>
<Times>/<ExpiryTime> | <xtimex> if <Times>/<Expires> is 'True'

KeePass V2 can create an history section when anything is changed in an entry. Password Safe only saves password changes. All other saved changed fields in the KeePass XML element are ignored.

KeePass V2 History | Password Safe Entry XML Element Equivalent
<Times>/<LastModificationTime> | <history_entry>/<changedx>
<String[Key='Password']> | <history_entry>/<oldpassword>
All other tags from <History> | Ignored

The following KeePass V2 Auto-type special codes (see http://keepass.info/help/base/autotype.html) are translated as follows. All codes not listed are copied across as-is.

KeePass V2 Auto-type | Password Safe Equivalent
\ | \\ (escaping '\')
Tab {TAB} | \t
Enter {ENTER} or ~ | \n
Backspace {BACKSPACE}, {BS} or {BKSP} | \b
Keypad + {ADD} | +
Keypad - {SUBTRACT} | -
Keypad * {MULTIPLY} | *
Keypad / {DIVIDE} | /
+ {+} | +
^ {^} | ^
% {%} | %
~ {~} | ~
(, ) {(}, {)} | (, )
{DELAY X} Delays X milliseconds. | \wX (\WX)
{DELAY=X} Sets the default delay to X milliseconds for all standard keypresses in this sequence. | \dX

The following KeePass V2 Platzhalter (see http://keepass.info/help/base/placeholders.html) are translated as follows. All codes not listed are copied across as-is.

Platzhalter achten nicht auf Groß- oder Kleinschreibung. Custom strings can be referenced using {S:Name}. For example, if the database has a custom string named "eMail", it can be referenced via the Placeholder {S:eMail}.

KeePass V2 Platzhalter | Password Safe Autom. Eingabe | Password Safe Kommando ausführen
{GROUP} | \g | ${G}
{TITLE} | \i | ${t}
{USERNAME} | \u | ${u}
{PASSWORD} | \p | ${p}
{NOTES} | \o | ${n}

KeePass V2 Platzhalter | Password Safe Kommando ausführen
\{ | \\{ (escaping \)
$ | \$ (escaping $)
{GROUPPATH} | ${g}
{URL} | ${url}
{URL:RMVSCM} | ${url}
{APPDIR} | ${appdir}
{DB_PATH} | ${fulldb}
{DB_DIR} | ${dbdir}
{DB_NAME} | ${dbname}.${dbextn}
{DB_BASENAME} | ${dbname}
{DB_EXT} | ${dbextn}
All others | Copied unchanged


Einträge exportieren

Password Safe unterstützt das Exportieren (und Importieren) der gespeicherten Passwörter in (und von) verschiedenen Formate. Das Exportieren von Daten erreichen Sie im Menü Datei->Exportiere zu. Die unterstützten Formate sind:

  • Password Safe v1 (zur Verwendung mit Version 1.x von Password Safe)
  • Password Safe v2 (zur Verwendung mit Version 2.x von Password Safe)
  • Text
  • XML

Für frühere Versionen von Password Safe wählen Sie einfach das gewünschte Format und definieren Sie den Namen der Passwortdatenbank.

Zusätzlich können Sie auch folgendes machen, um eine Untermenge an Einträge und/oder Gruppen in eine anderen Datenbank zu 'exportieren'. Vorausgesetzt Sie haben mehrere Instanzen erlaubt -siehe hierzu Verwalten->Optionen->System-, starten Sie Password Safe nochmal, und erstellen die neue Datenbank. Die andere Datenbank ist während dessen auch geöffnet. Sie können dann einfach per Drag und Drop jeden Eintrag bzw. Gruppe von der alten in die neue Datenbank 'exportieren'.

Export verwendet ein Wizard Schnittstelle Sie k&onnen auch "Erweitertes Feld für Auswahlkriterien" auswählen um die zu exportierende Einträge und dessen Felder einzuschränken. Siehe hier für mehr Information.

Ein Bericht zu den ausgeführten Aktionen steht nach dem Abschluß zur Verfügung. Dieser Bericht kann dann als Textdatei in die Zwischenablage oder auf Festplatte kopiert werden, im selben Verzeichnis wie die Datenbank. Mit dem Menüpunkt "Ansicht → Berichte" können die Berichte tu einem späteren Zeitpubkt angeschaut werden. Der Name des Berichtes ist festgelegt, und hängt ab von der Funktion mit der er erzeugt wurde. Wenn dieselbe Funktion ausgeführt, und der entsprechende Bericht auf die Festplatte abgespeichert wird, wird jegliche Bericht zu dieser Funktion überschrieben. Hinweis: Der Bericht kann sensible Daten enthalten, so Vorsicht ist geboten beim Abspeichern auf die Festplatte.

Text Export

Hinweis: Der exportierte Text ist eine ungeschützte Kopie der Passworteinträge. Das Löschen dieser Datei nach deren Verwendung ist nicht ausreichend, um Sie für einen Angreifer unzugänglich zu machen. Im Gegenteil, hiermit umgehen Sie bewusst die Sicherheit der Anwendung.
Bitte verwenden Sie diese Möglichkeit NICHT, außer Sie verstehen und akzeptieren die Risiken.

Password Safe unterstützt das Exportieren von Passworteinträgen in Textdateien. Diese Dateien können dann von anderen Anwendungen verwendet und bearbeitet werden.

Zuerst werden Sie aufgefordert das Master-Passwort als Bestätigung, dass Sie die Datenbank in eine unverschlüsselte reine Textdatei exportieren möchten, einzugeben. Sie werden ebenfalls nach dem Namen einer neuen Datei gefragt, und ev. um eine Bestätigung das Überschreiben zu erlauben, wenn die Datei schon besteht im angegebenen Verzeichnis.

Export Text

Sie können einige Optionen angeben:

  • Die Felder der Passworteinträge werden beim Export mit TAB-Zeichen getrennt. Die Felder sind Gruppe.Titel, Benutzername, Passwort und Notizen. Das Feld Gruppe.Titel wird als ein Feld betrachtet. Wenn ein Feld Leerzeichen enthält, wird es in Gänsefüßchen gesetzt. Nur das Feld Notizen kann mehrere Zeilen enthalten. Normalerweise würde man jeden Zeileneintrag in eine neue Zeile ablegen. Dies macht aber ein Vergleich zwischen mehreren exportierten Dateien ungleich schwerer. Um dies zu verhindern, kann beim Export für das Zeilenende ein Trennzeichen definiert werden. Wenn Sie eine solche Datei mit Trennzeichen wieder importieren (dieses Trennzeichen muss definiert sein) wird es wie eine gesamte Zeile in die Datenbank erscheinen.
    Wenn gewünscht, können Sie ankreuzen, ob Sie alle getrennten Zeilen im Feld Notizen in einer Zeile ablegen wollen und geben Sie das Trennzeichen an. Weil das gesamte Feld Notizen in Gänsefüßchen gesetzt wird, wird dieses Zeichen anschließend nicht als Trennzeichen für Zeilen erkannt.

Erweiterte Optionen f¨r Text Export

Nach dem Markieren von "Erweitertes Feld für Auswahlkriterien" wird dieser Assistent geöffnet. Er hilft beim Festlegen der Texte zur Auswahl der Einträge und/oder beim Spezifizieren welche Felder exportiert werden sollen. Siehe hier für mehr Information.

Hinweis: Details zum Format der exportierten Textdatei finden Sie im Kapitel "Text Export & Import Format".

XML

XML (eXtensible Markup Language) ist ein populäres Format, um Daten zwischen Anwendungen zu übertragen. Password Safe kann Datenbankeinträge in diesem Format exportieren (und importieren). Die Struktur (oder Schema) womit die Daten exportiert und validiert werden, steht in der Datei pwsafe.xsd. Sie ist Teil dieser Distribution. Diese Datei wird verwendet, wenn Password Safe XML Daten importiert und sollte den Anwendungen, die diese exportierten Daten verwenden wollen, zur Verfügung gestellt werden.
Hinweis: Der exportierte Text ist eine ungeschützte Kopie der Passworteinträge. Das Löschen dieser Datei nach deren Verwendung ist nicht ausreichend, um sie für einen Angreifer unzugänglich zu machen. Im Gegenteil, hiermit umgehen Sie bewusst die Sicherheit dieser Anwendung.
Bitte verwenden Sie diese Möglichkeit NICHT, außer Sie verstehen und akzeptieren die Risiken.
Die Ansicht der XML Dateien ist festgelegt in pwsafe.xsl - eine eXtensible Stylesheet Language Datei. Eine Beispieldatei ist der Distribution beigefügt. Sie können diese nach eigenen Bedürfnissen abändern. Diese Datei ist nur ein Beispiel, und sie ist einfach zu ändern, um die Felder anzuzeigen, die Sie brauchen. Weil dies nur die Anzeige der Daten und nicht die Daten selbst ändert, sind Sie immer noch in der Lage es in Password Safe zu einem späteren Zeitpunkt zu importieren.

Wie beim Text Exportieren können Sie definieren welche Einträge und Felder zur XML Datei exportiert werden sollen: durch Klicken auf "Erweitert" im Export Dialog. Dies wird folgender Dialog aufmachen:
Erweiterte XML Export Optionen

Nach dem Markieren von "Erweitertes Feld für Auswahlkriterien" wird dieser Assistent geöffnet. Er hilft beim Festlegen der Texte zur Auswahl der Einträge und/oder beim Spezifizieren welche Felder exportiert werden sollen. Bemerkung: Das XML Schema setzt Titel und Passwort zwingend voraus. Aus diesem Grund können diese nicht abgewählt werden. Siehe hier für mehr Information


Filter

Filter können im Ansicht erreicht werden.

Filter Menu

Ein "Filter" ist ein Kriterium (oder ein Satz an Kriterien), ob ein Eintrag dem Filter entspricht oder auch nicht. Password Safe erlaubt es Filter zu definieren, um nur die Einträge anzuzeigen, die dem gegebenen Filter entsprechen. Sie können das Filter für eine einmalige Abfrage hernehmen, oder Sie können die Filter mit Namen versehen und dauerhaft abspeichern. Filter können in der Datenbank abgelegt werden, oder extern, um die Filter für mehrere Datenbanken gemeinsam verwenden zu können.

Filter definieren

Um ein neues Filter zu definieren, wählen Sie das Menü Ansicht->Filter->Filter neu/bearbeiten aus. Folgender Dialog wird angezeigt:

Dialog Anzeigefilter setzen

Wie Sie sehen, besteht jedes Filter aus einer oder mehreren Zeilen, wobei jede dieser Zeilen ein Kriterium für ein gegebenes Feld umfasst. Die Bedingungen, die in jeder Zeile definiert sind, können entweder "und" oder "oder" der Bedingung in der vorherigen Zeile sein. Auf diese Weise können Sie Filter zusammenstellen wie:

  1. Alle Einträge mit dem Benutzernamen "josef" oder "Josef" oder "JOSEF":
    Beispiel 1
  2. Alle Einträge mit dem Benutzernamen "Josef" erstellt nach dem 18ten Januar 2009
    Beispiel 2
  3. Alle Einträge mit den Benutzernamen "Josef" oder "Maria"
    Beispiel 3

Wie Sie sehen können, können Filter einigermaßen komplex werden.

Die Spalten im Filter sehen wie folgt aus:

  • '#' - Dies ist die Zeilennummer. Sie wird nur aus Bequemlichkeit angezeigt, und kann nicht geändert werden.
  • '?' - Dies markiert, ob die Zeile aktiv ist oder nicht. Nur aktive Zeilen werden angewandt, wenn das Filter eingesetzt wird. Mit Klicken kann die Markierung für die jeweilige Zeile ein- bzw. ausgeschaltet werden.
  • '+' - Dies fügt beim Klicken eine neue Zeile unterhalb der jetzigen Zeile ein.
  • '-' - Dies löscht die aktuelle Zeile. Hinweis: Das Löschen einer Zeile ist unwiderruflich. Vielleicht wäre es besser sie nur zu deaktivieren mit '?'.
  • 'Und/Oder' - Dies erlaubt die Festlegung der Verknüpfung zwischen dieser Regel und der Regel in der Zeile darüber.
  • 'Feld' - Wählt das gewünschte Feld aus, z.B. Benutzername, Titel, Gruppe, Notizen, usw.
  • 'Kriterien' - Stellt den gewünschten Wert für das ausgewählte Feld ein. Wenn Sie einmal ein Feld ausgewählt haben, klicken Sie darauf und ein Dialog wird dann angezeigt womit Sie die erforderlichen Kriterien festlegen können.

Filter anwenden

Nach der Definition eines Filters, genügt das Anklicken von 'Übernehmen', damit das Filter auf die Einträge in der Datenbank angewendet wird. Der Filterdialog bleibt offen. Dies ist nützlich, um die Filterung basierend auf den erreichten Ergebnissen anzupassen und zu verfeinern. Mit Klicken auf 'OK' wird das Filter ausgeführt und der Filterdialog verlassen.

Wenn ein Filter aktiv ist, wird die gefilterte und die gesamte Anzahl Einträge in der Datenbank in der Statuszeile angezeigt. Ein rot-weißes Symbol ( Filter aktiv) erscheint ganz rechts. Die Einträge selber werden rot dargestellt.

Filter abgelaufene Passwörter

Filter Verwalten

Filter definieren und editieren ist ein einfacher und bequemer Weg sie anzuwenden, aber nur für einmal. Wenn Sie allerdings wünschen, öfter mehrere Filter anzuwenden, dann können Sie diese abspeichern und im Dialog Ansicht->Filter->Verwalten auf einfache Art und Weise verwalten.

Filter verwalten

Der Dialog 'Verwalte Filter' hat zwei Tabellen. Die obere listet die Filter auf, und die untere listet die Elemente des ausgewählten Filters auf.
  • Um ein neues Filter einzufügen, klicken Sie auf 'Neu'. Dies ist das Gleiche wie Menü Ansicht->Filter->Filter neu/bearbeiten.
  • Um ein Filter zu bearbeiten, klicken Sie es an, und drücken Sie 'Bearbeiten'.
  • Um ein bestehendes Filter anzuwenden, klicken Sie auf 'Übernehmen' in der gewünschten Filterzeile. Beachten Sie dabei, dass nur ein Filter zur selben Zeit angewendet werden kann.

Filter speichern

Filter können entweder als Teil der aktuellen Datenbank abgespeichert werden, oder extern als XML Datei. Das externe Abspeichern von Filtern ist ein guter Weg, um Filter über mehrere Datenbanken gemeinsam verwenden zu können. Das Abspeichern in die Datenbank hingegen stellt sicher, dass eventuell sensible Informationen in den Filtern geschützt sind (und bleiben).
  • Um Filter in einer externen Datei auszulagern: markiere 'Exportieren' in eine oder mehrere der gewünschten Filterzeilen, dann klicken Sie auf die Taste 'Exportieren'.
  • Um Filter in die aktuelle Datenbank auszulagern: markiere 'Zur DB kopieren' und klicken Sie dann auf die Taste 'Kopieren'.
  • Um extern gespeicherte Filter zu laden: klicken Sie auf die Taste 'Importieren'.
Hinweis:
Beim Starten sucht Password Safe nach einer Datei mit dem Namen autoload_filters.xml im selben Verzeichnis, in welchem die Datei pwsafe.cfg steht (standardmäßig das Verzeichnis, in welchem Password Safe installiert ist). Wenn diese Datei besteht, dann wird sie automatisch importiert und die enthaltenen Filter stehen von Anfang an zur Verfügung. Dies ist dann nützlich, wenn Sie Filter definiert haben, die Sie über mehrere Datenbanken anwenden wollen, ohne sie jedes Mal von Hand importieren zu müssen.


Kommandozeilen Argumente

Wenn Sie Password Safe ohne Argumente aufrufen, wird die Anwendung nach dem Master-Passwort der zuletzt geöffneten Datenbank fragen, oder nach dem Master-Passwort für eine neue Datenbank, wenn vorher noch keine auf Ihrem Computer eröffnet wurde (z.B. bei der erstmaligen Anwendung von Password Safe). Es ist aber auch möglich dies durch Aufrufen von Password Safe wie folgt abzuändern:

  • pwsafe Datenbank
    Dies wird die angegebene Datenbank öffnen, anstelle der zuletzt geöffneten. Wenn nur ein Dateiname ohne Pfad angegeben ist, wird in dem Verzeichnis gesucht, aus welchem die Anwendung aufgerufen wurde. Wenn im Dateinamen und/oder der Pfad Leerzeichen vorkommen, sollte es mit Gänsefüßchen eingeschlossen sein.
  • pwsafe -r Datenbank
    Dies wird die angegebene Datenbank in NUR-Lese Modus öffnen.
  • pwsafe -e Dateiname
    Hierbei wird der Benutzer aufgefordert, eine Passphrase (ein Kennwort bestehend aus mehreren Wörtern) einzugeben. Die Datei wird anschließend mit einem Schlüssel, der von der Passphrase abgeleitet wurde, verschlüsselt. Bemerkung: Die Datei kann jede Art von Datei sein. Die verschlüsselte Datei hat denselben Dateinamen, mit der angehängten Erweiterung ".PSF".
  • pwsafe -d Dateiname
    Hierbei wird der Benutzer aufgefordert eine Passphrase (ein Kennwort bestehend aus mehreren Wörtern) einzugeben. Die Datei wird anschließend entschlüsselt mit einem Schlüssel der von der Passphase abgeleitet ist. Bemerkung: Dies wird nur funktionieren mit Dateien die vorher mit pwsafe und dem Argument '-e' aufgerufen wurden (siehe oben).
  • pwsafe -c
    Dies wird die Anwendung starten, ohne dass eine Datenbank geöffnet wird. Auch der anfängliche Eröffnungsdialog wird nicht ausgeführt. (Um eine Datenbank zu eröffnen, gehe zum Menü Datei).
  • pwsafe -s [Datenbank]
    Dies wird die Anwendung "leise" (silent) starten, d.h. minimiert und ohne Datenbank. Wenn die Datenbank aus der Minimierung rausgeholt wird, erscheint der Eröffnungdialog. (Diese Option wird eingesetzt, um die Anwendung bei der Benutzeranmeldung zu starten mit einer Verknüpfung im Startverzeichnis). Bemerkung: Dies stellt die Anwendung implizit in die Systemleiste.
  • pwsafe -m
    Dies ist dasselbe wie '-c'. Außerdem wird die Anwendung minimiert gestartet.
Zusätzlich werden folgende Argumente akzeptiert:
Diese Argumente könnten nützlich sein, wenn Sie dieselben Einstellungen über mehrere Maschinen gemeinsam benutzen möchten, z.B. wenn Sie Password Safe aus einer disk-on-key betreiben.
  • -u Benutzername
    Hiermit kann die Anwendung angehalten werden, das Lesen und Schreiben der Einstellungen unter dem angegebenen Benutzername zu machen, anstatt es unter dem Anmeldenamen zu tun.
  • -h Rechnername
    Hiermit kann die Anwendung angehalten werden, das Lesen und Schreiben der Einstellungen auf dem angegebenen Rechnernamen zu machen, anstatt es unter dem Maschinennamen zu tun.
  • -g konfig_datei
    Hiermit kann die Anwendung angehalten werden, die angegebene Datei für das Laden und Abspeichern der Einstellungen zu verwenden, anstatt der standardmäßige pwsafe.cfg. Wenn nur eine Dateiname ohne Pfad angegeben ist, wird in dem Verzeichnis gesucht, aus welchem die Anwendung aufgerufen wurde. Wenn im Dateinamen und/oder der Pfad Leerzeichen vorkommen, sollte es in Gänsefüßchen eingeschlossen sein.

Zu guter letzt, sind da noch ein paar spezielle Kommandozeilen 4flags die mit "--" beginnen. Dies sind:

  • --novalidate
    Dies verhindert dass Password Safe automatisch Datenbanken validiert beim Eröffnen. Einige Sachen müssen aber immer validiert werden, z.B. Eindeutichkeit der ID der Einträge und der Kombination Gruppe / Titel / Benutzername.
  • --testdump
    Dies erlaubt es Testern bei der Erstellung eines Mini-Dump, wenn Password Safe ein Problem hat, um die Entwickler bei der Lösung zu helfen.
  • --cetreeview
    Dieses neue Merkmal erlaubt es zwei Einträge auszuwählen und zu vergleichen im Bearbeiten Menü oder durch ein Rechtsklick auf einem Eintrag. Die Auswahl mehrere Einträge wird von Hause aus in der Listenansicht unterstützt, aber nicht in der Baumstruktur. Dieses Flag schaltet Vergleiche Eintrag frei, mit einem extra Dialog um den 'anderen' Eintrag auszuwählen. Die Unterstützung dieses Merkmales in der Baumstruktur wird noch entwickelt. Wenn es implementiert ist, wird dieses Flag ignoroert.


Menü Datei

Menü Datei

Das Menü Datei enthält die Punkte, um Password Safe Datenbanken erstellen und bearbeiten zu können.

Neu

Erstellt eine neue leere Password Safe Datenbank.

Öffnen

Öffnet eine bereits bestehende Password Safe Datenbank.

Schließen

Schließt die aktuell geöffnete Password Safe Datenbank, ohne die Anwendung zu verlassen.

Zuletzt

Dieser Teil im Menü Datei enthält die Liste der zuletzt geöffneten Datenbanken. Diese Liste ist leer beim ersten Einsatz von Password Safe.

Hinweis:
  • Die Liste der zuletzt geöffneten Dateien kann gelöscht werden, wenn Sie "Aktuelle Liste löschen" auswählen.
  • Die Anzahl der zuletzt geöffneten Dateien die sich Password Safe merkt kann mit dem Dialog Verwalten->Optionen->System eingestellt werden. Hier können Sie auch festlegen ob Sie die Liste im Menü Datei sehen wollen, oder lieber in einem Untermenü.

Speichern

Speichert jede Änderung zur aktuellen Datei ab. Wenn seit der letzten Speicherung keine Änderungen gemacht wurden, oder wenn die Datenbank im NUR Lesen Modus geöffnet wurde, ist dieser Punkt ausgegraut.

Speichern unter

Speichert eine Kopie der aktuellen Datenbank mit neuem Namen und Speicherort ab.

Exportiere zu

Exportiert den Inhalt der aktuellen Datenbank zu einer externen Datei in einem früheren Password Safe Datenbankformat, in XML, oder als Text ab. Siehe hier für mehr Information wie man Datenbanken exportiert in anderen Formaten.

Importiere von

Importiert den Inhalt einer früher exportierten oder korrekt formatierten Textdatei, XML, oder eine KeePass Passwort Datenbank in die aktuelle Datenbank. Siehe hier für mehr Information wie man Textdateien importiert.

Zusammenführen

Führt eine Password Safe Datenbank oder ein Sicherungskopie (.bak) zusammen mit der aktuellen Datenbank. Dies ist im NUR Lesen Modus gesperrt.

Vergleichen

Vergleicht die aktuell geöffnete Datenbank mit einer anderen Password Safe Datenbank.

Synchronisieren

Synchronisiert die aktuell geöffnete Datenbank mit einer anderen Password Safe Datenbank. Dies ist im NUR Lesen Modus gesperrt.

Der Unterschied zwischen Zusammenführen und Synchronieren besteht in der Tatsache das beim Zusammenführen sämtliche Elemente aus der synchonisierenden Password Safe Datenbank in die aktuell geöffneten Datenbank übernommen werden, beim Synchronisieren werden nur die in der aktuell geöffneten Datenbank vorhandenen Elemente abgearbeitet.

Hinweis: Die Punkte Zusammenführen, Vergleichen und Synchronisieren können einige Zeit in Anspruch nehmen, vor allem bei große Datenbanken.

Zu R-O ändern

Die aktuell geöffnete Datenbank ist entweder im Modus R-O (read only = nur Lesen) oder Modus R/W (read / write = Lesen / Schreiben). Zwischen diese beiden Modi kann umgeschaltet werden.

Hinweis: Ein in Modus R-O geöffnete Datenbank kann nur dann in Modus R/W umgeschaltet werden, solange keine Änderung vorgenommen wurde.

Eigenschaften

Zeigt Informationen zur aktuell geöffneten Password Safe Datenbank an, wie da sind: Format, Version, Anzahl Gruppen, Anzahl Einträge, wer was zuletzt gespeichert hat. Der Name der Datenbank und eine Beschreibung derselben können bearbeitet werden.

Password Safe Eigenschaften

Beenden

Beendet die Password Safe Anwendung. Wenn seit der letzten Speicherung noch Änderungen vorgenommen wurden, werden Sie aufgefordert die Datenbank abzuspeichern.

Berichte

Hinweis: Die Aktionen Vergleichen, Exportieren, Inportieren, Zusammenführen und Synchronisieren erzeugen alle einen Bericht. Dieser Bericht kann eingesehen werden, und dann in die Zwischenablage oder als Datei kopiert werden als Textdatei im selben Verzeichnis wie die Datenbank. Das Menü "Ansicht → Berichte" kann dazu verwendet werden diese Berichte zu einem späteren Zeitpunkt anzuschauen. Der Name der Berichtsdatei ist fest eingestellt und abhängig von der Funktion die den Bericht erzeugt hat. Wenn dieselbe Funktion wieder ausgeführt wird, und der Bericht wird als Datei abgespeichert, wird der vorherige Bericht unweigerlich überschrieben. Hinweis: Der Bericht kann empfindliche Daten enthalten, und darum ist es ratsam die Funktion Auf Festplatte Speichern mit Bedacht auszuführen.

file menu


Menü Bearbeiten

Eintrag | Alias | Gruppe
Menü Eintrag Bearbeiten | Menü Alias Bearbeiten | Menü Gruppe Bearbeiten

Im Menü Bearbeiten können Benutzernamen und Passwörter eingefügt, bearbeitet, angewendet und organisiert werden. Beachten Sie dass die Menü-Inhalte sich in Funktion von dem was in der Hauptanzeige ausgewählt ist, ändern können (z.B. wenn Sie einen Eintrag oder eine Gruppe ausgewählt haben). Es könnten auch einige Elemente deaktiviert sein, wie weiter unten erwähnt.

Eintrag einfügen

Benutzernamen und Passwort werden eingefügt. Dies ist deaktiviert, wenn eine Datenbank in NUR-Lesen Modus geöffnet ist.
Siehe Benutzernamen, Passwörter und Gruppen für mehr Information.

Eintrag bearbeiten / Gruppe ausklappen/zuklappen

Wenn ein Eintrag ausgewählt ist, den ausgewählten Benutzernamen und Passwort bearbeiten. Wenn eine Gruppe ausgewählt ist (in Baumdarstellung), wird dies die Einträge der ausgewählten Gruppe aus- bzw. zuklappen. Das Bearbeiten eines Eintrages ist deaktiviert, wenn eine Datenbank in NUR-Lesen Modus geöffnet ist.
Siehe Benutzernamen, Passwörter und Gruppen für mehr Information.

Eintrag löschen / Gruppe löschen

Wenn ein Eintrag ausgewählt ist, wird dieser Eintrag gelöscht. Wenn eine Gruppe ausgewählt ist (in Baumdarstellung), wird diese Gruppe mit allen sich darin befindlichen Einträgen gelöscht. Dies muss bestätigt werden, wenn mehr als ein Eintrag in der ausgewählten Gruppe vorhanden ist. Dies ist deaktiviert, wenn eine Datenbank in NUR-Lesen Modus geöffnet ist.

Eintrag umbenennen / Gruppe umbenennen

Der ausgewählte Eintrag wird umbenannt (oder Gruppe, in Baumdarstellung). Dies ist deaktiviert, wenn eine Datenbank in NUR-Lesen Modus geöffnet ist.

Suchen

Suche nach einem gegebenen Text in den Einträgen. Standardmäßig werden alle Felder durchsucht, mit Ausnahme der Passwörter.
Siehe Suchen für mehr Information.

Eintrag duplizieren

Der ausgewählte Eintrag wird dupliziert. Dies ist deaktiviert, wenn eine Datenbank in NUR-Lesen Modus geöffnet ist.

Gruppe einfügen

Es wird eine neue Passwortgruppe eingerichtet (z.B. Bank Passwörter). Dies ist deaktiviert, wenn eine Datenbank in NUR-Lesen Modus geöffnet ist.

Rückgängig

Die zuletzt ausgeführte Aktion wird rückgängig gemacht.

Wiederholen

Die zuletzt rückgängig gemachte Aktion wird wiederhergestellt.

Zwischenablage löschen

Löscht die Zwischenablage. Dies löscht in der Zwischenablage nur die Sachen, die von Password Safe (Passwort, Benutzername, Notizen, usw.) stammen. Wenn der momentane Inhalt in der Zwischenablage nicht von Password Safe stammt, dann passiert damit nichts.

Passwort in Zwischenablage kopieren

Kopiert das Passwort vom ausgewählten Eintrag in die Zwischenablage.

Teilmenge des Passwortes anzeigen

Im oberen Feld des Dialoges können Sie die Positionen der Zeichen im Passwort eingeben, die sie für die Teilmenge des Passwortes benötigen. Als Trennzeichen dient das Leerzeichen, das Komma oder der Strichpunkt. Im unteren Feld werden die Zeichen, die mit den Positionen übereinstimmen, angezeigt. Aus diesem Dialog kehren sie mit Esc zurück.

Benutzername in Zwischenablage kopieren

Kopiert den Benutzernamen vom ausgewählten Eintrag in die Zwischenablage.

Notizen in Zwischenablage kopieren

Kopiert den Inhalt der Notizen vom ausgewählten Eintrag in die Zwischenablage.

URL in Zwischenablage kopieren

Kopiert die URL des ausgewählten Eintrages in die Zwischenablage.

Email in Zwischenablage kopieren

Kopiert die Email Adresse des ausgewählten Eintrages in die Zwischenablage.

Kommando Ausführen in Zwischenablage kopieren

Kopiert das auszuführende Kommando des ausgewählten Eintrages in die Zwischenablage.

Hinweis: Variablen werden in der Regel mit den entsprechenden Werte ersetzt, ausser die Strg Taste ist gedrückt bei der Asuwahl dieses Menüpunktes.

Gehe zu URL

Wenn ein Eintrag ausgewählt ist, und es ist eine URL mit diesem Eintrag verbunden, dann wird der standardmäßige Browser mit dieser URL aufgerufen. Wenn kein Eintrag ausgewählt ist, oder es ist keine URL mit diesem Eintrag verbunden, dann ist dieser Menüpunkt deaktiviert.

Wenn nicht im Reiter "Verwalten → Optionen → Sicherheit" anders eingestellt, wird das Passwort eines Eintrages in die Zwischenablage kopiert.

Gehe zu URL + Autom. Eingabe

Wenn ein Eintrag ausgewählt ist, und es ist eine URL mit diesem Eintrag verbunden, dann wird der standardmäßige Browser mit dieser URL aufgerufen. Wenn kein Eintrag ausgewählt ist, oder es ist keine URL mit diesem Eintrag verbunden, dann ist dieser Menüpunkt deaktiviert.

Benutzername und Passwort werden ebenfalls automatisch in das ausgewählte Eingabeformular eingefügt.
Siehe Autom. Eingabe anwenden für mehr Information.

Email senden

Eine Email an die Email-Adresse des ausgewählten Eintrages wird vorbereitet.
Siehe Benutzernamen, Passwörter und Gruppen für mehr Information.

Autom. Eingabe ausführen

Benutzername und Passwort werden automatisch in das ausgewählte Eingabeformular eingefügt.
Siehe Autom. Eingabe anwenden für mehr Information.

Kommando Ausführen

Mit dieser Auswahl führen sie das Kommando, welches im Feld Ausführen eines Eintrages enthalten ist, aus.
Siehe Kommando ausführen für mehr Information.

Verknüpfung erstellen

Wenn ein Eintrag ausgewählt ist, erstellen Sie hiermit eine Verknüpfung zu diesem Eintrag; typischerweise angewendet in einer Gruppe. Dies ist dann nützlich, wenn einen Eintrag zu mehreren Gruppen gehören soll, ohne dass Sie die Daten duplizieren müssen. Diese Verknüpfung wird durch ein gesondertes Symbol shortcut angedeutet und hat standardmäßig den Namen "Verküpfung mit x", wo x der Name des originalen Eintrages ist. Natürlich kann diese Verknüpfung bearbeitet, gelöscht oder verschoben werden, wie jeder normaler Eintrag auch.

Gehe zum Basiseintrag

Dieser Punkt kommt nur dann vor, wenn Sie ein verknüpfter Eintrag oder ein Alias-Eintrag anklicken. Nach einem Klick auf Gehe zum Basiseintrag wird der Basiseintrag, der zu diesem Eintrag gehört, ausgewählt.

Basiseintrag bearbeiten

Dieser Punkt kommt nur dann vor, wenn Sie ein verknüpfter Eintrag oder ein Alias-Eintrag anklicken. Nach einem Klick auf Basiseintrag bearbeiten kann der Basiseintrag, der zu diesem verknüpften oder Alias-Eintrag gehört, bearbeitet werden.

Exportiere Eintrag als Text

Der ausgewählte Eintrag wird als Text exportiert. Vorerst werden Sie aufgefordert das Master-Passwort als Bestätigung, dass Sie ein Element aus der Datenbank in eine unverschlüsselte reine Textdatei exportieren möchten, einzugeben.
Siehe auch Einträge exportieren für mehr Information.

Exportiere Eintrag in XML Format

Der ausgewählte Eintrag wird als XML exportiert. Vorerst werden Sie aufgefordert das Master-Passwort als Bestätigung, dass Sie ein Element aus der Datenbank in eine unverschlüsselte reine Textdatei exportieren möchten, einzugeben.
Siehe auch Einträge exportieren für mehr Information.

Schütze Eintrag / alle Einträge

Der Eintrag bzw. alle Einträge werden geschützt vor jegliche Änderung. Geschützte Einträge sind mit einem '#' gekennzeichnet.

Rechtsklick Bearbeiten

Fast alle Punkte im Menü Bearbeiten können auch mit einem rechten Mausklick auf den entsprechenden Eintrag, Alias bzw. Gruppe erreicht werden.

Eintrag | Alias | Gruppe
Menü Eintrag Bearbeiten | Menü Eintrag Bearbeiten | Menü Gruppe Bearbeiten

All diese Menüpunkte sind im Kapitel Menü Bearbeiten oben abgehandelt worden.


Menü Ansicht

Menu Ansicht

Das Menü Ansicht kontrolliert die vorhandenen Anzeigemöglichkeiten. Sie können umschalten zwischen den verschiedenen Darstellungsarten, wie Benutzernamen und Passwörter eines Eintrages dargestellt werden: entweder als einfache Tabelle oder als Baumstruktur. Sie können wählen ob Sie die Toolleiste anzeigen oder nicht, und wenn ja, ob Sie die klassische oder die moderne Darstellung verwenden wollen. Die Toolleiste selber kann angepasst werden. In der Baumdarstellung kann alles ausgeklappt werden, oder zugeklappt. Die Einträge können gefiltert werden nach irgendwelchen Kriterien. Die Schriftart für die Anzeige kann ausgewählt werden. Berichte zum Zusammenführen (merge), Vergleichen, Importieren und andere erweiterte Operationen können ebenfalls dargestellt werden.

Umschalten zwischen Tabelle und Baumstruktur

  1. Gehen Sie zum Menü Ansicht
  2. Wählen Sie Tabelle oder Baumstruktur aus

Einstellung der Toolleiste

Um die Toolleiste anzuzeigen oder zu verbergen, markieren Sie das Element Toolleiste sichtbar oder nicht.

Um die "klassische" oder die "moderne" Symbole für die Toolleiste zu setzen, wählen Sie das Element "Klassische Toolleiste" oder "Moderne Toolleiste" aus.

Die "Dragleiste" ist eine spezielle Toolleiste, die es erlaubt vom ausgewählten Eintrag bestimmte Elemente zu "ziehen" (drag). Mit dem Bild in der Dragleiste können die Elemente gezogen werden, die Sie in einem anderen Fenster kopiert haben wollen. Zum Beispiel, um die Notizen von einem bestimmten Eintrag zu einem Fenster in einer anderen Anwendung zu ziehen mit Hilfe der Dragleiste, wählen Sie den Eintrag aus, und ziehen Sie das Symbol "N" aus der Dragleiste in die Anwendung. Wenn Sie die Maustaste loslassen, wird der Inhalt vom Notizen-Feld in die Anwendung kopiert. In der Dragleiste sind die Elemente die im ausgewählten Eintrag leer sind, ausgegraut.

Hinweis:Es scheint ein Problem zu bestehen beim Einsetzen der neuen Autom. Eingabe in der Dragleiste mit dem Internet Explorer (getestet mit V7, V8 & V9): alle Zeichen vor dem ersten Tabulator gehen verloren. Dies passiert NICHT beim Firefox und Chrome Browser. Obwohl wir dafür eine Lösung haben (wir senden TAB und Shift-TAB, um zum ausgewählten Fenster zurück zu kehren, aber nur aus der Dragleiste), funktioniert dies (als unschöne Nebenerscheinung) nur beim Ersetzen eines bereits vorhandenen String im Eingabefeld. Wenn ins Fenster einer andere Anwendung gezogen wird, wird das Endergebnis davon abhängen wie diese Anwendung mit TAB und Shift-TAB umgeht.

Um die Dragleiste anzuzeigen bzw. zu verbergen, markieren Sie das Element Dragleiste sichtbar oder nicht.

Folgende Symbole sind in der Dragleiste vorhanden:

  • "G" = Gruppe
  • "T" = Titel
  • "U" = Benutzer ('U'ser)
  • "P" = Passwort
  • "N" = Notizen
  • "B" = URL ('B'rowse)
  • "E" = E-Mail
  • "A" = Autom. Eingabe.

Alle ausklappen

Klappt alle Gruppen aus, sodass sämtliche Einträge sichtbar sind. (nur in der Baumstruktur).

Alle zuklappen

Klappt alle Gruppen zu (nur in der Baumstruktur).

Aktualisieren F5

Durch Betätigen der Taste F5 oder durch Drücken dieses Menüpunktes kann die Anzeige der vorhandenen Daten aktualisiert werden.

Zeige ungespeicherte Änderungen

Wenn das Feld "Datenbank sofort nach Bearbeiten oder Einfügen speichern" in den Verwalten → Optionen → Sicherungen nicht markiert ist, werden die geänderten Felder nicht sofort abgespeichert, sondern farblich gekennzeichnet. Siehe hierzu auch das nächste Bild:

Daten mit Änderungen
Die Übersicht mit allen Einträgen

Durch Markieren dieses Menüpunktes werden -zur Übersicht- ausschließlich die geänderten Felder angezeigt.

Daten, nur die Änderungen
Die Übersicht, ausschließlich der geänderten Einträge.

Bemerkung: Solange überhaupt geänderte aber noch nicht abgespeicherte Einträge vorhanden sind, erscheint in der Statuszeile ein "*".

Zeige Einträge mit Ablaufdatum

Durch Markieren dieses Menüpunktes werden -zur Übersicht- ausschließlich die Einträge angezeigt, die ein Ablaufdatum haben.

Wenn gar keine Einträge mit Ablaufdatum vorhanden sind, ist dieser Menüpunkt ausgegraut.

Filter

Ein "Filter" ist ein Kriterium (oder ein Satz an Kriterien) mit dem ein Eintrag übereinstimmt oder nicht. Password Safe erlaubt es Filter zu definieren und nur die Einträge anzuzeigen die mit einem gegebenen Filter übereinstimmen. Für mehr Informationen wie Filter zu definieren und verwenden sind, siehe hier.

Schriftart wechseln

Change Fonts

Wählen Sie eine andere Schriftart aus, um Einträge in der Tabellenansicht oder Baumstruktur darzustellen. Dies gilt ebenso für die Darstellung der Passwörter im Menü Einfügen bzw. Bearbeiten.

Sie können ebenfalls die Schriftart für die virtuelle Tastatur festlegen. Achten Sie darauf das diese Schriftart Unicode Zeichen darstellen können muss. Die unterstützte Schriftarten sind: "Arial Unicode MS" (kommt mit Microsoft's Office suite), "Arial Unicode" und "Lucida Sans Unicode". Sie können aber auch eine andere Schriftart auswählen mit dem angebrachten Menüpunkt.

Berichte

View Reports

Wenn Sie die Berichte vom Vergleichen, Exportieren, Importieren, Zusammenführen und Synchronisieren auf Festplatte abspeichern, werden sie im selben Verzeichnis wie die Datenbank abgespeichert. Bei wiederholten Aktionen und nochmaligem Abspeichern auf Festplatte, wird der alte Bericht unweigerlich überschrieben. Die Berichte können zu einem späteren Zeitpunkt eingesehn werden, solange die Datenbank im selben Verzeichnis steht.


Menü Verwalten

Menü Verwalten

Das Menü Verwalten verwaltet sämtliche Optionen und Einstellungen von Password Safe.

Master-Passwort ändern

Bei der Auswahl dieses Reiters erscheint der Dialog Ändere das Master-Passwort.
Siehe Master-Passwörter ändern für mehr Information.

Sicherung erstellen

Erstellt eine Sicherung von der aktuellen Datenbank.
Siehe Datenbasen sichern und wiederherstellen für mehr Information.

Wiederherstellen aus Sicherungen

Die Datenbank wird aus einer Sicherung wiederhergestellt.
Siehe Datenbasen sichern und wiederherstellen für mehr Information.

Optionen...

Bei der Auswahl von Optionen... erscheint ein Dialog mit mehreren Reitern. Viele der Einstellungen in Password Safe können hier eingesehen und bearbeitet werden. Um mehr über einen bestimmten Reiter zu erfahren, wählen Sie ihn unten aus:

Sicherungen
Anzeige
Sicherheit
System
Passworthistorie
Verschiedenes
Schnelltasten

Hinweis: Der Reiter Passwortrichtlinie wurde ersetzt durch das folgende Menüelement um die standardmäßige und benannte Passwortrichtlinien zu verwalten.

Hinweis:
Viele dieser Einstellungen werden als Voreinstellungen abgespeichert, wie hier beschrieben.

Passwortrichtlinie...

Hier können Sie die standardmäßige und benannte Passwortrichtlinien verwalten. Es können bis zu 255 benannte Passwortrichtlinien eingerichtet werden. Der Name einer benannten Passwortrichtlinie darf nicht länger als 255 Ziechen sein.

Toolleiste anpassen

Wählen Sie die Symbole aus die in der Toolleiste dargestellt werden sollen (oder auch nicht). Die Reihenfolge der Symbole kann dabei umgestaltet werden.

Generiere Passwort

Erstellt ein Passwort nach der eingestellten Passwortrichtlinie, und legt das generierte Passwort nach Drücken der Taste Generierung in die Zwischenablage ab. Das Passwort in der Zwischenablage kann dann von anderen Anwendungen verwendet werden. Dazu können Sie die standardmäßige Passwortrichtlinie, eine benannte Passwortrichtlinie oder eine spezifische Richtlinie (mit dem Dialog eingegeben) auswählen.

Yubikey

Hiermit können Sie Ihr optionales Gerät YubiKey einstellen, um es als Zugang zu Ihrer Password Safe Datenbank einzusetzen, oder auch um ein Sicherungs-YubiKey zu erzeugen, wenn es mal verloren oder kaputt gehen sollte.

YubiKey Configuration

Einstellen des YubiKey

  1. Stecken Sie den YubiKey in einen USB-Anschluß Ihres Komputers.
  2. Wählen Sie den Menüpunkt Verwalten->Yubikey... aus. Der Dialog YubiKey Konfiguration erscheint.
  3. Die Seriennummer des YubiKey sollte angezeigt werden. Wenn dieses Feld leer ist, müssen Sie nachprüfen ob der YubiKey richtig angesteckt ist.
  4. Drücken Sie die Taste Generiere. Dies erzeugt einen 20 Byte langen geheimem Schlüssel der auf den YubiKey geschrieben wird. Anschließend wird dieser Schlüssel verwendet um den Zugang zu Ihrer Datenbank zu realisieren.
  5. Drücken Sie die Taste Setze YubiKey. Der generierte Schlüssel wird auf den YubiKey abgelegt, und gleichzeitig in verschlüsselter Form in die Password Safe Datenbank, um damit ein Sicherungs-YubiKey zu konfigurieren.
  6. Wenn die Konfiguration erfolgreich war, schließt der Dialog. Wenn nicht, erscheint eine Fehlermeldung mit der Beschreibung des Fehlers.
  7. Drücken Sie die Taste Schließen um das Dialogfenster zu verlassen.
Hinweis: Nach der Konfiguration des YubiKey, müssen Sie das Passwort der Datenbank abändern um YubiKey einsetzen zu können. Dies ist in Master-Passwörter ändern beschrieben.

Sicherungs-YubiKey erstellen

  1. Stecken Sie den YubiKey in einen USB-Anschluß Ihres Komputers.
  2. Wählen Sie den Menüpunkt Verwalten->Yubikey... aus. Der Dialog YubiKey Konfiguration erscheint.
  3. Die Seriennummer des YubiKey sollte angezeigt werden. Wenn dieses Feld leer ist, müssen Sie nachprüfen ob der YubiKey richtig angesteckt ist.
  4. Drücken Sie NICHT auf die Taste Generiere. Der angezeigte Schlüssel im Feld "Geheimer YubiKey Schlüssel" ist der in dieser Datenbank abgelegter Schlüssel. Dieser Schüssel wird dann auf dem Sicherungs-YubiKey geschrieben.
  5. Drücken Sie die Taste Setze YubiKey. Der Schlüssel wird auf den Sicherungs-YubiKey abgelegt.
  6. Wenn die Konfiguration erfolgreich war, schließt der Dialog. Wenn nicht, erscheint eine Fehlermeldung mit der Beschreibung des Fehlers.
  7. Drücken Sie die Taste Schließen um das Dialogfenster zu verlassen.

Sprache ändern

Change Language

Wenn Sie bei der Installation von Password Safe alle derzeit zur Verfügung stehenden, zusätzlichen Spachen DLLs installiert haben (dies ist Standard), sind Sie in der Lage zwischen alle diese Sprachen hin- und herzuschalten, ohne das Programm zu verlassen ("on-the-fly").

Nach der Sprachenumschaltung stehen alle Menüs, Dialoge und Meldungen dann in der ausgewählten Sprache zur Verfügung.

Die aktuell eingestellte Sprache ist mit einem Haken versehen.


Menü Hilfe

Das Menü Hilfe hilft beim Zugang zu den verschiedensten Quellen zu und über Password Safe.

Hilfe (F1)

Öffnet diese Hilfedatei.

Password Safe Webseite besuchen...

Öffnet die Password Safe Home Page im Browser.

Über Password Safe

Diese Option eröffnet ein Dialogfenster mit der Versionsnummer und einem Copyright Hinweis. Ebenfalls können Sie hier nachprüfen ob eine neuere Version von Password Safe vorhanden ist. Beachten Sie dass die Datenbank von Password Safe aus Sicherheitsgründen geschlossen wird bevor ein Verbindung zum Internet aufgebaut wird, um auf eine neuere Versionen abzuprüfen.

Dialog Über Password Safe


Menü Toolleiste

Menü

Es gibt zwei verschiedene Arten von Ansichten für die Toolleiste: modern und klassisch. Jeder dieser Ansichten hat für die sichtbaren Symbole Tooltips. Einfach mit der Maus über das Symbol ziehen und ein kleiner Tooltip erscheint. Zur Einfachheit beinhaltet dieses Element einer Kurzbeschreibung des jeweiligen Symbols.

Ab Version 3.11 kann die Art der Symbole individuell angepasst werden. Welche Art von Symbole und deren Reihenfolge kann eingestellt werden.

Umschalten zwischen Menüsymbole

  1. Gehe zum Menü Ansicht
  2. Wählen Sie Klassische Toolleiste oder Moderne Toolleiste

Symbolliste

Klassisch | Modern | Standard | Beschreibung
 |  | X | Öffnet eine neue Datenbank um Passwörter einzugeben.
 |  | X | Öffnet ein Dialogfenster zum Öffnen oder Umschalten einer Datenbank.
 |  | X | Schliesst die aktuelle Datenbank.
 |  | X | Speichert sämtliche Änderungen in der aktuellen Datenbank ab.
 |  |  | Speichert sämtliche Änderungen in der aktuellen Datenbank unter anderem Namen ab.
 |  | X | Kopiert das Passwort vom ausgewählten Eintrag in die Zwischenablage.
 |  | X | Kopiert den Benutzername vom ausgewählten Eintrag in die Zwischenablage.
 |  | X | Kopiert die Notizen vom ausgewählten Eintrag in die Zwischenablage.
 |  | X | Löscht den Inhalt der Zwischenablage
 |  | X | Führt Autom. Eingeben für den ausgewählten Eintrag durch.
 |  | X | Gehe zur URL des ausgewählten Eintrages.
 |  |  | Gehe zur URL des ausgewählten Eintrages, mit autom. Eingabe
 |  | X | Fügt in die geöffnete Datenbank Benutzername und Passwort ein.
 |  | X | Öffnet den ausgewählten Eintrag zum Bearbeiten.
 |  | X | Löscht den ausgewählten Eintrag.
 |  |  | Schaltet zwischen Listen- und Baumdarstellung um.
 |  | X | Klappt alle offenen Gruppen zu (Baumdarstellung).
 |  | X | Klappt alle offenen Gruppen aus (Baumdarstellung).
 |  |  | Vergleicht die aktuelle Datenbank mit einer anderen.
 |  |  | Führt die aktuelle Datenbank mit einer anderen zusammen.
 |  |  | Exportiert Daten zu einer Textdatei.
 |  |  | Exportiert Daten zu einer XML-Datei.
 |  |  | Importiert Daten aus einer Textdatei.
 |  |  | Importiert Daten aus einer XML-Datei.
 |  |  | Zeigt Berichte zu Import und Zusammenführen an.
 |  | X | Konfiguriert die Optionen.
 |  | X | Öffnet diese Hilfedatei.
 |  |  | Führt ein Kommando aus.
 |  |  | Ermittelt ein Teil des Passwortes.
 |  |  | Filter verwalten.
 |  |  | Startet die Bearbeitung der Filter.
 |  |  | Löscht und setzt Filter.
 |  |  | Schaltet die Suchleiste ein.
 |  |  | Sendet eine Email.
 |  |  | Synchronisiert 2 Datenbanken.
 |  |  | Macht die letzte Aktion rückgängig.
 |  |  | Stellt die zuletzt rückgängig gemachte Aktion wieder her.
 |  |  | Fügt in die geöffnete Datenbank eine neue Gruppe ein.
 |  |  | Passwortrichtlinie verwalten


Anzeige

Reiter Anzeige

Die Funktionen im Reiter Anzeige steuern wie welche Elemente in Password Safe angezeigt werden.

Password Safe immer im Vordergrund

Wenn markiert, wird ein maximiertes Password Safe am Bildschirm immer im Vordergrund gehalten, unabhängig davon welche andere Anwendung den Fokus hat.

Zeige Benutzername in der Baumdarstellung

Wenn markiert, wird zusätzlich zum Titel des Eintrages der Benutzername in eckigen Klammern angezeigt.

Zeige Passwort in der Baumdarstellung

Wenn markiert, wird zusätzlich zum Titel des Eintrages das Passwort in geschweiften Klammern angezeigt.
In Umgebungen, wo Leute im Vorbeigehen den Monitor sehen können, wird von dieser Einstellung dringend abgeraten.

Zeige Notizen in Baum- und Listen-Darstellung als ToolTip

Wenn markiert, werden sowohl in der Baum- als auch in der Listen-Darstellung die Notizen angezeigt.

Zeige Passwort beim Einfügen und Bearbeiten

Wenn markiert, sind Passwörter -standardmäßig sind sie nicht sichtbar- in den Dialogen Eintrag einfügen und Eintrag bearbeiten standardmäßig doch sichtbar dargestellt. Für jeden einzelnen Eintrag kann dieses Verhalten durch Anklicken von "Anzeigen/Ausblenden" eingestellt werden.
In Umgebungen, wo Leute im Vorbeigehen den Monitor sehen können, wird von dieser Einstellung dringend abgeraten.

Zeige Notizen beim Bearbeiten

Wenn markiert, werden die Notizen standardmäßig angezeigt im Menü Bearbeiten. Wenn nicht, müssen Sie im Notizenfeld klicken, um diese sehen zu können.

Umbrechen der Notizen beim Einfügen & Bearbeiten

Wenn markiert, werden im Menü Bearbeiten bzw. Einfügen die Notizen im Notizenfeld umgebrochen dargestellt (nur in der Anzeige). Wenn nicht markiert, erscheinen die Notizen im Notizenfeld in einer Zeile, mit Scrollbalken.

Zeige Gitterlinien in der angezeigten Liste

Wenn markiert, wird in der Liste eine leichte Linie angezeigt, um es wie eine Tabelle aussehen zu lassen.

Gruppen im Baum zuerst anzeigen

Standardmäßig werden die Einträge rein alphabetisch in der Baumdarstellung angezeigt. Wenn diese Option markiert ist, werden zuerst alle Gruppen (in alphabetischer Reihenfolge) angezeigt, gefolgt von allen Einträgen, ebenfalls alphabetisch.

Geänderte Einträge kennzeichnen

Wenn dieses Feld markiert ist, werden geändeter Einträge (solange sie nicht abgespeichert wurden) farblich anders dargestellt. Wenn dieses Feld nicht markiert ist, erkennt man das Vorhandensein von geänderten Einträgen nur am "*" in der Statuszeile, oder durch Auswählen von "Zeige ungesicherte Änderungen" in Menü Ansicht.

Warnen N Tage bevor Passwörter ablaufen

Wenn markiert, wird Password Safe beim Lesen der Datenbank sämtliche Einträge durchsuchen (typischerweise beim Start der Anwendung), und eine Liste anzeigen mit den Einträgen deren Ablaufdatum in N Tage oder weniger eintritt.

Anfängliche Baumansicht

Dies stellt ein, wie in der Baumdarstellung die Einträge dargestellt werden, beim Öffnen der Datenbank.

Anfängliches Symbol im Infobereich

Dies erlaubt die Farbe des Symbols im Systembereich festzulegen, wenn Password Safe gestartet wird, während dessen noch keine Datenbank geöffnet ist.


Verschiedenes

Reiter Verschiedenes

Mehrere Standardeinstellungen sind im Reiter Verschiedenes zusammengefasst.

Das Löschen von Elementen bestätigen

Wenn markiert, wird der Benutzer bei jedem Versuch ein Passworteintrag zu löschen aufgefordert dies zu bestätigen.

Speichere das Datum des letzten Zugriffs

Wenn markiert, merkt sich Password Safe für jeden Eintrag den Zeitpunkt eines Zugegriffes (z.B. wann das Passwort kopiert wurde, oder wenn die Details zum Eintrag angeschaut wurden, usw.). Dieser Zeitpunkt wird zusammen mit dem Eintrag gespeichert, und kann im Dialog zu diesem Eintrag angesehen werden.
Hinweis:
  • Wenn dies freigegeben ist, wird eventuell die Datenbank geändert, auch wenn kein Eintrag bearbeitet wird. Dies kann dazu führen dass Sie zum Speichern der Datenbank aufgefordert werden beim Verlassen der Anwendung, auch wenn Sie explizit nichts geändert haben.
  • Wenn die Datenbank in NUR Lesen Modus geöffnet wurde, werden keine Zugriffszeiten aktualisiert.

Taste Escape schließt die Anwendung

Wenn markiert, kann die Anwendung Password Safe mit der Taste Esc geschlossen werden, wenn sie maximiert ist. Beachten Sie dass, wenn die Anwendung im Infobereich freigegeben ist (mit der Option 'Symbol im Infobereich'), die Taste Esc nur das Hauptfenster schließt. Die Anwendung kann dann mit einem Doppelklick im Infobereich wieder maximiert werden.

Hotkey

Wenn markiert, wird ein Drücken der Tastenkombination im Feld rechts Password Safe aus dem Infobereich wiederherstellen (wenn minimiert) oder sie wieder in Vordergrund bringen, soweit Password Safe von anderen Anwendungen verdeckt ist. Die Tastenkombination kann nur geändert werden, solange diese Option markiert ist.

Doppelklick-Aktion

Dies erlaubt es festzulegen welche Aktion Password Safe ausführt, wenn Sie ein Doppelklick auf einem Eintrag ausführen. Standardmäßig wird das Passwort des ausgewählten Eintrages in die Zwischenablage kopiert. Diese Aktionen stehen zur Verfügung:

  • Autom. Eingabe
  • Benutzername in die Zwischenablage kopieren
  • Email senden
  • Gehe zu URL
  • Gehe zu URL + Autom. Eingabe
  • Kommando ausführen
  • Notizen in die Zwischenablage kopieren
  • Passwort in die Zwischenablage kopieren
  • Passwort in die Zwischenablage kopieren, minimieren
  • Zeige/bearbeite ausgewählten Eintrag

Beachten Sie dass die letzte Aktion "Passwort in die Zwischenablage kopieren, minimieren" nicht funktioniert wie erwartet, wenn gleichzeitig die Option "Zwischenablage nach Minimieren löschen" markiert ist im Reiter Sicherheit.

Umschalt Doppelklick-Aktion

Dies erlaubt es festzulegen welche Aktion Password Safe ausführt, wenn Sie ein Umschalt-Doppelklick auf einem Eintrag ausführen. Standardmäßig wird der Benutzername des ausgewählten Eintrages in die Zwischenablage kopiert.

Es stehen dabei dieselben Aktionen zur Verfügung wie bei der Doppelklick-Aktion.

Autom. Eingabe

  • Minimieren nach Autom. Eingabe: Wird standardmäßig Password Safe minimieren, wenn Autom. Eingabe eingeschaltet ist. Wenn diese Option ausgeschaltet wird, wird Password Safe sich hinter allen angezeigten Fenstern stellen.
  • Standardzeichen bei autom. Eingabe: Hier können Sie die standardmäßigen Zeichen für die Autom. Eingabe festlegen für alle Einträge. Beachten Sie dass man dies per Eintrag auch überschreiben kann. Diese Option ist dann sinnvoll, wenn Sie für alle Einträge z.B. die Verzögerung ändern wollen. Siehe hier für mehr Details über Autom. Eingabe.

Standard-Benutzername

Hiermit können Sie den Standardbenutzernamen definieren der automatisch beim Erstellen eines neuen Eintrages im Feld Benutzername eingetragen werden soll. Wenn markiert, wird dieser Name im Feld Benutzername eines jeden neuen Eintrages ausgefüllt. Natürlich kann er dann bearbeitet werden, wenn Sie wollen.

Alternativer Browser

Der alternative Browser wird in diesem Feld definiert. Er wird aufgerufen beim Drücken auf "Los", wenn im ausgewählten Eintrag im Feld URL "[alt]" vor der URL steht, z.B. "[alt]http://www.foo.net". Dies ist dann sinnvoll, wenn der Standardbrowser Firefox ist, und Sie wollen auf eine Internet-Seite zugreifen, von dem Sie wissen dass diese Seite mit dem Internet Explorer am besten dargestellt wird. In diesem Falle würden Sie den Internet Explorer als "Alternativer Browser" festlegen, mit z.B. "C:\Program Files\Internet Explorer\iexplorer.exe".

Wenn weitere Parameter in der Kommandozeile benötigt werden, können diese im Fenster "Browser Kommandozeilenparameter" angegeben werden.

Alternativer Notizen Editor

Die Benutzung eines alternativen, externen Editors wird hiermit unterstützt. Nach Drücken der rechten Maustaste im Notizenfeld, kann man ! Extern bearbeiten drücken. Es wird dann folgender Hinweis ausgegeben: "WARNUNG: die Benutzung eines externen Editors kann sensible Daten auf Ihrer Festplatte hinterlassen. Wollen Sie fortfahren?". Nach dem bejahen, ist ein Arbeiten im externen Editor möglich. Nachdem die Daten im externen Editor bearbeitet und abspeichert sind, und der externe Editor verlassen wurde, stehen die bearbeiteten Daten im Notizenfeld zur Verfügung.


Passworthistorie

Reiter Passworthistorie

Im Reiter Passworthistorie werden die Regeln, wie die Historie der Einträge in Password Safe festgehalten wird, beschrieben.
Wenn Sie das Passwort eines Eintrages ändern, kann Password Safe die alten Passwörter, die zu diesem Eintrag gehören, abspeichern. Dies ist dann z.B. nützlich, wenn die Änderung des Passwortes nicht das erhoffte Ergebnis gebracht hat in der Anwendung, in dem das Passwort eingesetzt wurde. Auch kann festgelegt werden wie viele Passwörter für einen neuen Eintrag standardmäßig gespeichert werden sollen. Dies kann allerdings für einen bestimmten Eintrag wieder aufgehoben werden im Dialog "Eintrag bearbeiten" oder "Eintrag einfügen".

Speichere N bisherige Passwörter pro Eintrag

Wenn Sie dies markieren, und die Anzahl festlegen, definieren Sie hiermit den standardmäßigen Wert wie viele Passwörter festgehalten werden für jeden neuen Eintrag.

Verwalte Passworthistorie der aktuellen Einträge

Hiermit können Sie die Passworthistorie von bereits bestehenden Einträge abändern, wie folgt:
  • Keine Änderung - hiermit bleibt der bestehende Zustand erhalten, es ändert sich nichts.
  • Beende das Speichern vorheriger Passwörter - dies ist gleichbedeutend mit dem Löschen der Markierung zu "Speichere N bisherige Passwörter pro Eintrag" in allen Einträgen der Datenbank. Es geht hierbei keine Historie verloren, lediglich das Abspeichern der neuen Passwörter wird angehalten bis das Speichern der Passwörter wieder reaktiviert wird.
  • Beginne mit der Speicherung vorheriger Passwörter - dies ist gleichbedeutend mit dem Setzen der Markierung zu "Speichere N bisherige Passwörter pro Eintrag" in allen Einträgen der Datenbank. Einträge die bis dato keine Historie hatten, werden nun bearbeitet bis zur angegebenen Anzahl. Einträge die schon eine Historie hatten werden nur wieder bearbeitet, die Anzahl ändert sich aber nicht.
  • Setze die maximale Anzahl an gespeicherten Passwörtern auf obigen Wert - sämtliche Einträge werden auf die eingegebene Anzahl gesetzt. Hierbei geht keine Historie verloren, auch wenn ein Eintrag mehr als diese Anzahl Elemente gespeichert haben sollte.


Sicherheit

Im Reiter Sicherheit werden die sicherheitsrelevanten Einstellungen vorgenommen. Eine einfache Handhabung und die Sicherheit der Anwendung werden von den aufgelisteten Optionen beeinflusst. Die Sicherheit der verschlüsselten Datenbank hingegen ist keineswegs betroffen.

Zwischenablage nach Minimieren löschen

Wenn markiert, wird die Anwendung, wenn sie minimiert wird, in der Zwischenablage alle gespeicherten Informationen löschen (z.B. das Passwort). Dies verhindert dass jemand anderes oder eine andere Anwendung den Inhalt der Zwischenablage lesen kann. Beachten Sie, dass das Markieren dieser Option zusammen mit der Doppelklick-Aktion "Passwort in die Zwischenablage kopieren, minimieren" im Reiter Verschiedenes zu unerwartete Ergebnisse führen kann (das Passwort wird kopiert, aber anschließend gleich wieder gelöscht).

Zwischenablage nach Beenden löschen

Wenn markiert, wird die Anwendung, wenn sie minimiert oder geschlossen wird, in der Zwischenablage alle von Password Safe gespeicherten Informationen löschen (z.B. das Passwort). Dies verhindert dass jemand anderes oder eine andere Anwendung den Inhalt der Zwischenablage lesen kann.

Kopieren von Elementen in Zwischenablage bestätigen

Wenn markiert, wird der Benutzer jedes Mal aufgefordert das Kopieren des Passwortes aus der Datenbank zur Zwischenablage zu bestätigen.

Passwortdatenbank sperren wenn minimiert

Wenn markiert, wird die Datenbank gesperrt, wenn die Anwendung minimiert wird. Wenn die Anwendung wieder maximiert wird, müssen Sie den Zugang zur Datenbank durch die Eingabe des Master-Passwortes freigeben.

Passwortdatenbank sperren wenn Computer gesperrt

Wenn markiert, wird die Datenbank gesperrt, wenn der Computer gesperrt wird. Somit werden unberechtigte Zugriffe verhindert von Anwender oder Anwendungen die noch auf dem Computer Zugriff haben (auch von außen).

Passwortdatenbank sperren nach N Minuten Leerlauf

Wenn dies markiert ist und die Zeit gesetzt ist, wird Password Safe die Passwortdatenbank nach der gegebenen Zeit sperren, ohne Zutun des Benutzers.

'Gehe zu URL' kopiert Passwort in die Zwischenablage

Wenn dies markiert ist, wird beim Ausführen des Kommandos 'Gehe zu URL' das Passwort in die Zwischenablage kopiert.

Entsperrschwierigkeitsgrad

Die Stellung des Schiebers stellt dar wieviel Berechnungszeit benötigt wird um die Password Safe Datenbank zu öffnen bzw. zu speichern. Die Stellung Normal sollte genügend Sicherheit bieten, um das Öffnen einer Datenbank auf den meisten Plattformen nicht allzuviel zu verzögern. Wenn dieser Wert erhöht wird, sollten Sie die langsamste CPU die Sie verwenden um eine Datenbank zu bearbeiten berücksichtigen.


System

Reiter System

Der Reiter System gibt Zugriff auf die Einstellungen die Password Safe benötigt für das System worauf es läuft.

Symbol im Infobereich

Wenn markiert, wird Password Safe minimiert im Infobereich gestartet.
Wenn nicht markiert, startet das Programm minimiert in der Taskleiste.

Das Symbol im Infobereich zeigt an ob die Passwortdatenbank gesperrt ( Gesperrt) ist oder nicht gesperrt ( Entsperrt) ist. Wenn die Datenbank gesperrt ist, werden Sie beim Versuch die Anwendung zu maximieren aufgefordert das Master-Passwort einzugeben.

Merke letzte N benutzte Einträge im Infobereich

Wenn die Option Symbol im Infobereich markiert ist, können Sie mit einem Rechts-Klick im Infobereich die zuletzt benutzten Einträge direkt erreichen, ohne die Anwendung vorher öffnen zu müssen. Mit dieser Option können Sie festlegen wie viele Einträge maximal in der Liste im Infobereich vorhanden sind.

Symbol im Infobereich verbergen (Tastenkürzel MUSS aktiv sein)

Wenn markiert, wird das Symbol für Password Safe im Infobereich verborgen. Das Tastenkürzel zum Aufrufen von Password Safe MUSS allerdings aktiv sein, sonst wird die Auswahlmöglichkeit ausgegraut.

Starte Password Safe beim Anmelden

Wenn markiert, startet Password Safe bei der Anmeldung automatisch im Infobereich. Beachten Sie, dass Sie erst beim Aufrufen der Anwendung mit einem Doppelklick im Infobereich zur Eingabe des Master-Passwortes aufgefordert werden, nicht vorher.

Zuletzt benutzte Password Safe-Datenbanken

Dies legt die Anzahl der Datenbanken im Menü Datei fest, die Sie als letzte benutzt haben. Beachten Sie, dass Password Safe geschlossen und wieder geöffnet werden muss, um diese Einstellung wirksam werden zu lassen.

zuletzt benutzte Datenbanken im Menü Datei und nicht als Untermenü.

Diese Option legt fest, ob die zuletzt benutzen Dateien direkt im Menü Datei angezeigt werden, oder als extra Untermenü.

Datenbank standardmäßig für Nur-Lesen öffnen

Wenn dies gesetzt ist, werden in Password Safe Datenbanken in NUR-Lesen Modus geöffnet. Dies könnte in einem Umfeld mit mehreren Benutzern sinnvoll sein, weil Password Safe standardmäßig nur dem ersten Benutzer die Datenbank mit Schreibrechten öffnet, und alle anderen im NUR-Lesen Modus. Auf diese Weise können Sie an einem Standort bestimmen wer welche Zugriffsrechte auf eine gegebene Datenbank hat.

Mehrere Instanzen erlauben (bedingt ein Wiederstart aller Instanzen)

Entferne Password Safe-Einträge aus der Registry

Vor Version 3.05 benutzte Password Safe die Registry, um die Konfigurationsdaten abzuspeichern, wie da sind, nicht standardmäßige Einstellungen, zuletzt benutzte Datenbanken, usw. Ab der Version 3.05 werden diese Informationen aufgeteilt in einem datenbankspezifischen Teil und einem Benutzer/Maschine-spezifischen Teil. Der letzte Teil wird in einer getrennten Konfigurationsdatei abgelegt. Wenn Sie diese Option markieren, und die Taste Übernehmen drücken, werden die Einstellungen für Password Safe in der Registry gelöscht. Dies ist vor allem dann sinnvoll, wenn Sie "Spuren" von Password Safe auf Ihrem PC löschen wollen. Beachten Sie aber, dass dies dazu führt dass eventuell vorhandene ältere Versionen von Password Safe wieder mit einigen standardmäßigen Werten anfangen.
Hinweise:
  • Wenn keine früheren Versionen von Password Safe installiert wurden, oder wenn die Daten schon gelöscht sind, werden sowohl das Kontrollkästchen als auch die Taste Übernehmen nicht angezeigt.
  • In den seltenen Fällen wo Password Safe die Konfigurationsdatei nicht verwenden kann, wird die Registry verwendet.

Migriere die PasswordSafe Daten zur lokalen Benutzer-Anwenderdaten

Vor Version 3.22 speicherte Password Safe die Einstellungen (z.B. Benutzeroptionen, zuletzt geöffnete Dateien, Fenstergröße, usw.) in einer Datei ab, die im selben Verzeichnis war wie das ausgeführte Programm Password Safe. Dies verursachte Probleme mit neueren Versionen von Windows, wo der Benutzer keinen Zugriff mehr auf dieses Verzeichnis hatte. Darum wurde, ab Version 3.22, die Konfigurationsdatei im standardmäßigen Verzeichnis für solche Dateien abgelegt (im benutzereigenen Verzeichnis 'Anwendungsdaten').
Standardmäßig werden Updates bei bestehende Installationen dieses nicht ändern. (nach dem Motto: "Wenn es nicht kaputt ist, repariere es nicht"). Allerdings kann der Benutzer, wenn er die neue Einstellung verwenden will, diesen Punkt markieren, und die Taste Übernehmen drücken, um dies Änderung zu realisieren.

Im Detail: Die Konfigurationsdatei ist so konzipiert, dass mehrere Benutzer auf mehreren Maschinen bedient werden können. Die Migrier-Funktion wird die Einstellungen des aktuellen Benutzers (auf dem aktuellen PC) aus der Konfigurationsdatei in die neue Datei ablegen. Andere Einstellungen bleiben davon unberührt. Wenn aber am Ende der Operation keine Einstellungen mehr übrig bleiben sollten, wird die Konfigurationsdatei gelöscht.
Wenn Sie eine gemeinsame Konfigurationsdatei für Benutzer und/oder PC's benutzen wollen, können Sie entweder die Datei im Verzeichnis des Programmes belassen, oder ein spezifisches Verzeichnis festlegen mit der '-g Konfigurationsdatei' Option, wie beschrieben in Kommandozeilen Argumente.


Schnelltasten

Reiter System

Der Reiter Schnelltasten gibt Zugriff auf die Tastenkombinationen die in den Menüs von Password Safe für die verschiedenen Menüeinträge vorgesehen sind.

Spalte Menüeintrag

In der Spalte Menüeintrag sind (fast) alle Menüeinträge aufgeführt, die in den Menüs vorkommen. Die Menüs sind mit den UnterMenüs jeweils mit dem Zeichen '»' verbunden.

Spalte Tastenkombination

In der Spalte Tastenkombination ist die gültige Tastenkombination angegeben, die für den jeweiligen Menüeintrag gelten. Wenn die Tastenkombination abweicht von der Standardmäßigen Einstellung ist die dazugehörige Menüeintrag rot dargestellt.
Um z.B. die Tastenkombination F12 (für "Speichern unter...") um zu stellen auf F11, klicken Sie das Feld mit F12 an, und drücken dann die Taste F11. Mit der Taste OK kann das Ergebnis abgespeichert werden. Weitere Details zu den belegbaren (und nicht belegbaren) Tasten finden Sie hier.
Hinweis: Die umgestellten Tastenkombinationen werden von Password Safe abgespeichert, und stehen beim nächsten Start weiterhin zur Verfügung.

Alles rücksetzen

Mit der Taste Alles rücksetzen können die standardmäßigen Werte für alle Menüeinträge wieder hergestellt werden.

Password Safe erlaubt es Tastatureingaben (Kürzel) zu definieren die bestimmte Aufgaben ausführen in der Anwendung. In diesem Fenster können Sie die Kürzel kontrellieren und bearbeiten.

Hot Key Anwendung

Wenn der Haken gesetzt ist, bewirkt das Drücken der Kombination zur Rechten das Hochfahren von Password Safe aus dem Infobereich, wenn die Anwendung minimiert war, oder bringt die Anwendung im Vordergrund, wenn sie von andere Anwendungen abgedeckt war. Nur wenn der Haken gesetzt ist, kann die Kombination eingegebene werden.

Programmverknüpfung

Um Verknüpfungen zu ändern (oder hinzuzufügen), wählen Sie die Zeile aus mit der zu ändernden Aktion, und klicken Sie das Feld Tastenkombination zu dieser Aktion. Jeder Tastaturkombination die sie drücken wird als Verknüpfung abgelegt. Z.B. wenn die Dateieigenschaften erscheinen soll wenn Sie die Tasten Alt, Strg und 'p' drücken, wählen Sie vorerst die Zeile mit Datei > Eigenschaften aus, klicken das Feld Tastenkombination und drücken dann die Tasten Alt, Strg und 'p'. Der Text ALT+STRG+P erscheint dann im Feld. Wenn Sie dann OK drücken, wird die Änderung übernommen. Für weitere Details über Tastenkombinationen die wohl oder nicht geändert werden können, siehe hier.

Beachten Sie dass Sie sowohl neue Verknüpfungen festlegen können, als auch vordefinierte überschreiben können wie Sie es haben wollen. Die Verknüpfungen werden abgespeichert, und werden dann auch beim erneuten Starten von Password Safe zur Verfügung stehen.

Wenn Sie eine Verknüpfung entfernen wollen, oder auf den Standardwert zurücksetzen wollen, suchen Sie die Verknüpfung und rechtsklicken auf das Feld Tastenkombination. Es erscheint ein Popup-Menü, wo Sie machen können was Sie tun möchten. Um alle Verknüpfungen auf den Standardwert zurückzusetzen, klcken Sie auf Alle Programmkürzel zurücksetzen.

Kürzel der Datenbankeinträge

Die Tabelle stellt eine Übersicht der Kürzel dar, die für bestimmte Einträge in der geöffneten Datenbank vorhanden sind. Die Kürzel werden festgelegt im Reiter Zusätzlich des jeweiligen Eintrages. Um das Kürzel zu bearbeiten genügt ein Doppelklick in der betreffenden Zeile.


Alias

Passwort Alias

Wenn Sie ein System mit einer "einziger Anmeldung" verwenden, das es Ihnen erlaubt in mehreren Systemen / Server / Anwendungen, usw. dasselbe Passwort einzusetzen, können Sie in Password Safe die Einträge so einstellen, das bei Änderung eines Eintrages auch alle anderen artverwandte Einträge mit geändert werden. Diese nennt man "Alias" Einträge. Dieser Beitrag beschreibt die Definition und Anwendung dieser Alias.

Zusammenfassung

Der Grundgedanke dabei ist zu erlauben dass das Passwort eines Eintrages von einem anderen Eintrag mitbenutzt wird. Der zu benutzende Eintrag wird Basis genannt und der benutzende Eintrag (oder Einträge) wird (werden) Alias genannt. Wenn ein Eintrag als Alias zu einem anderen Eintrag gesetzt wurde, 'folgt' das Alias Passwort gewissermaßen das Passwort des Basiseintrages. Wenn Sie das Passwort eines Alias in die Zwischenablage kopieren, wird tatsächlich das Passwort der Basis kopiert. Wenn Sie das Passwort der Basis ändern, spiegelt sich dies unmittelbar in sämtliche Aliaseinträge wieder. Obwohl dies kompliziert klingen mag, ist es eigentlich eher einfach und intuitiv. Am Aufwendigsten daran ist das Aufsetzen der Alias, wie unten beschrieben.

Definition eines Alias

In Password Safe kann ein Eintrag auf das Passwort eines anderen Eintrag verweisen, mittels eines speziell formatierten Passwortes im benutzenden Eintrag. Das Format ist der "Name" vom benutzten Eintrag eingeschlossen in eckigen Klammern. Meistens versteht man unter "Name" das Synonym vom Feld Titel eines Eintrages. Wenn der Titel eines Eintrages z.B. "Master" ist, reicht die Eingabe von "[Master]" (ohne Gänsefüßchen) im Feld Passwort eines anderen Eintrages, um diesen als Alias von "Master" zu definieren, aus. Im allgemeinen, "Name" kann in diesem Kontext nachstehend genannte Felder, getrennt mit Doppelpunkt enthalten: Gruppe, Titel und Benutzername. Beachten Sie dass, wenn der Titel in der Datenbank eindeutig ist, die anderen Felder optional sind. Gleiches gilt, wenn Gruppe und Titel zusammen oder Title und Benutzernamen zusammen einen eindeutigen Eintrag ergeben.

Bei Einträgen in Password Safe ist nur das Titelfeld obligatorisch. Gruppe und Benutzername sind optional solange die resultierende Kombination aus Gruppe/Titel/Benutzername eindeutig ist. Wie oben erwähnt besteht das 'Alias Passwort' aus der Form [g:t:b] aber tatsächlich ist es ausreichend genügend Information anzugeben, um den Basiseintrag eindeutig zu identifizieren. Also, wenn nur ein einziger Eintrag mit Titel 't' in der Datenbank vorhanden ist, würde [t] ausreichen, weil Titel obligatorisch ist, und mit nur einem angegebenen Element nimmt man an dass es der Titel ist. Wenn mehr als einen Eintrag bestehen würde mit diesem Titel, kommt eine Warnung hoch, und Sie müssten genauer den Basiseintrag spezifizieren durch Angeben der Gruppe, des Benutzernamens oder eventuell sogar beide! So lange es ein einziger Eintrag gibt der mit den angegebenen Informationen zusammenpasst, werden die folgenden Formate angenommen: [g:t:b], [g:t], [t:b] oder [t]. Wenn Sie ein Doppelpunkt ohne dazugehörigen Wert angeben, wird von einem leeren Feld ausgegangen. Zum Beispiel: [g:t:] gibt einen Eintrag mit Titel 't' in Gruppe 'g' ohne Benutzernamen an, und [:t:] einen Eintrag mit Titel 't' in der Wurzel, ohne Benutzernamen usw.

Die folgenden Beispiele sollten dies klarstellen.

Beispiele

1. Wenn der Titel des Basiseintrages "LDAP Server" ist, und kein anderer Eintrag mit diesem Titel besteht, dann ist ein Alias mit dem Wert "[LDAP Server]" im Passwortfeld eindeutig definiert.

2. Wenn der Wert "LDAP Server" in Einträge von zwei verschiedenen Gruppen vorkommt -sagen wir "Abt. A" und "Abt. B"- dann kann der Eintrag für letztere mit "[Abt. B:LDAP Server]" spezifiziert werden. Bemerke dass der Benutzername nicht angegeben sein muss, wenn die angegebene Information ausreicht, um den Basiseintrag eindeutig zu identifizieren.

3. Unterschiedliche Benutzernamen können auch benutzt werden, um zwischen gleichartige Basiseinträge zu Differenzieren, z.B. "[LDAP Server:Joe]" und "[LDAP Server:Mary]".

4. Schlussendlich, alle drei Felder können angegeben sein wie in "[Abt. A:LDAP Server:Joe]"

Anzeige

Basiseinträge, d.h. Einträge mit mindestens ein Alias der auf ihn verweist, werden angezeigt mit einem grünen Dreieck anstelle des grünen Rechtecks in der Baumstruktur.

Alias Einträge sind mit einem weißen Dreieck gekennzeichnet.


Text Export & Import Format

Warnung: Der Export von sensiblen Informationen aus einer Passwort Safe Datenbank in einer Textdatei bringt erhebliche Sicherheitsprobleme mit sich. Bei diesem Vorgang wird eine ungeschützte Kopie der Passwörter in der Datenbank erstellt. Das Löschen dieser Kopie nach deren Verwendung ist nicht ausreichend und darum müssten andere Anwendungen eingesetzt werden, um die Daten "garantiert" zu löschen (z.B. externe Hilfsmitteln zum "Schreddern" der Daten). Der Export von sensiblen Informationen aus einer Passwort Safe Datenbank umgeht die Sicherheit der Anwendung.

Hinweis: Das Exportieren und Importieren zu/von Textdateien wurde in Version V3.06 geändert. Auf dieser Seite wird das aktuelle Format beschrieben.

Exportierter Text wird:

  • beginnen mit einer Titel-Zeile als erster Datensatz in der Textdatei
  • ein Trennzeichen anwenden, um das "neue Zeile"-Zeichen in Notizen mit mehr als einer Zeile und den Punkt ('.') im Feld Titel zu ersetzen. Das Standardtrennzeichen ist '»' [Alt+0187]. Es kann, wenn notwendig, überschrieben werden.

Importierter Text setzt voraus dass:

  • eine Titel-Zeile als erste Zeile in der Textdatei vorhanden ist.
  • ein Trennzeichen da ist, um das "neue Zeile"-Zeichen in Notizen mit mehr als einer Zeile und den Punkt ('.') im Feld Titel zurückzuersetzen. Das Standardtrennzeichen ist '»' [Alt+0187]. Es kann, wenn notwendig, überschrieben werden.

Die Titel-Zeile enthält für einen vollständigen Export standardmäßig folgende Felder, getrennt mit einem TAB-Zeichen.

  • Gruppe/Titel
  • Benutzername
  • Passwort
  • URL
  • Autom. Eingabe
  • Erstellungszeit
  • Passwort Änderungszeit
  • Letzter Zugriffszeit
  • Passwort Ablaufdatum
  • Passwort Ablaufintervall
  • Datensatz Änderungszeit
  • Passwort Richtlinie
  • Historie
  • Kommando Ausführen
  • DCA
  • E-Mail
  • Schutz Status
  • Symbolische Liste zur Passwortgenerierung
  • Notizen

Beim Exportieren von Daten, können Sie auf "Erweitert" drücken, um eine beliebige Anzahl dieser Felder auszuschließen in der Titel-Zeile und den Datensätzen. In der Option "Erweitert" (siehe unten) definieren Sie eine Untermenge an Einträge die Sie Exportieren wollen.

Erweiterte Optionen f¨r Text Export

Beim Importieren muss die eingebaute Titel-Zeile exakt die Elemente als 'Spalten-Köpfe' enthalten, wie oben definiert. Wenn irgendein 'Spalten-Kopf' wiederholt wird, werden nur die Daten des letzten übernommen beim Importieren. Wenn ein 'Spalten-Kopf' nicht in der obigen Liste vorkommt, wird er beim Importieren nicht berücksichtigt. Die Daten müssen mit dem Trennzeichen unterteilt sein wie es im Dialog Text Importieren definiert wurde.

Hinweis:
  • Um überhaupt Daten zu Passwort Safe importieren zu können müssen unbedingt die Felder Titel und Passwort vorhanden sein. Sie dürfen weder nur Leerzeichen noch leer sein, wie es auch der Fall ist beim Einfügen eines Eintrages zu einer Datenbank.
  • Es besteht keine Einschränkung in der Reihenfolge der 'Spalten-Köpfe'. Passwort Safe wird die mitgebrachte Titel-Zeile verwenden, um die spezifizierten Daten im richtigen Feld abzulegen.

Daten Formate

Spalte Kopf/Feld | Kommentare
Gruppe/Titel | Wenn vorhanden, werden Gruppen mit Punkt getrennt ('.'). Das Feld Titel darf nicht leer sein, nur Leerzeichen oder überhaupt Trennzeichen enthalten.
Benutzername
Passwort | kann kein Leerzeichen oder überhaupt leer sein.
URL
Autom. Eingabe
Erstellungszeit | Siehe Hinweis 1 unten
Passwort Änderungszeit | Siehe Hinweis 1 unten
Letzter Zugriffszeit | Siehe Hinweis 1 unten
Passwort Ablaufdatum | Siehe Hinweis 1 unten
Passwort Ablaufinterval | Siehe Hinweis 1 unten
Datensatz Änderungszeit | Siehe Hinweis 1 unten
Passwort Richtlinie | Siehe Hinweis 3 unten
Historie | Siehe Hinweis 2 unten
Kommando Ausführen
DCA | = 'Doppel Klick Aktion'. Siehe Hinweis 4 unten
Shift-DCA | = 'Doppel Klick Aktion'. Siehe Hinweis 4 unten
E-Mail
Geschützt
Symbole
Notizen
  • Das Feld Notizen sollte in Gänsefüßchen eingeschlossen sein ("wie dies").
  • Das Feld Notizen sollte kein Trennzeichen enthalten, weil es sonst beim Importieren in "neue Zeile" umgesetzt wird.

Hinweis: 1

Zeit-Felder können eines der 5 folgende Formate haben:

1. | yyyy/mm/dd hh:mm:ss | z.B., 2007/01/26 19:31:25
2. | ddd MMM dd hh:mm:ss yyyy | z.B., Fri Jan 26 19:31:25 2007
3. | yyyy-mm-ddThh:mm:ss | z.B., 2007-01-26T19:31:25
4. | yyyy-mm-ddThh:mm:ssZ (nur XML) | z.B., 2007-01-26T19:31:25Z
5. | yyyy-mm-ddThh:mm:ssthh:mm (nur XML) | z.B., 2007-01-26T19:31:25+01:00
6. | 0 | das Feld unbesetzt lassen
7. | now | die Zeit des Importierens anwenden

wo:

yyyy | das voll ausgeschriebene Jahr. Der Wert liegt zwischen 1970 und 2038.
mm | der Monat; z.B. 01 = Januar, 02 = Februar usw.
dd | der Tag im Monat
MMM | die Kurzform des Monats; z.B. Jan = Januar, Feb = Februar usw.
ddd | die Kurzform des Wochentages; z.B. Mon = Montag, Tue = Dienstag (Tuesday) usw.
hh | die Stunde (24-teilig).
mm | die Minuten
ss | die Sekunden
Hinweis: Format '2' ist das Ergebnis der ANSI C Funktion 'asctime' und Format '3' ist konform zum ISO 8601 Standard.

Hinweis: 2

Die Passworthistorie wird im exportierten Datensatz in einem Textfeld abgebildet durch eine Kopf gefolgt von einer Anzahl Felder mit den alten Passwörtern:

Passworthistorie Kopf:

1 hexadezimales Zeichen | Status zum Speicher der Passworthistorie für diesen Eintrag (0 = nein; 1 = ja)
2 hexadezimale Zeichen | Maximum Anzahl an Einträgen für diesem Satz
2 hexadezimale Zeichen | Anzahl der aktuel abgespeicherten Einträge

Jeder Eintrag der Passworthistorie:

8 hexadezimale Zeichen | Zeit wann das alte Passwort gesetzt wurde
4 hexadezimale Zeichen | Länge des alten Passwortes
Zeichen String | altes Passwort

Hinweis: 3

 Die Passwortrichtlinie wird im exportierten Datensatz wie ein Textstring 'ffffnnnllluuudddsss' in hexadezimalem Format abgelegt, z.B. 'F000010004002005003'. Insgesamt sind 6 Hexadezimalwerte enthalten. Der erste Wert ist 4-stelling, alle andere sind 3-stellig.

'ffffnnnllluuudddsss' bedeutet im Detail:

  • ffff : 4 Hexadezimalzeichen als Flag für
    • 0x8000: verwende kleingeschriebene Buchstaben
    • 0x4000: verwende grossgeschriebene Buchstaben
    • 0x2000: verwende numerische Zeichen
    • 0x1000: verwende Sonderzeichen
    • 0x0800: verwende nur Hexadezimalzeichen (0-9,a-f) (wenn gesetzt, kann kein anderes Bit gesetzt sein)
    • 0x0400: verwende ein leicht zu lesendes Passwort (EasyVision)
    • 0x0200: verwende ein aussprechbares Passwort
    • 0x01FF: nicht verwendet
  • nnn  : 3 Hexadezimalzeichen : gesamte Passwortlänge
  • lll  : 3 Hexadezimalzeichen : minimum Anzahl kleingeschriebene Buchstaben im Passwort
  • uuu  : 3 Hexadezimalzeichen : minimum Anzahl grossgeschriebene Buchstaben im Passwort
  • ddd  : 3 Hexadezimalzeichen : minimum Anzahl numerische Zeichen im Passwort
  • sss  : 3 Hexadezimalzeichen : minimum Anzahl Sonderzeichen im Passwort

Die Passwortrichtlinie 'F000010004002005003' gedeutet dann

  • F000 : verwende kleingeschriebene, grossgeschriebene, numerische und Sonderzeichen
  • 010  : verwende mindestens 16 (dez) Zeichen
  • 004  : verwende mindestens 4 kleingeschriebene Buchstaben
  • 002  : verwende mindestens 2 grossgeschriebene Buchstaben
  • 005  : verwende mindestens 5 numerische Zeichen
  • 003  : verwende mindestens 3 Sonderzeichen

Hinweis: 4

Bei der Abspeicherung der Doppel Klick Aktion kommen folgende Werte vor:
  • -1: Standard
  • 0: Passwort in die Zwischenablage kopieren
  • 1: Zeige/bearbeite ausgewählten Eintrag
  • 2: Autom. Eingabe
  • 3: Gehe zu URL
  • 4: Notizen in die Zwischenablage kopieren
  • 5: Benutzername in die Zwischenablage kopieren
  • 6: Passwort in die Zwischenablage kopieren, minimieren
  • 7: Gehe zu URL + Autom. Eingabe
  • 8: Kommando ausführen
  • 9: Email senden


Voreinstellungen

Password Safe Voreinstellungen

Wie manche andere Anwendungen auch hat Password Safe die Möglichkeit sein Verhalten und Aussehen einzustellen, um sich so gut wie möglich auf Ihre Nöte und Wünsche einzustellen. Viele Anwendungen speichern solche Voreinstellungen in die Windows Registry ab, eine Art von Gewohnheit und Bequemlichkeit. Frühere Versionen von Password Safe haben die Registry auch eingesetzt, dies brachte aber folgende Probleme mit sich:

  1. Einige der konfigurierbaren Voreinstellungen sind sicherheitsrelevant, und das Abspeichern in einer offenen Ablage wie die Windows Registry könnte einem Angreifer beim Zugang zur Datenbank helfen (z.B. wenn der Angreifer nach Ablauf der Pause auf die Datenbank zugreift, wo der Anwender selber weiterhin von einer Datenbanksperrung ausgeht).
  2. Einige Leute betreiben Password Safe von einer disk-on-key. Oder Sie betreiben eine Datenbank gemeinsam von mehreren Maschinen aus. In diesem Falle wäre es ungünstig die Registry zu verwenden.

Password Safe hat eine Anzahl Voreinstellungen, jeder mit einem sinnvollen Wert besetzt. Wenn ein Benutzer diesen Wert auf einem anderen Wert einstellt, wird dieser neue Wert von Password Safe gespeichert.

Password Safe kennt sicherheitsrelevante und nicht sicherheitsrelevante Voreinstellungen. Die ersteren werden in der Datenbank abgespeichert, verschlüsselt mit demselben Schlüssel womit auch die Daten vom Benutzer abgelegt sind.

Die anderen, nicht sicherheitsrelevante Daten werden in der Konfigurationsdatei pwsafe.cfg abgespeichert. Diese Datei ist in XML Format abgelegt, mit Aufteilung der Daten per Host Maschine und Benutzer. Somit kann diese Datei von verschiedenen Benutzer und Maschinen gemeinsam benutzt werden.

Standardmäßig wird die Datei pwsafe.cfg im selben Verzeichnis wie die ausführbare Anwendung pwsafe.exe abgelegt. Wenn hingegen die Umgebungsvariable PWS_PREFSDIR gesetzt ist, wird Passowrd Safe die Datei verwenden die dort angegeben ist. Dies ist dann sinnvoll, wenn der Schreibzugriff zum Verzeichnis wo pwsafe.exe liegt eingeschränkt ist.

Die folgenden Tabellen beschreiben die Konfigurationselemente. Die meisten können mit dem Dialog Verwalten->Optionen konfiguriert werden. Weil wir XML einsetzen, sind die Namen für Werte und Felder case sensitif. Voreinstellungen die in der Datei "pwsafe.cfg" abgespeichert sind, treffen auf alle Datenbanken zu. Diese die nur in der Datenbank abgespeichert sind, sind nur für diese Datenbank relevant. In Windows Vista oder Windows 7, kann man die Datei pwsafe.cfg in folgendem Verzeichn is finden: "C:\Users\\AppData\Local\PasswordSafe" und in Windows XP, finden Sie es in: "C:\Documente und Einstellungen\\Application Data\PasswordSafe". Beachten Sie das beide Verzeichnisse versteckt sein können, und ev. sollten Sie die Verzeichniseigenschaften so abändern, dass Sie sie sehen können. Veraltete Voreinstellungen werden nicht aufgelistet.

Beachten Sie dass nur die nicht standardmäßen Voreinstellungen in die Konfigurationsdatei oder die Datenbank abgelegt werden.

Hinweis: ändern sie KEINE der Voreinstellungen in der Datei pwsafe.cfg von Hand. Dies k&onnte unerwartete und nicht voraussagbare Folgen haben. Auch wenn wir uns viel Mühe geben alle Werte die wir einlesen zu verifizieren, gibt es keine Garantie dafür dass händisch geänderte Werte nicht zu Probleme führen können.

Boolesche (wahr ('1')/falsch('0')) Voreinstellungen

Voreinstellung | Standard | Wo gespeichert | Kommentar
AlwaysOnTop | falsch | pwsafe.cfg | Hauptfenster immer im Vordergrund
ShowPWDefault | falsch | Datenbank | Das Passwort wird standardmäßig bei Einfügen/Bearbeiten angezeigt
ShowUsernameInTree | wahr | Datenbank | Der Benutzername wird in Ansicht 'Baumstruktur' angezeigt
ShowPasswordInTree | falsch | Datenbank | Das Passwort wird in Ansicht 'Baumstruktur' angezeigt (Der Benutzername MUSS auch angezeigt werden)
ShowNotesDefault | falsch | Datenbank | Die Notizen werden bei Einfügen/Bearbeiten angezeigt
ShowNotesAsToolTipsInViews | falsch | pwsafe.cfg | Die Notizen eine Eintrages werden als Tip angezeigt in Tabellen- und Baum-Ansicht (nur die ersten 250 Zeichen werden angezeigt)
SortAscending | wahr | Datenbank | Die letzte Sortierrichtung in Ansicht Tabelle (aufsteigend oder abfallend)
UseDefaultUser | falsch | Datenbank | Der Standardtext für den Benutzer wird benutzt beim Einfügen eines neuen Eintrages
SaveImmediately | wahr | Datenbank | Die Datenbank wird gesichert nach jedem Einfügen und Bearbeiten
PWUseLowercase | wahr | Datenbank | Passwortrichtlinie - verwende Kleinbuchstaben
PWUseUppercase | wahr | Datenbank | Passwortrichtlinie - verwende Großbuchstaben
PWUseDigits | wahr | Datenbank | Passwortrichtlinie - verwende Zahlen
PWUseSymbols | wahr | Datenbank | Passwortrichtlinie - verwende Symbole
PWUseHexDigits | falsch | Datenbank | Passwortrichtlinie - generiere ein Passwort mit ausschließlich hexadezimale Zeichen (immer eine gerade Anzahl)
PWUseEasyVision | falsch | Datenbank | Passwortrichtlinie - verwende Easy-Vision (leicht zu lesende) Zeichen, sodass kein Zeichen mit einem anderen verwechselt werden kann (z.B. Nummer 0 (Null) und Buchstabe 0 (Großbuchstabe O) usw.
PWMakePronounceable | falsch | Datenbank | Passwortrichtlinie - konvertiere das generierte Passwort besser aussprechbar
dontaskquestion | falsch | pwsafe.cfg | Keine Bestätigung beim Kopieren des Passwortes in die Zwischanablage
deletequestion | falsch | pwsafe.cfg | Keine Bestätigung beim Löschen eines einzelnen Eintrages
DatabaseClear | falsch | pwsafe.cfg | Sperre die Datenbank beim Minimieren. Dies impliziert ein Löschen der Datenbank im Arbeitsspeicher
QuerySetDef | wahr | pwsafe.cfg | Frage den Benutzer jedesmal beim Einfügen oder Bearbeiten eines Eintrages, ob der Benutzername als Standard fü alle Neueinträge übernommen werden soll
UseNewToolbar | wahr | pwsafe.cfg | Benutze die Moderne oder Klassische Toolleiste
UseSystemTray | wahr | pwsafe.cfg | Stelle ein Password Safe Symbol im Windows Infobereich
LockOnWindowLock | wahr | pwsafe.cfg | Sperre die Password Safe Datenbank wenn der Benutzer die Windows Session sperrt
EscExits | wahr | pwsafe.cfg | Die ESC Taste schließt die Datenbank und beendet Password Safe (wenn der Windows Infobereich nicht benutzt wird)
HotKeyEnabled | falsch | pwsafe.cfg | Wahr wenn der Benutzer ein Hotkey definiert hat um schnell auf Password Safe zuzugreifen
MRUOnFileMenu | wahr | pwsafe.cfg | Die zuletzt benutzten Datenbanken werden im Menu Datei (oder ein Untermenu) angezeigt
MaintainDateTimeStamps | falsch | Datenbank | Der letzte Zugriff auf ein Eintrag wird gespeichert, wenn die Datenbank in Schreibmodus ist
SavePasswordHistory | falsch | Datenbank | Speichere die alten Passwörter eines Eintrages beim Zuweisen eines neuen Passwortes
BackupBeforeEverySave | wahr | pwsafe.cfg | Benenne die aktuelle Datenbank um nach den Sicherungsregeln bevor Änderungen gespeichert werden.
PreExpiryWarn | falsch | pwsafe.cfg | Warne den Benutzer beim Öffnen einer Datenbank falls irgendwelche Einträge abgelaufen sind oder bald ablaufen
ExplorerTypeTree | falsch | pwsafe.cfg | Zeige die Gruppe zuerst an in Baum-Ansicht
ListViewGridLines | falsch | pwsafe.cfg | Zeige Gitterlinien in Tabellen-Ansicht
MinimizeOnAutotype | wahr | pwsafe.cfg | Minimiere Password Safe während Autom. Eingabe. Die Datenbank kann auch gesperrt werden, abhängig von den Einstellungenzum Minimieren
ShowToolbar | wahr | pwsafe.cfg | Ziege die Toolleiste
ShowDragbar | wahr | pwsafe.cfg | Zeige die Dragleiste
ShowFindToolBarOnOpen | wahr | pwsafe.cfg | Zeige die Suchleiste wenn Password Safe startet. Dies wird festgelegt an Hand des Zustandes von Password Safe beim letzten Beenden
DefaultOpenRO | falsch | pwsafe.cfg | Setze standardmäßg auf Nur-Lesen der Datenbank beom Öffnen
MultipleInstances | wahr | pwsafe.cfg | Erlaube mehrere Instanzen von Password Safe. Eine Änderung dieses Wertes wirkt sich erst aus nach einem Neustart von Password Safe
ClearClipboardOnMinimize | wahr | pwsafe.cfg | Lösche die Zwischenablage mit Password Safe Information beim Minimieren
ClearClipboardOnExit | wahr | pwsafe.cfg | Lösche die Zwischenablage mit Password Safe Information beim Beenden
NotesWordWrap | wahr | pwsafe.cfg | Notizen werden umgebrochen in der Anzeige während Einfügen/Bearbeiten
LockDBOnIdleTimeout | wahr | Datenbank | Sperren der Datenbank wenn der Benutzer den PC für eine Anzahl Minuten nicht verwendet hat. Siehe "IdleTimeout" Integer Voreinstellung für den Grenzwert in Minuten
HighlightChanges | wahr | pwsafe.cfg | Hervorheben von geänderte und nicht abgespeicherte Einträge in blau
HideSystemTray | falsch | pwsafe.cfg | Verstecken des Symbol Password Safe im Infobereich. Dies kann nur gesetzt werden, wenn schon der Hotkey gesetzt wurde
UsePrimarySelectionForClipboard | falsch | pwsafe.cfg | Festlegung welche Zwischenablage verwendet wird (nur Linux)
CopyPasswordWhenBrowseToURL | wahr | Datenbank | Kopiere das Passwort vom Eintrag in die Zwischenablage beim Aufruf von "Gehe zu URL"

Numerische Voreinstellungen

Voreinstellung | Standard | Wo gespeichert | Min | Max | Kommentar
column1width | n/a | pwsafe.cfg | n/a | n/a | Die Breite der 1. Spalte in der Ansicht Tabelle beim letzten Beenden von Password Safe
column2width | n/a | pwsafe.cfg | n/a | n/a | Die Breite der 2. Spalte in der Ansicht Tabelle beim letzten Beenden von Password Safe
column3width | n/a | pwsafe.cfg | n/a | n/a | Die Breite der 3. Spalte in der Ansicht Tabelle beim letzten Beenden von Password Safe
column4width | n/a | pwsafe.cfg | n/a | n/a | Die Breite der 4. Spalte in der Ansicht Tabelle beim letzten Beenden von Password Safe
sortedcolumn | 0 | pwsafe.cfg | 0 | 15 | Zuletzt verwendete Spalte um die Ansicht Tabelle zu sortieren
PWDefaultLength | 12 | Datenbank | 4 | 1024 | Standard Passwortlänge
maxmruitems | 4 | pwsafe.cfg | 0 | 20 | Anzahl zuletzt benutzte Datenbanken gesichert im Menu Datei
IdleTimeout | 5 | Datenbank | 1 | 120 | Grenzwert in Minuten um festzulegen wann Password Safe nach inaktiver Zeit gesperrt wird
DoubleClickAction | Kopiere Password | pwsafe.cfg | n/a | n/a | Siehe Hilfe Eintrag DCA Werte Export
HotKey | keine | pwsafe.cfg | n/a | n/a | Wert vom Hotkey
MaxREItems | 25 | pwsafe.cfg | 0 | 25 | Maximum Anzahl "letzte Einträge" zum Speichern in die Datenbank und zur Anzeige im Infobereich, um einen schnelleren Zugriff zu ermöglichen
TreeDisplayStatusAtOpen | AllCollapsed | Datenbank | n/a | n/a | Werte sind: Alles zugeklappt, Alles aufgeklappt oder Wert bei der letzten Sicherung
NumPWHistoryDefault | 3 | Datenbank | 0 | 255 | Wie viele Passwörter werden in der Historie beibehalten
BackupSuffix | 0 | pwsafe.cfg | n/a | n/a | Wete sind: keine, DatumUhrzeit oder eine inkrementelle Nummer
BackupMaxIncremented | 1 | pwsafe.cfg | 1 | 999 | Nur gültig wenn 'BackupSuffix' eine inkrementelle Nummer ist
PreExpiryWarnDays | 1 | pwsafe.cfg | 1 | 30 | Gegebenenfalls warnen wenn Passwörter bald ablaufen
ClosedTrayIconColour | 0 | pwsafe.cfg | 0 | 0 | Stelle die Farbe des Password Safe Symbol einer geschlossenen Datenbank im Infobereich ein: 0 = Schwwarz, 1 - Blau, 2 = Weiß und 3 = Gelb
PWDigitMinLength | 0 | Datenbank | 0 | 1024 | Standard minimal Anzahl Nummern in einem generierten Passwort
PWLowercaseMinLength | 0 | Datenbank | 0 | 1024 | Standard minimal Anzahl Kleinbuchstaben in einem generierten Passwort
PWUppercaseMinLength | 0 | Datenbank | 0 | 1024 | Standard minimal Anzahl Großbuchstaben in einem generierten Passwort
PWSymbolMinLength | 0 | Datenbank | 0 | 1024 | Standard minimal Anzahl Symbole in einem generierten Passwort
OptShortcutColumnWidth | 92 | pwsafe.cfg | 10 | 512 | Größe der Spalten in Verwalten → Optionen → Schnelltasten
ShiftDoubleClickAction | Kopiere Passwort | pwsafe.cfg | n/a | n/a | Siehe Hilfeeintrag in DCA Exportwerte

Textuelle Voreinstellungen

Voreinstellung | Standard | Wo gespeichert | Kommentar
currentbackup | <keine> | pwsafe.cfg | Pfad und Name der letzten Zwischen-Sicherung
currentfile | <keine> | pwsafe.cfg | Aktuel (d.h. zuletzt) geöffnete Datei
lastview | tree | pwsafe.cfg | Letzte ausgewählte Ansicht: Baum oder Tabelle
DefaultUsername | <keine> | Datenbank | Standardwert für den Benutzername beim Erstellen eines neuen Eintrages
treefont | <keine> | pwsafe.cfg | Information über den verwendeten Font in der Baumansicht
PasswordFont | <keine> | pwsafe.cfg | Information über den verwendeten Font um Passwörter anzuzeigen
BackupPrefixValue | <keine> | pwsafe.cfg | Normalerweise wird der Name der aktuellen Datenbank als Vorspann für die Sicherungsdatei verwendet. Mit dieser Auswahl kann das überschrieben werden.
BackupDir | <keine> | pwsafe.cfg | Normalerweise wird die Sicherungsdatei im selben Verzeichnis wie die aktuelle Datenbank abgespeichert. Mit dieser Auswahl kann das überschrieben werden
AltBrowser | <keine> | pwsafe.cfg | Voller Pfad zum alternativen Browser
ListColumns | <keine> | pwsafe.cfg | Nicht-standardmäßige Spaltenreihenfolge in Ansicht Tabelle. Beachten Sie dass die Liste von mit Komma getrennten Werte eine interne Nummernschema folgt, und nicht von Hand geädert werden soll
ColumnWidths | <keine> | pwsafe.cfg | Nicht-standardmäßige Spaltenbreite in Ansicht Tabelle
DefaultAutotypeString | \u\t\p\t\n | Datenbank | Der standardmäßige Satz für die Autom. Eingabe. Beachten Sie dass jeder Eintrag diesen Wert überschreiben kann
AltBrowserCmdLineParms | <keine> | pwsafe.cfg | Spezielle Zeilenparameter für den alternativen Browser, wenn spezifiert
MainToolBarButtons | <keine> | pwsafe.cfg | Eine Liste der Tasten in der Toolleiste und deren Reihenfolge, wie vom Benutzer eingestellt. Ein Trennzeichen sieht so ~ aus
TreeListSampleText | "AaBbYyZz 0O1IlL" | pwsafe.cfg | Beispieltext zur Verwendung bei der Entscheidung welcher Font bei der Baumstruktur verwendet werden soll
PswdSampleText | "AaBbYyZz 0O1IlL" | pwsafe.cfg | Beispieltext zur Verwendung bei der Entscheidung welcher Font bei der Anzeige von Passwörter verwendet werden soll
VKSampleText | "AaBbYyZz 0O1IlL" | pwsafe.cfg | Beispieltext zur Verwendung bei der Entscheidung welcher Font in der virtuellen Tastatur verwendet werden soll
VKeyboardFontName | <keine> | pwsafe.cfg | Name des Unicode Font der verwendet wird um alle Zeichen in der virtuellen Tastatur anzuzeigen. Dies schließt Lateinische und nicht-Lateinische Zeichen ein
LastUsedKeyboard | <keine> | pwsafe.cfg | Speichere den Kode von der zuletzt verwendeten virtuellen Tatatur
AltNotesEditor | <keine> | pwsafe.cfg | Voller Pfadangabe vom Texteditor der beim Editieren vom Notizenfeld (anstelle der standardmäßen Windows-Anwendung)
LanguageFile | <keine> | pwsafe.cfg | Der Kode der zuletzt vom Benutzer eingesetzte Sprachendatei. Es ist wie "LL" oder "LL_CC", wo LL = ISO 639-1 2-Zeichen Sprachenkode z.B.. EN, FR, DE, HE... siehe http://www.loc.gov/standards/iso639-2/ und CC = ISO 3166-1 2-Zeichen Länderkode z.B. US, GB, FR, CA... siehe http://www.iso.org/iso/en/prods-services/iso3166ma/index.html
DefaultSymbols | <keine> | Datenbank | Die Standardliste der Symbole zur Verwendung beim Generieren von Passwörter mit Symbole. Beachten Sie dass jeder Eintrag diesen Wert überschreiben kann


Kommando ausführen

Das Feld Ausführen eines Eintrages enthält ein Kommando. Dieses Kommando wird ausgeführt, wenn der Menüpunkt Ausführen ausgewählt wird. Das Kommando kann alles das enthalten was nach Start->Ausführen am Computer auch eingegeben werden kann.

Zusätzlich kann Password Safe Parameter zum Kommando übergeben, wie da sind: Benutzername, Passwort, usw. So können einigermaßen komplizierte Aktionen programmiert werden, wie z.B. Aufrufen eines Programms über Fernzugriff mit Übergabe von Benutzername und Passwort.

In der Regel werden 'Variablen' ersetzt durch die dazugehörigen Werte, bevor das Kommando dem Computer übergeben wird. Ein Dollarzeichen ('$') kennzeichnet die Variablen.

  • Variablen sind spezifiziert mit '$name' und sie sind case sensitive. Namen von Variablen beginnen immer mit einem alphabetischen Zeichen, gefolgt von alphanumerischen Zeichen. Der Variablenname endet beim nächsten nicht-alphanumerischen Zeichen, oder am Ende des Kommandostrings.
    • Wenn direkt an einem Variablenname ein alphanumerisches Zeichen anschließt, sollte der Variablenname in geschweifte Klammer gesetzt werden. Z.B. '${varname}blabla'.
    • Um das Zeichen '$' in einem normalen Text nicht als Variablenindikator zu verwenden, muss ein umgekehrter Schrägstrich ('\') vorangestellt werden, z.B. '\$text' wird als Text '$text' und nicht als Variable 'text' interpretiert.
    • Um vor dem Zeichen '$' ein umgekehrter Schrägstrich einzusetzen, setzt man ein doppelter ('\\') ein, z.B. aus '\\$name' wird '\$name', und '$name' wird als Variable interpretiert. Ein umgekehrter Schrägstrich ('\'), der nicht zum Zeichen '$' verwendet wird, kann als einzelnes Zeichen dargestellt werden.
    • Eine Variable die von einem numerischen Wert in eckigen Klammern gefolgt wird, wird als Indexwert bezeichnet. Der Indexwert 'n' kann einem '+' oder '-' vorangestellt sein. Es kann z.B. [-2] oder [2] oder [+2] sein. Password Safe behandelt ein Indexwert von Null als das komplette Feld.

  • Folgende Variablen werden momentan erkannt:

    • Bezogen auf die Applikation:
      • appdir Verzeichnis des Programms Password Safe. Siehe Noten 1 und 2 unten.

    • Bezogen auf die aktuelle Datenbank:
      • dbdir | Verzeichnis der aktuell geöffneten Datenbank. Siehe Noten 1 und 2 unten.
fulldb | Pfad, Dateiname und Erweiterung der aktuell geöffneten Datenbank. Siehe Note 2 unten.
dbname | Dateiname der aktuell geöffneten Datenbank.
dbextn | Erweiterung der aktuell geöffneten Datenbank.

    • Bezogen auf den aktuellen Eintrag:
      • g oder group | Gruppe (komplette Struktur von der Wurzel weg, die Gruppen mit Punkte getrennt).
G oder GROUP | Nur die Gruppe die diesen Eintrag enthält.
t oder title | Titel
u oder user | Benutzername
p oder password | Passwort
a oder autotype | Autom. Eingabe. Siehe Note 5 unten.
url | URL
n oder n[0] | Das komplette Feld Notizen (auch: notes oder notes[0]). Siehe Note 3 unten.
n[i] oder notes[i] | ith Zeile im Feld Notizen, beginnend am Anfang. Z.B. i=1 ist die erste Zeile, i=2 ist die zweite Zeile, usw. Siehe Note 4 unten.
n[-i] oder notes[-i] | ith Zeile im Feld Notizen, beginnend am Ende. z.B. i=1 ist die letzte Zeile, i=2 ist die vorletzte Zeile, usw. Siehe Note 4 unten.

      Noten
      1 | Verzeichnisse (appdir oder dbdir) haben kein '\' am Ende. Achten sie darauf wenn sie dies im auszuführenden Kommando brauchen.
      2 | Der Inhalt einer Variablen (sowohl Verzeichnisse als auch ganze Pfade) kann Leerzeichen enthalten. Unter Umständen muss dieser Inhalt in Gänsefüßchen eingeschlossen werden um das auszuführende Kommando auch richtig auszuführen.
      3 | Wenn im Feld Notizen mehr als eine Zeile vorhanden ist, sind auch die Zeichen Wagenrücklauf (CR) und Zeilenvorschub (LF) vorhanden. Dies kann zu Schwierigkeiten führen, wenn CR und/oder LF als 'Enter' interpretiert werden.
      4 | In Einzelzeilen werden sämtliche CR und/oder LF aus dem Feld Notizen entfernt.
      5 Wenn die Variable für Autom.Eingabe vorhanden ist, wird die Autom.Eingabe ausgeführt im Moment wo das Windows Fenster aktiv ist. Die Variable und der Wert (soweit vorhanden) werden entfernt aus dem auszuführenden Kommando. Diese Variable kann beliebig im auszuführenden Kommando stehen, weil es nur definiert was Password Safe tut nach der Ausführung des Kommandos. Im Unterschied zu den anderen Variablen, kann es dadurch den aktuellen Wert im Eintrag übergehen. Das Format ist ($autotype könnte $a ersetzen in den folgenden Beispiele):
      $a | Verwende den Wert des aktuellen Eintrages.
${a} | Verwende den Wert des aktuellen Eintrages (wenn Text direkt an der Variable '$a' anschließt).
$a(Wert) | Verwende den Wert in runden Klammern als Autom.Eingabe.
${a}(Wert) | Verwende den Wert in runden Klammern als Autom.Eingabe.

      Hinweis: Stellen sie sicher das das Kommando gegebenenfalls in Gänsefüßchen eingeschlossen ist. Z.B. wenn das Datenbankverzeichnis Leerzeichen enthält, ist für den Zugriff auf eine Textdatei mit dem Namen der aktuellen Datenbank folgendes notwendig (inkl. Hochkomma):

      '$dbdir\\$dbname.txt'

      Bemerken sie dass der umgekehrter Schrägstrich ('\\') zweimal eingesetzt ist, um '$dbname' als Variable zu erkennen.

      Für Windows werden Umgebungsvariable (definiert als %Variablenname%) normal ersetzt. Z.B., '%windir%\notepad.exe' wird (abhängig von der Installation) in 'C:\Windows\notepad.exe' umgewandelt. Die aktuellen Werte der Umgebungsvariablen können ermittelt werden durch Ausführen von 'cmd.exe' und Absetzen des Befehles 'set' ohne Parameter. Sämtliche unbekannte Umgebungsvariablen bleiben unverändert im auszuführenden Kommando, z.B. %xyz%\notepad.exe bleibt %xyz%\notepad.exe wenn die Variable 'xyz' nicht besteht. Hinweis: Windows Umgebungsvariablen sind nicht case sensitive.

      Beispiel

      Das folgende ausführbare Kommando wird das Program Putty veranlassen eine Verbindung zu myHost zu machen, mit Benutzername und Passwort:

      "C:\Program Files\PuTTY\putty.exe" -ssh ${u}@myHost 22 -pw $p


Schnelltasten

Tastatur Schnelltasten/Beschleunigungstasten

Hier sind die Details und die Einschränkungen für den Einsatz von benutzerdefinierte Tastenkürzel, die Sie mit der Tastatur in Password Safe definieren können, beschrieben.

Die Tastenkombinationen wurden an einer UK-Tastatur mit 102 Tasten getestet. Die Standardzeichen sollten an jeder Tastatur mit Lateinischen Zeichen funktionieren. Einige Tastenkombinationen könnten unterschiedlich zu anderen sein. Z.B. Auf einer UK-Tastatur hat das Zeichen # eine eigene Taste (zusammen mit Tilde ~), aber auf einer US-Tastatur is dies das Zeichen über der 3 (d.h. Umschalt+3). Bitte lesen Sie die Tabelle und wandeln Sie die geeigneten Zeichen für Ihre eigene Tastatur um. Sie können stets ausprobieren ob eine spezifische Tastenkombination für Sie auch funktioniert.

Abhängig von der Sprache, sind bestimmte Alt Tasten reserviert. Diese stimmen mit den Zeichen überein um Punkte im Hauptmenü aufzurufen. Das Drücken der Alt Taste wird diese Zeichen unterstrichen darstellen. Im Englischen Menü sind dies Alt+F (File), Alt+E (Edit), Alt+V (View), Alt+M (Manage) und Alt+H (Help). In anderssprachigen Anwendungen sollten Sie die unterstrichenen Zeichen im Hauptmenü bestimmen, und als reserviert betrachten. Z.B. In der Deutschen Übersetzung wird "File" im Menü in "Datei" umgesetzt, und damit wäre Alt+D reserviert anstelle von Alt+F, usw.

Die Eingabe Taste ist ebenso reserviert, weil sie im Menü Verwalten->Optionen->Schnelltasten als Schnelltaste benutzt wird um den gesetzten Wert zu speichern. Darum kann diese Taste nicht als Schnelltaste für irgendeine Funktion hergenommen werden. Beachten Sie, dass im Modus "Baumstruktur" das Einklappen und Zuklappen der Gruppen mit der Auswahl der Gruppe und der Eingabetaste erreicht werden kann. Dessen ungeachtet, könnte dies zu jede andere gültige Kombination umgesetzt werden, aber die Eingabetaste bleibt weiterhin aktiv, weil es eine Eigenschaft der Prozedur für die Baumstruktur ist. Darum kann auch diese Funktion im Optionsmenü für die Schnelltasten nicht abgeändert werden.

Die Escape Taste ist reserviert, weil sie zum Schliessen des Suchfeldes oder zum Minimieren von Password Safe im Infobereich benutzt wird. Diese Taste ist in jedem Dialog auch equivalent zu "Abbrechen".

Konzeptionell ist die Tastenkombination zum Anschauen eines Eintrages in NUR-Lesen-Modus und zum Bearbeiten eines Eintrages im Schreib-Lese-Modus identisch. Sie können nicht getrennt gesetzt werden. Genau so verhält es sich auch mit den Kombinationen für "Eintrag löschen" bzw. "Gruppe löschen" und "Eintrag umbenennen" bzw. "Gruppe umbenennen". Sie werden darum im Menü "Schnelltasten" nur als "Löschen" und "Umbenennen" dargestellt.

Einige Tasten sind von Windows selber reserviert - z.B. Strg+Alt+Löschen; Tab; Umschalt+Tab; Alt+Tab; Alt+Umschalt+Tab usw.

Nicht-standardmäßige Tasten werden nicht unterstützt (z.B. die Tasten die nur an einer Kanji Tastatur vorkommen).

Password Safe kann keine Unterscheidung zwischen der linke und der rechte Alt, Strg und Umschalt Taste machen. Dies kann dazu führen, dass einige Kombinationen an bestimmte Tastaturen nicht zur Vefügung stehen. Z.B. Das Euro Symbol "€" ist auf einer UK-102-Tastatur die rechte Alt (Alt-Gr) und die Taste 4. Allerdings bringt das Drücken dieser Kombination die Kombination Strg+Alt+4 hervor. Dies liegt an der Art wie Microsoft die Schnelltasten abarbeitet, und ist keine Einschränkung von Password Safe.

Hinweis: Das Setzen von nicht-standardmäßige Kombinationen kann dazu führen dass diese Kombinationen an einem anderen Computer mit einer anderen Tastatur nicht dargestellt werden können. Es wird empfohlen nur Kombinationen aus der unten stehenden Liste zu entnehmen.

In der unterstehenden Tabelle bedeuten die Kürzel in den Spaltenköpfe folgendes:

Spaltenkopf | meint Drücken
T | Nur die Taste
A+T | Die Taste zusammen mit der Alt Taste
S+T | Die Taste zusammen mit der Strg Taste
U+T | Die Taste zusammen mit der Umschalt Taste
A+U+T | Die Taste zusammen mit der Alt und Umschalt Taste
S+U+T | Die Taste zusammen mit der Strg und Umschalt Taste
A+S+T | Die Taste zusammen mit der Alt und Strg Taste
A+S+U+T | Die Taste zusammen mit der Alt, Strg und Umschalt Taste

Tastenname | T | A+T | S+T | U+T | A+U+T | S+U+T | A+S+T | A+S+U+T
Rücktaste | J | N | J | J | N | J | J | J
Tab | N | N | J | N | N | J | J | J
Eingabe | R (1) | N | J | N | N | J | J | J
Escape | N | N | N | N | N | N | N | N
Leer | J | N | J | J | N | J | J | J
Bild rauf | J | J | N | J | J | N | N | N
Bild runter | J | J | N | J | J | N | N | N
Ende | J | J | J | J | J | J | J | J
Pos1 | J | J | J | J | J | J | J | J
Pfeil links | J | J | J | J | J | J | J | J
Pfeil rauf | J | J | J | J | J | J | J | J
Pfeil rechts | J | J | J | J | J | J | J | J
Pfeil runter | J | J | J | J | J | J | J | J
Druck | N | N | N | N | N | N | N | N
Einfügen | J | J | J | J | J | J | J | J
Entfernen | J | N | J | J | N | J | N | J
0-9 | J | J | J | J | J | J | J | J
A-Z | J | J | R (2) | J | J | J | J | J
Num. Block 0-9 | J | J | J | N | J | N | J | N
Num. Block * | J | J | J | J | J | J | J | J
Num. Block + | J | J | J | J | J | J | J | J
Num. Block - | J | J | J | J | J | J | J | J
Num. Block . | J | J | J | N | N | N | N | N
Num. Block / | J | J | J | J | J | J | J | J
F1 | R (3) | J | J | J | J | J | J | J
F2 | J | J | J | J | J | J | J | J
F3 | J | J | J | J | J | J | J | J
F4 | J | R (2) | J | J | J | J | J | J
F5 | J | J | J | J | J | J | J | J
F6 | J | J | J | J | J | J | J | J
F7 | J | J | J | J | J | J | J | J
F8 | J | J | J | J | J | J | J | J
F9 | J | J | J | J | J | J | J | J
F10 | J | J | J | J | J | J | J | J
F11 | J | J | J | J | J | J | J | J
F12 | J | J | J | J | J | J | J | J
Num Lock | J | J | N | J | N | J | J | J
Rollen | J | J | J | J | J | J | J | J
; : (4) | J | J | J | J | J | J | J | J
+ = | J | J | J | J | J | J | J | J
, < | J | J | J | J | J | J | J | J
- _ | J | J | J | J | J | J | J | J
. > | J | J | J | J | J | J | J | J
/ ? (4) | J | J | J | J | J | J | J | J
# ~ (4) | J | J | J | J | J | J | J | J
[ { (4) | J | J | J | J | J | J | J | J
\ | (4) | J | J | J | J | J | J | J | J
] } (4) | J | J | J | J | J | J | J | J
' @ (4) | J | J | J | J | J | J | J | J
` ¬ (4) | J | J | J | J | J | J | J | J

Notizen:

  1. Weil die Eingabe Taste für das Setzen der Schnelltasten verwendet wird, kann sie nicht zum Setzen anderer Funktionen eingesetzt werden.

  2. Strg+Q und Alt+F4 sind für das Verlassen der Anwendung Password Safe vorgesehen.

  3. F1 ist für die Hilfe reserviert.

  4. Dies kann abhängig von der Tastatur sein.


Eintrag Symbole

Folgende Symbole werden angewendet um den Typ eines Eintrags in der Baumstruktur oder Listenanzeige aufzuzeigen.
Hinweis: diese Symbole werden in der Baumstruktur immer angezeigt. In der Listenanzeige, kann die Symbol-Spalte wohl oder nicht angezeigt werden mit Hilfe des Spaltenpflückers, aber immer nur in Spalte 1.

Knoten oder Gruppe [nur Baumstruktur]

Normaler Eintrag

Normaler Eintrag mit Alias

Normaler Eintrag mit Verknüpfung

Alias

Verknüpfung

Zusätzlich kann ein Eintrag ein Ablaufdatum für das Passwort besitzen. Wenn der Benutzer ein Warnintervall von z.B. 5 Tage angibt bis das Passwort abläuft, zeigt sich das Bild halb in Lila.

Normaler Eintrag - das Passwort läuft im vom Benutzer festgelegten Intervall ab

Normaler Eintrag mit Alias - das Passwort läuft im vom Benutzer festgelegten Intervall ab

Normaler Eintrag mit Verknüpfung - das Passwort läuft im vom Benutzer festgelegten Intervall ab

Einmal abgelaufen, wird das Bild ganz Lila.

Normaler Eintrag - das Passwort ist abgelaufen

Normaler Eintrag mit Alias - das Passwort ist abgelaufen

Normaler Eintrag mit Verknüpfung - das Passwort ist abgelaufen


Danksagung

Programm Danksagung

Herzlichen Dank an Bruce Schneier für das Erschaffen des Twofish Algorithmus und für die Freigabe von Password Safe an die Allgemeinheit, und an SourceForge.net für das Hosting des Projektes und Unterstützung der Open Source Gemeinschaft.
Password Safe verwendet ab Version 3.06 TinyXML zum Parsen der Konfigurationsdatei dieser Anwendung. Der Kode für TinyXML wird unter der zlib license zur Verfügung gestellt.
Password Safe verwendet ab Version 3.12 einen Algorithmus erstellt von Tom Van Vleck, Morrie Gasser und Dan Edwards, um aussprechbare Passwörter zu generieren.

Die folgenden Links führen zu verschiedene Seiten auf der SourceForge WEB Seite die sich auf das Password Safe Projekt beziehen:

  • Password Safe Home Page: Information und Neuigkeiten über Password Safe als auch Ankündigungen zum Status und neue Ausgaben. Die Home Page wird von Brad Chance gepflegt. Danke!
  • Entwicklungsteam: einige der Leute die bei der Entwicklung mitgemacht haben und dabei helfen Password Safe am Leben zu erhalten.
  • Password Safe Forum: Ein Forum für Fragen, Unterstützung und Probleme.
  • Password Safe News: RSS feeds verfügbar für dieses Projekt.
  • Seite für die Mailingliste von Password Safe, niedriges Aufkommen (ungefähr eine Meldung pro Monat oder so), Spam freie Seite für Ankündigungen und Mailingliste.


Erweiterte Feldauswahl Kriterien

Mit dem Assistenten wä Vergleich, Zusammenführen, Synchronisieren und Exportieren zu Text/XML

When selected via the "Wizard Select Database or File" page, you will be given the option to restrict the Compare, Merge, Synchronize or Export based on your selected criteria. You will also be able to restrict which fields are Compared, Synchronized or Exported.

The criteria specified here for a particular function are remembered for this Password session and are independent of each other. If you close and exit Password Safe and then restart it, they will be reset to 'no restrictions' and the corresponding default fields for these functions.

Should you specify any restrictions or field selection but do not want to use them this time, then press the Back button and uncheck the "Advanced field selection criteria" on the "Wizard Select Database or File" page. The values you have specified for the "Advanced field selection criteria" will still remain but will not be used.

If you wish to reset these values to the default for the function, press the Reset button. Resetting the values for, say, Compare will not reset the values for the other functions supported e.g. Merge, Synchronize or Export.

Via the Find Toolbar Button

When selected via the Advanced button on the Find Toolbar, you will be given the option to restrict the search based on your selected criteria. You will also be able to restrict which fields are examined.

The criteria specified here for a search are remembered for this Password session and are independent of those mentioned above. If you close and exit Password Safe and then restart it, they will be reset to 'no restrictions' and the corresponding default fields for a search.

Should you specify any restrictions or field selection but do not want to use them this time, then either press the Cancel button or press the OK button and uncheck the Advanced button on the Find Toolbar. The values you have specified for the "Advanced field selection criteria" will still remain but will not be used.

If you wish to reset these values to the default for search, press the Reset button. Resetting the search values will not reset the values for the other functions mentioned above.

Synchronizing entries when reviewing the Compare Databases results

After comparing two databases, if they are not identical, a Compare Results dialog is displayed. By right clicking on the 'Y' is the relevant column, a context menu is displayed. For entries in the current database, the only allowed option is to directly Edit (View if the database was opened in read-only mode) this entry. For entries in the comparison database, the options are View, Copy to the original database and Synchronize.

If Synchronize is chosen, then a small Advanced dialog is display allowing the user to select which fields to synchronize.

The criteria specified here for a particular function are remembered for this Password session and are independent of each other. If you close and exit Password Safe and then restart it, they will be reset to the corresponding default fields for these functions.


Benannte Passwortrichtlinie

Anmerkung: Teile in blau sind (noch) nicht aus dem Englischen übersetzt.

Seit PasswordSafe V3.28 kann man Benannte Passwortrichtlinien erzeugen und bearbeiten mit dem Menü "Verwalten → Passwortrichtlinien...". Diese sind datenbankspezifisch und werden im Kopf der Datenbank abgespeichert. Dieses Menü ersetzt auch den Reiter zum Setzen der Datenbankstandardwerte im Menü "Verwalten → Optionen".

Dialog benannte Passwortrichtlinie

Mit diesem Dialog können Sie die aktuelle standardmäßige Passwortrichtlinie bearbeiten und neue benannte Passwortrichtlinien hinzufügen, bearbeiten und löschen. Vorsicht, es ist nicht möglich eine benannte Passwortrichtlinie zu löschen, solange mindestens ein Eintrag in der Datenbank diese verwendet. Nach der Auswahl einer Richtlinie sieht man im unteren Feld die dazugehörigen Details. Ebenso ist es möglich eine Liste der Einträge die diese Richtlinie verwenden zu sehen, mit einem Klick auf die Taste Liste. Zurück geht es mit einem Klick auf die Taste Details. Wenn die Liste der Einträge angezeigt wird, kommt man mit einem Doppelklick auf einem Eintrag zum Bearbeiten / Anzeigen dieses Eintrages.

Ändern der Standardwerte für die Passwortrichtlinie

Wenn die standard Passwortrichtlinie ausgewählt ist, benutzt man die Taste Bearbeiten um die Werte zu ändern. Der nachstehender Dialog wird angezeigt (er ersetzt die frühere Funktion im Menü "Verwalten → Optionen"). Weil diese Werte in der Datenbank abgespeichert sind, werden die Beschreibungen der Felder blau dargestellt.

Edit database default password Policy dialog

Eine neue benannte Passwortrichtlinie hinzufügen

Durch Betätigen der Taste Neu wird nachstehender Dialog aufgemacht, um ein neue benannte Passwortrichtlinie hinzuzufügen. Die Initialwerte werden von der standardmäßigen Passwortrichtlinie übernommen. Zusätzlich zu den normalen Überprüfungen zur Konsistenz der eingegeben Informationen, muss außerdem eine eindeutiger Name (innerhalb der Datenbank) vergeben werden. Hinweis: der Name darf nicht länger sein als 255 Zeichen.

Add a named password policies dialog

Eine bestehende benannte Passwortrichtlinie bearbeiten

Wenn eine benannte Passwortrichtlinie ausgewählt ist, benutzt man die Taste Bearbeiten um dessen Werte zu ändern. Der Name dieser benannten Passwortrichtlinie kann hierbei nicht verändert werden.

Edit a named password policies dialog

Bearbeiten / Einfügen eines Eintrages und Passowrt erzeugen

Die Funktionen Bearbeiten / Einfügen eines Eintrages und "Verwalten → Generiere Passwort" wurden beide erweitert um einen Eintrag die Benutzung einer benannten Richtlinie zu erlauben oder um das Generieren eines zufälligen Passwortes mithilfe einer benannten Richtlinie zu ermöglichen. Ein Grund unbenutzte benannte Richtlinien zu behalten wäre es, sie ausschließlich zum Generieren von Passwörtern einzusetzen.

Testen einer Passwortrichtlinie

Sie können die standardmäßige oder eine der benannten Passwortrichtlinien auswählen und die Taste Generiere drücken, um ein Passwort mit dieser Richlinie zu generieren. Dieses Passwort kann auch in die Zwischenablage kopiert werden.

Nur-Lesen Datenbanken

Wenn die Datenbank im Modus Nur-Lesen ist, kann man keine neue benannte Passwortrichtlinie generieren, die standardmäßige oder eine benannte Passwortrichtlinie bearbeiten und keine unbenutzte benannte Passwortrichtlinie löschen. Eine Ansicht der standardmäßigen und der benannten Passwortrichtlinien ist jedoch möglich. Etwaige Änderungen an den Passwortrichtlinien während der Ansicht werden aber nicht abgespeichert.

Rückgängig / Wiederholen

Sie können die Tasten Rückgängig und Wiederholen (oder die Standards Strg+Z und Strg+Y [oder die Equivalente, die sie mit "Verwalten → Optionen → Schnelltasten" verändert haben]) benutzen um Änderungen in diesem Dialog rückgängig zu machen, z.B. geänderte Werte in der standardmäßigen oder einer benannten Passwortrichtlinie, hinzufügen oder Löschen einer neuen bzw. unbenutzten Passwortrichtlinie. Wenn ein Änderung rückgängig gemacht wurde, können Sie das mit Wiederholen zurücksetzen, allerdings nur solange keine andere Änderung vorgenommen wurde. Änderungen werden erst nach Drücken der Taste OK -um den Dialog zu verlassen- in die Datenbank übernommen.

XML und Text Import/Export

When a database is exported to XML (whether it is a specific subset of the entries in the database or the whole database), all the Named Password Policies in the current database are also exported. During the subsequent import of that XNL file, all the Named Pasword Policies are also imported into the current database. If a Named Password Policy of the same name already exists in the current database and it has the same policy settings as that being imported, then it will be used by any entries referencing it when they are imported. However, if the imported Named Password Policy has different policy settings to that in the database with the same name, then the policy will be imported with the words "Imported - datetime" appended to its name (where the 'datetime' is the date/time of the Import) and all imported entries refering to it will now reference the newly named policy.

When importing a XML file, if the any record references a Named Password Policy that does not exist in the current database (or in the XML file being imported), then the entry will be changed to use the current database default policy. Warning messages will be placed in the Import log show which entries have been affected.

When exporting to a Text file, the name of of any referenced Named Password Policy is also exported. However, there is no facility to also export the values contained in these Named Password Policies.

Due to the above restriction, when importing a Text file, if the any record references a Named Password Policy that does not exist in the current database, then the entry will be changed to use the current database default policy. Warning messages will be placed in the Import log show which entries have been affected.

Zusammenführen und Drag & Drop

When a whole or subset of a database is merged into the current database, any Named Password Policy referenced by the entries being merged will be brought across from the source database. If a Named Password Policy of the same name already exists in the current database and it has the same policy settings as that being copied across, then it will be used by any entries referencing is are merged. However, if the imported Named Password Policy has different policy settings to that in the database with the same name, then it will be imported with the word "Merged - datetime" appended to its name (where the 'datetime' is the date/time of the Merge) and all entries refering to it will now reference the newly named policy.

Similarly, when one or more entries are dragged from another database and dropped into the current database except "Drag - datetime" will be used to make the Named Password Policy unique.


Assistent Beenden

Während die ausgewähte Funktion (Vergleich, Zusammenführen, Synchronisieren oder Exportieren) läuft, wird diese Seite entweder die benutzte Datenbank ( Vergleich, Zusammenführen und Synchronisieren) oder die zu schreibende Datei (Export zu Text oder XML) anzeigen. Auch wird der gerade in Bearbeitung befindlicher Eintrag (in der Form «Gruppe» «Titel» «Benutzername») angezeigt. Während dieses Vorganges ist weder "Ansicht Berichte" noch "Beenden" freigegeben.

Einmal fertig, können Sie den Bericht anschauen und/oder den Assistenten verlassen. Im Menu Ansicht können sie auf Festplatte abspeichern (im selben Verzeichnis wie die Datenbank) und/oder den Inhalt in die Zwischenablage ablegen. Wenn auf Festplatte abgespeichert, können Sie es nochmal anschauen mit "Ansicht → Berichte". Es sei bemerkt dass beim Abspeichern auf Festplatte jeder vorheriger Bericht zur gleichen Funktion in diesem Verzeichnis überschrieben wird. Hinweis: Der Bericht kann sensible Daten enthalten, so Vorsicht ist geboten beim Abspeichern auf die Festplatte.


Assistent zur Auswahl einer Datenbank oder Datei

Vergleich, Zusammenführen oder Synchronisieren

Wenn Sie die Datenbank vergleichen, zusammenführen oder synchronisieren, müssen Sie den Namen der Datenbank bereitstellen mit der Sie vergleichen, zusammenführen oder sychonisieren wollen.

Das verlangte Passwort ist das der neuen Datenbank, und nicht das der bereits ge/ouml;ffneten Datenbank.

Export zu Text oder XML

Beim Ausführem eines Export der aktuellen Datenbank zu Text oder XML, müssen sie den Namen der zu erzeugende Datei bereitstellen. Wenn die angegebene Datei schon besteht, werden Sie um einer Bestätigung zum Überschreiben gefragt.

Das verlangte Passwort ist das der aktuell geöffneten Datenbank.

Sie sollten auch das Trennzeichen zum Darstellen eines Zeilenumbruch im Notizenfeld definieren, sodass es beim Importieren richtig verarbeitet werden kann. Wenn Sie zu Text exportieren wird dieses Zeichen auch dazu verwendet den Punkt (.) im Titel zu ersetzen, sodass beim Importieren die richtige Struktur wieder aufgebaut werden kann (Bemerkung: der Punkt wird dazu verwendet Gruppen zu trennen).

Erweitertes Feld für Auswahlkriterien

Sie haben in jedem Falle die Wahl "Erweitertes Feld für Auswahlkriterien" auszuwählen. Diese Seite erlaubt es Einschränkungen zu definieren basierend sowohl auf den Inhalt der Felder Gruppe, Titel, Benutzername, URL oder Notizen als auch auf die Felder zum Vergleichen, Zusammenführen oder Synchronisieren.

Die Auswahl von 'Zurück' bringt Sie zurück zur ersten Seite des Assistenten, wo Sie die Auswahl "Erweitertes Feld für Auswahlkriterien" rücksetzen können. Dann werden alle Einträge und alle zugehörige Felder.

Hinweis 1: Wenn Sie ein einzelner Eintrag exportieren mit dem Menu Bearbeiten oder mit der rechten Maustaste, steht die Option zur Einschräng beim Export nicht zur Verfüng.

Hinweis 2: Beim Zusammenführen einer Datenbank mit der aktuel geöffneten Datenbank gibt es keine Möglichkeit die Zusammenstellung der Felder zu beeinflüssen. Wenn ein Eintrag den Auswahlkriterien entspricht, wird der komplette Eintrag mit der aktuel geöffneten Datenbank zusammengeführt.